%global _empty_manifest_terminate_build 0
Name: python-graphene-tornado
Version: 2.6.1
Release: 1
Summary: Graphene Tornado integration
License: MIT
URL: https://github.com/graphql-python/graphene-tornado
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/41/e4/85471712288567a34ffd8d422deed8da9404ea38d1ff74d2f5624747a5e1/graphene-tornado-2.6.1.tar.gz
BuildArch: noarch
Requires: python3-six
Requires: python3-graphene
Requires: python3-Jinja2
Requires: python3-tornado
Requires: python3-werkzeug
Requires: python3-json-stable-stringify-python
Requires: python3-protobuf
Requires: python3-tornado-retry-client
Requires: python3-opencensus
Requires: python3-coveralls
Requires: python3-mock
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-pytest-tornado
Requires: python3-tox
%description
A project for running `Graphene `__ on top
of `Tornado `__ in Python 2 and 3. The
codebase is a port of
`graphene-django `__.
%package -n python3-graphene-tornado
Summary: Graphene Tornado integration
Provides: python-graphene-tornado
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-graphene-tornado
A project for running `Graphene `__ on top
of `Tornado `__ in Python 2 and 3. The
codebase is a port of
`graphene-django `__.
%package help
Summary: Development documents and examples for graphene-tornado
Provides: python3-graphene-tornado-doc
%description help
A project for running `Graphene `__ on top
of `Tornado `__ in Python 2 and 3. The
codebase is a port of
`graphene-django `__.
%prep
%autosetup -n graphene-tornado-2.6.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-graphene-tornado -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 2.6.1-1
- Package Spec generated