%global _empty_manifest_terminate_build 0
Name: python-MoNeT-MGDrivE
Version: 0.9.0.2
Release: 1
Summary: MoNeT python package for MGDrivE data analysis
License: MIT
URL: https://github.com/Chipdelmal/MoNeT_MGDrivE
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f6/be/1f4438ca67775b63fc35ffdd3ade0a563c7edbd8c3b642e1297b1f97eb58/MoNeT_MGDrivE-0.9.0.2.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-scipy
Requires: python3-matplotlib
Requires: python3-ipython
Requires: python3-jupyter
Requires: python3-pandas
Requires: python3-sympy
Requires: python3-compress-pickle
Requires: python3-joblib
Requires: python3-more-itertools
%description
This module was created to accompany the [MGDrivE](https://marshalllab.github.io/MGDrivE/) and [MoNeT](https://chipdelmal.github.io/MoNeT/) projects to make the analysis of the spatiotemporal simulations of gene-drive spreads as seamless as possible.
It is also meant to serve as a platform to ensure the reproducibility of results of the publications from our [research group at UC, Berkeley](https://www.marshalllab.com/), as part of [DARPA's: Safe Genes program](https://www.darpa.mil/program/safe-genes) and [UCI Malaria Initiative](http://malaria.bio.uci.edu/).
## Project Status
Our code has been used and tested in several [MGDrivE](https://marshalllab.github.io/MGDrivE/) publications. For some examples of how this package is being currently used, please follow this [link](https://chipdelmal.github.io/MoNeT/Berkeley.html).
## Installation
To install from pypi with pip:
```bash
pip install MoNeT-MGDrivE
```
## Authors
* __Lead__: [Héctor M. Sánchez C](https://chipdelmal.github.io/)
* __Former Dev__: Chris De León, Priscilla Zhang, Sabrina Wong, Sarafina Smith, Víctor Ferman, Biyonka Liang, Gillian Chu, Maya Shen
* __PI__: [John M. Marshall](https://www.marshalllab.com/)
%package -n python3-MoNeT-MGDrivE
Summary: MoNeT python package for MGDrivE data analysis
Provides: python-MoNeT-MGDrivE
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-MoNeT-MGDrivE
This module was created to accompany the [MGDrivE](https://marshalllab.github.io/MGDrivE/) and [MoNeT](https://chipdelmal.github.io/MoNeT/) projects to make the analysis of the spatiotemporal simulations of gene-drive spreads as seamless as possible.
It is also meant to serve as a platform to ensure the reproducibility of results of the publications from our [research group at UC, Berkeley](https://www.marshalllab.com/), as part of [DARPA's: Safe Genes program](https://www.darpa.mil/program/safe-genes) and [UCI Malaria Initiative](http://malaria.bio.uci.edu/).
## Project Status
Our code has been used and tested in several [MGDrivE](https://marshalllab.github.io/MGDrivE/) publications. For some examples of how this package is being currently used, please follow this [link](https://chipdelmal.github.io/MoNeT/Berkeley.html).
## Installation
To install from pypi with pip:
```bash
pip install MoNeT-MGDrivE
```
## Authors
* __Lead__: [Héctor M. Sánchez C](https://chipdelmal.github.io/)
* __Former Dev__: Chris De León, Priscilla Zhang, Sabrina Wong, Sarafina Smith, Víctor Ferman, Biyonka Liang, Gillian Chu, Maya Shen
* __PI__: [John M. Marshall](https://www.marshalllab.com/)
%package help
Summary: Development documents and examples for MoNeT-MGDrivE
Provides: python3-MoNeT-MGDrivE-doc
%description help
This module was created to accompany the [MGDrivE](https://marshalllab.github.io/MGDrivE/) and [MoNeT](https://chipdelmal.github.io/MoNeT/) projects to make the analysis of the spatiotemporal simulations of gene-drive spreads as seamless as possible.
It is also meant to serve as a platform to ensure the reproducibility of results of the publications from our [research group at UC, Berkeley](https://www.marshalllab.com/), as part of [DARPA's: Safe Genes program](https://www.darpa.mil/program/safe-genes) and [UCI Malaria Initiative](http://malaria.bio.uci.edu/).
## Project Status
Our code has been used and tested in several [MGDrivE](https://marshalllab.github.io/MGDrivE/) publications. For some examples of how this package is being currently used, please follow this [link](https://chipdelmal.github.io/MoNeT/Berkeley.html).
## Installation
To install from pypi with pip:
```bash
pip install MoNeT-MGDrivE
```
## Authors
* __Lead__: [Héctor M. Sánchez C](https://chipdelmal.github.io/)
* __Former Dev__: Chris De León, Priscilla Zhang, Sabrina Wong, Sarafina Smith, Víctor Ferman, Biyonka Liang, Gillian Chu, Maya Shen
* __PI__: [John M. Marshall](https://www.marshalllab.com/)
%prep
%autosetup -n MoNeT-MGDrivE-0.9.0.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-MoNeT-MGDrivE -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.9.0.2-1
- Package Spec generated