%global _empty_manifest_terminate_build 0
Name: python-blackerz-wrapper
Version: 0.0.256
Release: 1
Summary: Developer kit to interact with our API
License: MIT License
URL: https://github.com/Fastering18/Blackerz-Wrapper-Python
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c7/8a/572c72e526c9dbbfc929d2ae380f0ccfbda920d80c8cef2256d1a2bce36f/blackerz-wrapper-0.0.256.tar.gz
BuildArch: noarch
Requires: python3-requests
%description
# Python Blackerz API-Wrapper 
Python SDK for interact with our API
__Example Post Bot Description__
```py
import blackerz_wrapper as blackerz
blackerz.authorize("V1auth")
goblox = blackerz.bot("bot_id")
bot_data = goblox.bot_data()
print(bot_data)
result = goblox.edit_data(short_description="generated_by_python_lib")
print(result) # boolean indicates success or not
print(goblox.check_vote("775363892167573535")) # check if userid 775363892167573535 voted the bot
```
## Website
Get your **V1 auth** by login to our website then visit your profile, here the link
https://blackerz.herokuapp.com/
Made by Fastering18, join our support server https://discord.gg/t7zJBwynFU for more information.
%package -n python3-blackerz-wrapper
Summary: Developer kit to interact with our API
Provides: python-blackerz-wrapper
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-blackerz-wrapper
# Python Blackerz API-Wrapper 
Python SDK for interact with our API
__Example Post Bot Description__
```py
import blackerz_wrapper as blackerz
blackerz.authorize("V1auth")
goblox = blackerz.bot("bot_id")
bot_data = goblox.bot_data()
print(bot_data)
result = goblox.edit_data(short_description="generated_by_python_lib")
print(result) # boolean indicates success or not
print(goblox.check_vote("775363892167573535")) # check if userid 775363892167573535 voted the bot
```
## Website
Get your **V1 auth** by login to our website then visit your profile, here the link
https://blackerz.herokuapp.com/
Made by Fastering18, join our support server https://discord.gg/t7zJBwynFU for more information.
%package help
Summary: Development documents and examples for blackerz-wrapper
Provides: python3-blackerz-wrapper-doc
%description help
# Python Blackerz API-Wrapper 
Python SDK for interact with our API
__Example Post Bot Description__
```py
import blackerz_wrapper as blackerz
blackerz.authorize("V1auth")
goblox = blackerz.bot("bot_id")
bot_data = goblox.bot_data()
print(bot_data)
result = goblox.edit_data(short_description="generated_by_python_lib")
print(result) # boolean indicates success or not
print(goblox.check_vote("775363892167573535")) # check if userid 775363892167573535 voted the bot
```
## Website
Get your **V1 auth** by login to our website then visit your profile, here the link
https://blackerz.herokuapp.com/
Made by Fastering18, join our support server https://discord.gg/t7zJBwynFU for more information.
%prep
%autosetup -n blackerz-wrapper-0.0.256
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-blackerz-wrapper -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.0.256-1
- Package Spec generated