%global _empty_manifest_terminate_build 0
Name:		python-iglovikov-helper-functions
Version:	0.0.53
Release:	1
Summary:	Unstructured set of the helper functions.
License:	MIT
URL:		https://github.com/ternaus/iglovikov_helper_functions
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/34/c4/6fe712dfce6ee22472f605ac792f70e276fa51a8dc14cb7fb18c56f85774/iglovikov_helper_functions-0.0.53.tar.gz
BuildArch:	noarch

Requires:	python3-addict
Requires:	python3-imagecorruptions
Requires:	python3-joblib
Requires:	python3-jpeg4py
Requires:	python3-numpy
Requires:	python3-opencv-python
Requires:	python3-pandas
Requires:	python3-Pillow
Requires:	python3-scikit-image
Requires:	python3-scikit-learn
Requires:	python3-scipy
Requires:	python3-torch
Requires:	python3-pytest

%description
[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/ambv/black)

[![DeepSource](https://static.deepsource.io/deepsource-badge-light.svg)](https://deepsource.io/gh/ternaus/iglovikov_helper_functions/?ref=repository-badge)
# An unstructured set of helper functions.

## Installation

`pip install -U iglovikov_helper_functions`

`pip install git+https://github.com/ternaus/iglovikov_helper_functions`




%package -n python3-iglovikov-helper-functions
Summary:	Unstructured set of the helper functions.
Provides:	python-iglovikov-helper-functions
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-iglovikov-helper-functions
[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/ambv/black)

[![DeepSource](https://static.deepsource.io/deepsource-badge-light.svg)](https://deepsource.io/gh/ternaus/iglovikov_helper_functions/?ref=repository-badge)
# An unstructured set of helper functions.

## Installation

`pip install -U iglovikov_helper_functions`

`pip install git+https://github.com/ternaus/iglovikov_helper_functions`




%package help
Summary:	Development documents and examples for iglovikov-helper-functions
Provides:	python3-iglovikov-helper-functions-doc
%description help
[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/ambv/black)

[![DeepSource](https://static.deepsource.io/deepsource-badge-light.svg)](https://deepsource.io/gh/ternaus/iglovikov_helper_functions/?ref=repository-badge)
# An unstructured set of helper functions.

## Installation

`pip install -U iglovikov_helper_functions`

`pip install git+https://github.com/ternaus/iglovikov_helper_functions`




%prep
%autosetup -n iglovikov-helper-functions-0.0.53

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-iglovikov-helper-functions -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.53-1
- Package Spec generated