%global _empty_manifest_terminate_build 0
Name: python-AaronTools
Version: 1.0b18
Release: 1
Summary: Tools for measuring and manipulating molecular structures
License: GNU General Public License v3 (GPLv3)
URL: https://github.com/QChASM/AaronTools.py
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/91/fb/099fc930d9aac8ddf437fe5752bc0b6e73cb4d71ac192a3b859d0610d50a/AaronTools-1.0b18.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-scipy
Requires: python3-pdfminer
Requires: python3-jinja2
Requires: python3-matplotlib
%description
# AaronTools.py
AaronTools provides a collection of tools for automating routine tasks encountered when running quantum chemistry computations.
These tools can be used either directly within a Python script using AaronTools objects, or via a series of command-line scripts.
See the Wiki for installation and usage.
AaronTools is described in
"QChASM: Quantum Chemistry Automation and Structure Manipulation" WIREs Comp. Mol. Sci. 11, e1510 (2021).
A Perl implementation of AaronTools is also available here.
However, users are strongly urged to use the Python version since it has far more powerful features and, unlike the Perl version, will continue to be developed and supported.
## Citation
If you use the Python AaronTools, please cite:
V. M. Ingman, A. J. Schaefer, L. R. Andreola, and S. E. Wheeler "QChASM: Quantum Chemistry Automation and Structure Manipulation" WIREs Comp. Mol. Sci. 11, e1510 (2021)
## Contact
If you have any questions or would like to discuss bugs or additional needed features, feel free to contact us at qchasm@uga.edu
%package -n python3-AaronTools
Summary: Tools for measuring and manipulating molecular structures
Provides: python-AaronTools
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-AaronTools
# AaronTools.py
AaronTools provides a collection of tools for automating routine tasks encountered when running quantum chemistry computations.
These tools can be used either directly within a Python script using AaronTools objects, or via a series of command-line scripts.
See the Wiki for installation and usage.
AaronTools is described in
"QChASM: Quantum Chemistry Automation and Structure Manipulation" WIREs Comp. Mol. Sci. 11, e1510 (2021).
A Perl implementation of AaronTools is also available here.
However, users are strongly urged to use the Python version since it has far more powerful features and, unlike the Perl version, will continue to be developed and supported.
## Citation
If you use the Python AaronTools, please cite:
V. M. Ingman, A. J. Schaefer, L. R. Andreola, and S. E. Wheeler "QChASM: Quantum Chemistry Automation and Structure Manipulation" WIREs Comp. Mol. Sci. 11, e1510 (2021)
## Contact
If you have any questions or would like to discuss bugs or additional needed features, feel free to contact us at qchasm@uga.edu
%package help
Summary: Development documents and examples for AaronTools
Provides: python3-AaronTools-doc
%description help
# AaronTools.py
AaronTools provides a collection of tools for automating routine tasks encountered when running quantum chemistry computations.
These tools can be used either directly within a Python script using AaronTools objects, or via a series of command-line scripts.
See the Wiki for installation and usage.
AaronTools is described in
"QChASM: Quantum Chemistry Automation and Structure Manipulation" WIREs Comp. Mol. Sci. 11, e1510 (2021).
A Perl implementation of AaronTools is also available here.
However, users are strongly urged to use the Python version since it has far more powerful features and, unlike the Perl version, will continue to be developed and supported.
## Citation
If you use the Python AaronTools, please cite:
V. M. Ingman, A. J. Schaefer, L. R. Andreola, and S. E. Wheeler "QChASM: Quantum Chemistry Automation and Structure Manipulation" WIREs Comp. Mol. Sci. 11, e1510 (2021)
## Contact
If you have any questions or would like to discuss bugs or additional needed features, feel free to contact us at qchasm@uga.edu
%prep
%autosetup -n AaronTools-1.0b18
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-AaronTools -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 1.0b18-1
- Package Spec generated