%global _empty_manifest_terminate_build 0
Name:		python-commit-entropy
Version:	0.2.0
Release:	1
Summary:	UNKNOWN
License:	apache
URL:		UNKNOWN
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/d3/94/8a943d511f2d1d998614cd0dec57ed28ccd20d3e1e280e9bf016d148ef2f/commit-entropy-0.2.0.tar.gz
BuildArch:	noarch


%description
Commit Entropy is a tool that can be used to calculate the entropy of
changes in a source code repository. Entropy for code changes is a
measure of how specific each commit was in relation to the entire code
base. Very specific commits only affect a small set of files, and thus
have a low entropy. Commits that touch a large number of files are much
less specific and have a higher entropy as a result.
The term Entropy in this context is a simplified application of `Shannon
Entropy <https://en.wikipedia.org/wiki/Entropy_%28information_theory%29>`__
to commits in a source repository. It's simplified since we only look at
the number of files changed each commit, with each file having an equal
probability.
Read more about entropy on our
`blog <http://grip.qa/blog/entropy-measuring-software-maturity/>`__.

%package -n python3-commit-entropy
Summary:	UNKNOWN
Provides:	python-commit-entropy
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-commit-entropy
Commit Entropy is a tool that can be used to calculate the entropy of
changes in a source code repository. Entropy for code changes is a
measure of how specific each commit was in relation to the entire code
base. Very specific commits only affect a small set of files, and thus
have a low entropy. Commits that touch a large number of files are much
less specific and have a higher entropy as a result.
The term Entropy in this context is a simplified application of `Shannon
Entropy <https://en.wikipedia.org/wiki/Entropy_%28information_theory%29>`__
to commits in a source repository. It's simplified since we only look at
the number of files changed each commit, with each file having an equal
probability.
Read more about entropy on our
`blog <http://grip.qa/blog/entropy-measuring-software-maturity/>`__.

%package help
Summary:	Development documents and examples for commit-entropy
Provides:	python3-commit-entropy-doc
%description help
Commit Entropy is a tool that can be used to calculate the entropy of
changes in a source code repository. Entropy for code changes is a
measure of how specific each commit was in relation to the entire code
base. Very specific commits only affect a small set of files, and thus
have a low entropy. Commits that touch a large number of files are much
less specific and have a higher entropy as a result.
The term Entropy in this context is a simplified application of `Shannon
Entropy <https://en.wikipedia.org/wiki/Entropy_%28information_theory%29>`__
to commits in a source repository. It's simplified since we only look at
the number of files changed each commit, with each file having an equal
probability.
Read more about entropy on our
`blog <http://grip.qa/blog/entropy-measuring-software-maturity/>`__.

%prep
%autosetup -n commit-entropy-0.2.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-commit-entropy -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.0-1
- Package Spec generated