%global _empty_manifest_terminate_build 0
Name: python-wsgiprox
Version: 1.5.2
Release: 1
Summary: HTTP/S proxy with WebSockets over WSGI
License: Apache 2.0
URL: https://github.com/webrecorder/wsgiprox
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/86/44/c52ccfc68fb7a46ec824d11bc99dcf3eb161c93e7bf31f04091c54f62d9b/wsgiprox-1.5.2.tar.gz
BuildArch: noarch
Requires: python3-six
Requires: python3-certauth
Requires: python3-gevent-websocket
%description
``wsgiprox`` is a Python WSGI middleware for adding HTTP and HTTPS proxy support to a WSGI application.
The library accepts HTTP and HTTPS proxy connections, and routes them to a designated prefix.
Usage
~~~~~
For example, given a `WSGI `_ callable ``application``, the middleware could be defined as follows:
from wsgiprox.wsgiprox import WSGIProxMiddleware
application = WSGIProxMiddleware(application, '/prefix/', 'wsgiprox')
With the above configuration, the middleware is configured to add a prefix of ``/prefix/`` to any url, unless it is to the proxy host ``wsgiprox``. Assuming a WSGI server running on port 8080, the middleware would translate HTTP/S proxy connections to a non-proxy WSGI request, and pass to the wrapped application:
* Proxy Request: ``curl -x "localhost:8080" "http://example.com/path/file.html?A=B"``
Becomes equivalent to: ``curl "http://localhost:8080/prefix/http://example.com/path/file.html?A=B"``
* Proxy Request: ``curl -k -x "localhost:8080" "https://example.com/path/file.html?A=B"``
Becomes equivalent to: ``curl "http://localhost:8080/prefix/https://example.com/path/file.html?A=B"``
* Proxy Request to proxy host: ``curl -k -x "localhost:8080" "https://wsgiprox/path/file.html?A=B"``
Not adding prefix for ``wsgiprox``, becomes equivalent to: ``curl -H "Host: wsgiprox" "http://localhost:8080/path/file.html?A=B"``
All standard WSGI ``environ`` fields are set to the expected values for the translated url.
When a request passes through wsgiprox middleware, ``environ['wsgiprox.proxy_host']`` is set to the proxy host.
In this example, the WSGI app could check that ``environ.get('wsgiprox.proxy_host') == 'wsgiprox'`` to ensure that it was a proxy request. If the request is to the proxy host itself, then it is passed to the WSGI app without prefixing, and ``environ['wsgiprox.proxy_host'] == environ['HTTP_HOST']``
%package -n python3-wsgiprox
Summary: HTTP/S proxy with WebSockets over WSGI
Provides: python-wsgiprox
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-wsgiprox
``wsgiprox`` is a Python WSGI middleware for adding HTTP and HTTPS proxy support to a WSGI application.
The library accepts HTTP and HTTPS proxy connections, and routes them to a designated prefix.
Usage
~~~~~
For example, given a `WSGI `_ callable ``application``, the middleware could be defined as follows:
from wsgiprox.wsgiprox import WSGIProxMiddleware
application = WSGIProxMiddleware(application, '/prefix/', 'wsgiprox')
With the above configuration, the middleware is configured to add a prefix of ``/prefix/`` to any url, unless it is to the proxy host ``wsgiprox``. Assuming a WSGI server running on port 8080, the middleware would translate HTTP/S proxy connections to a non-proxy WSGI request, and pass to the wrapped application:
* Proxy Request: ``curl -x "localhost:8080" "http://example.com/path/file.html?A=B"``
Becomes equivalent to: ``curl "http://localhost:8080/prefix/http://example.com/path/file.html?A=B"``
* Proxy Request: ``curl -k -x "localhost:8080" "https://example.com/path/file.html?A=B"``
Becomes equivalent to: ``curl "http://localhost:8080/prefix/https://example.com/path/file.html?A=B"``
* Proxy Request to proxy host: ``curl -k -x "localhost:8080" "https://wsgiprox/path/file.html?A=B"``
Not adding prefix for ``wsgiprox``, becomes equivalent to: ``curl -H "Host: wsgiprox" "http://localhost:8080/path/file.html?A=B"``
All standard WSGI ``environ`` fields are set to the expected values for the translated url.
When a request passes through wsgiprox middleware, ``environ['wsgiprox.proxy_host']`` is set to the proxy host.
In this example, the WSGI app could check that ``environ.get('wsgiprox.proxy_host') == 'wsgiprox'`` to ensure that it was a proxy request. If the request is to the proxy host itself, then it is passed to the WSGI app without prefixing, and ``environ['wsgiprox.proxy_host'] == environ['HTTP_HOST']``
%package help
Summary: Development documents and examples for wsgiprox
Provides: python3-wsgiprox-doc
%description help
``wsgiprox`` is a Python WSGI middleware for adding HTTP and HTTPS proxy support to a WSGI application.
The library accepts HTTP and HTTPS proxy connections, and routes them to a designated prefix.
Usage
~~~~~
For example, given a `WSGI `_ callable ``application``, the middleware could be defined as follows:
from wsgiprox.wsgiprox import WSGIProxMiddleware
application = WSGIProxMiddleware(application, '/prefix/', 'wsgiprox')
With the above configuration, the middleware is configured to add a prefix of ``/prefix/`` to any url, unless it is to the proxy host ``wsgiprox``. Assuming a WSGI server running on port 8080, the middleware would translate HTTP/S proxy connections to a non-proxy WSGI request, and pass to the wrapped application:
* Proxy Request: ``curl -x "localhost:8080" "http://example.com/path/file.html?A=B"``
Becomes equivalent to: ``curl "http://localhost:8080/prefix/http://example.com/path/file.html?A=B"``
* Proxy Request: ``curl -k -x "localhost:8080" "https://example.com/path/file.html?A=B"``
Becomes equivalent to: ``curl "http://localhost:8080/prefix/https://example.com/path/file.html?A=B"``
* Proxy Request to proxy host: ``curl -k -x "localhost:8080" "https://wsgiprox/path/file.html?A=B"``
Not adding prefix for ``wsgiprox``, becomes equivalent to: ``curl -H "Host: wsgiprox" "http://localhost:8080/path/file.html?A=B"``
All standard WSGI ``environ`` fields are set to the expected values for the translated url.
When a request passes through wsgiprox middleware, ``environ['wsgiprox.proxy_host']`` is set to the proxy host.
In this example, the WSGI app could check that ``environ.get('wsgiprox.proxy_host') == 'wsgiprox'`` to ensure that it was a proxy request. If the request is to the proxy host itself, then it is passed to the WSGI app without prefixing, and ``environ['wsgiprox.proxy_host'] == environ['HTTP_HOST']``
%prep
%autosetup -n wsgiprox-1.5.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-wsgiprox -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 1.5.2-1
- Package Spec generated