%global _empty_manifest_terminate_build 0
Name: python-femagtools
Version: 1.2.7
Release: 1
Summary: Python API for FEMAG
License: Copyright (c) 2016-2023, Semafor Informatik & Energie AG, Basel All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
URL: https://pypi.org/project/femagtools/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ba/9a/aac7b6fe8fc22ac96fa66bf90f52c8c9200c64e48455ec88d51c405576e9/femagtools-1.2.7.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-scipy
Requires: python3-mako
Requires: python3-six
Requires: python3-lmfit
Requires: python3-netCDF4
Requires: python3-lxml
Requires: python3-dxfgrabber
Requires: python3-networkx
Requires: python3-meshio
Requires: python3-matplotlib
Requires: python3-pytest
Requires: python3-vtk
Requires: python3-pyzmq
%description
# Introduction to Femagtools


Femagtools is an Open-Source Python-API for FEMAG offering following features:
* run Femag with a FSL script file anywhere:
locally (single and multi-core), remote (ZMQ), HT Condor, Cloud (Amazon AWS, Google Cloud), Docker
* read I7/ISA7, NC, BCH/BATCH, PLT, ERG files
* read and write MCV files (magnetizing curves)
* create a variety of plots
* create FSL files from model and calculation templates and/or user specific FSL
* create FSL files from DXF
* create and analyze symmetrical windings
* sizing and parameter identification
* calculate machine characteristics by using analytic machine models
* execute parameter studies and multi-objective optimization
The package can be used with Python 3.x on Linux, MacOS or Windows and is hosted on github: ` where also many examples can be found in the examples directory. Contributions and feedback to this project are highly welcome.
The installation can be done in the usual ways with pip:
```
pip install femagtools[all]
```
([all] pulls in all optional dependencies.
For details see the documentation
## Modules and Scripts
The package provides following modules:
* __mcv__, __tks__, __jhb__, __losscoeffs__: handling magnetizing curves and iron losses
* __erg__, __bch__: read ERG, BCH/BATCH files created by FEMAG
* __model__, __fsl__: create machine and calculation models
* __femag__: manage the FEMAG calculation
* __airgap__: read airgap induction file created by a previous calculation
* __machine__: analytical machine models
* __windings__: create and analyze windings
* __grid__: running parameter variations
* __opt__: running multi objective optimizations
* __plot__: creating a variety of plots
* __dxfsl__: create FSL from DXF
* __isa7__, __nc__: read ISA7/I7, NC (NetCDF) files
* __windings__: create and analyze windings
* __forcedens__: read PLT files
* __amazon__, __google__, __condor__, __multiproc__: engines for the calculation in Cloud and HTCondor environments or locally using multiple cores
The following modules can be executed as script:
* __bch__: print content in json format if invoked with a BCH/BATCH file as argument
* __bchxml__: produces an XML file when invoked with a BCH/BATCH file as argument
* __plot__: produces a graphical report of a BCH/BATCH file
* __airgap__: prints the base harmonic amplitude of the radial component of the airgap induction when invoked with the file name of an airgap induction file
* __mcv__: print content in json format if invoked with a MC/MCV file as argument
* __dxfsl/conv__: show geometry or create fsl from dxf
## Usage
For many applications it is sufficient to import femagtools:
```python
import femagtools
```
The version can be checked with:
```python
femagtools.__version__
```
'1.0.nn'
%package -n python3-femagtools
Summary: Python API for FEMAG
Provides: python-femagtools
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-femagtools
# Introduction to Femagtools


Femagtools is an Open-Source Python-API for FEMAG offering following features:
* run Femag with a FSL script file anywhere:
locally (single and multi-core), remote (ZMQ), HT Condor, Cloud (Amazon AWS, Google Cloud), Docker
* read I7/ISA7, NC, BCH/BATCH, PLT, ERG files
* read and write MCV files (magnetizing curves)
* create a variety of plots
* create FSL files from model and calculation templates and/or user specific FSL
* create FSL files from DXF
* create and analyze symmetrical windings
* sizing and parameter identification
* calculate machine characteristics by using analytic machine models
* execute parameter studies and multi-objective optimization
The package can be used with Python 3.x on Linux, MacOS or Windows and is hosted on github: ` where also many examples can be found in the examples directory. Contributions and feedback to this project are highly welcome.
The installation can be done in the usual ways with pip:
```
pip install femagtools[all]
```
([all] pulls in all optional dependencies.
For details see the documentation
## Modules and Scripts
The package provides following modules:
* __mcv__, __tks__, __jhb__, __losscoeffs__: handling magnetizing curves and iron losses
* __erg__, __bch__: read ERG, BCH/BATCH files created by FEMAG
* __model__, __fsl__: create machine and calculation models
* __femag__: manage the FEMAG calculation
* __airgap__: read airgap induction file created by a previous calculation
* __machine__: analytical machine models
* __windings__: create and analyze windings
* __grid__: running parameter variations
* __opt__: running multi objective optimizations
* __plot__: creating a variety of plots
* __dxfsl__: create FSL from DXF
* __isa7__, __nc__: read ISA7/I7, NC (NetCDF) files
* __windings__: create and analyze windings
* __forcedens__: read PLT files
* __amazon__, __google__, __condor__, __multiproc__: engines for the calculation in Cloud and HTCondor environments or locally using multiple cores
The following modules can be executed as script:
* __bch__: print content in json format if invoked with a BCH/BATCH file as argument
* __bchxml__: produces an XML file when invoked with a BCH/BATCH file as argument
* __plot__: produces a graphical report of a BCH/BATCH file
* __airgap__: prints the base harmonic amplitude of the radial component of the airgap induction when invoked with the file name of an airgap induction file
* __mcv__: print content in json format if invoked with a MC/MCV file as argument
* __dxfsl/conv__: show geometry or create fsl from dxf
## Usage
For many applications it is sufficient to import femagtools:
```python
import femagtools
```
The version can be checked with:
```python
femagtools.__version__
```
'1.0.nn'
%package help
Summary: Development documents and examples for femagtools
Provides: python3-femagtools-doc
%description help
# Introduction to Femagtools


Femagtools is an Open-Source Python-API for FEMAG offering following features:
* run Femag with a FSL script file anywhere:
locally (single and multi-core), remote (ZMQ), HT Condor, Cloud (Amazon AWS, Google Cloud), Docker
* read I7/ISA7, NC, BCH/BATCH, PLT, ERG files
* read and write MCV files (magnetizing curves)
* create a variety of plots
* create FSL files from model and calculation templates and/or user specific FSL
* create FSL files from DXF
* create and analyze symmetrical windings
* sizing and parameter identification
* calculate machine characteristics by using analytic machine models
* execute parameter studies and multi-objective optimization
The package can be used with Python 3.x on Linux, MacOS or Windows and is hosted on github: ` where also many examples can be found in the examples directory. Contributions and feedback to this project are highly welcome.
The installation can be done in the usual ways with pip:
```
pip install femagtools[all]
```
([all] pulls in all optional dependencies.
For details see the documentation
## Modules and Scripts
The package provides following modules:
* __mcv__, __tks__, __jhb__, __losscoeffs__: handling magnetizing curves and iron losses
* __erg__, __bch__: read ERG, BCH/BATCH files created by FEMAG
* __model__, __fsl__: create machine and calculation models
* __femag__: manage the FEMAG calculation
* __airgap__: read airgap induction file created by a previous calculation
* __machine__: analytical machine models
* __windings__: create and analyze windings
* __grid__: running parameter variations
* __opt__: running multi objective optimizations
* __plot__: creating a variety of plots
* __dxfsl__: create FSL from DXF
* __isa7__, __nc__: read ISA7/I7, NC (NetCDF) files
* __windings__: create and analyze windings
* __forcedens__: read PLT files
* __amazon__, __google__, __condor__, __multiproc__: engines for the calculation in Cloud and HTCondor environments or locally using multiple cores
The following modules can be executed as script:
* __bch__: print content in json format if invoked with a BCH/BATCH file as argument
* __bchxml__: produces an XML file when invoked with a BCH/BATCH file as argument
* __plot__: produces a graphical report of a BCH/BATCH file
* __airgap__: prints the base harmonic amplitude of the radial component of the airgap induction when invoked with the file name of an airgap induction file
* __mcv__: print content in json format if invoked with a MC/MCV file as argument
* __dxfsl/conv__: show geometry or create fsl from dxf
## Usage
For many applications it is sufficient to import femagtools:
```python
import femagtools
```
The version can be checked with:
```python
femagtools.__version__
```
'1.0.nn'
%prep
%autosetup -n femagtools-1.2.7
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-femagtools -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 1.2.7-1
- Package Spec generated