%global _empty_manifest_terminate_build 0
Name: python-PermutationImportance
Version: 1.2.1.8
Release: 1
Summary: Important variables determined through data-based variable importance methods
License: MIT
URL: https://github.com/gelijergensen/PermutationImportance
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/44/78/83c67e1d2f88808904762e3521aecdfe9bfd08505fa9b1f2629a1c7b6e32/PermutationImportance-1.2.1.8.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-pandas
Requires: python3-scipy
Requires: python3-scikit-learn
%description
# PermutationImportance
[![Build Status](https://travis-ci.com/gelijergensen/PermutationImportance.svg?branch=master)](https://travis-ci.com/gelijergensen/PermutationImportance)
[![Documentation Status](https://readthedocs.org/projects/permutationimportance/badge/?version=latest)](https://permutationimportance.readthedocs.io/en/latest/?badge=latest)
![PermutationImportance Logo](https://github.com/gelijergensen/PermutationImportance/blob/master/docs/images/favicon.png)
Welcome to the PermutationImportance library!
PermutationImportance is a Python package for Python 2.7 and 3.6+ which provides
several methods for computing data-based predictor importance. The methods
implemented are model-agnostic and can be used for any machine learning model in
many stages of development. The complete documentation can be found at our
[Read The Docs](https://permutationimportance.readthedocs.io/en/latest/).
## Version History
- 1.2.1.8: Shuffled pandas dataframes now retain the proper row indexing
- 1.2.1.7: Fixed a bug where pandas dataframes were being unshuffled when
concatenated
- 1.2.1.5: Added documentation and examples and ensured compatibility with
Python 3.5+
- 1.2.1.4: Original scores are now also bootstrapped to match the other results
- 1.2.1.3: Corrected an issue with multithreading deadlock when returned scores
were too large
- 1.2.1.1: Provided object to assist in constructing scoring strategies
- Also added two new strategies with bootstrapping support
- 1.2.1.0: Metrics can now accept kwargs and support bootstrapping
- 1.2.0.0: Added support for Sequential Selection and completely revised backend
for proper abstraction and extension
- Return object now keeps track of `(context, result)` pairs
- `abstract_variable_importance` enables implementation of custom variable
importance methods
- Backend is now correctly multithreaded (when specified) and is
OS-independent
- 1.1.0.0: Revised return object of Permutation Importance to support easy
retrieval of Breiman- and Lakshmanan-style importances
- 1.0.0.0: Published with `pip` support!
%package -n python3-PermutationImportance
Summary: Important variables determined through data-based variable importance methods
Provides: python-PermutationImportance
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-PermutationImportance
# PermutationImportance
[![Build Status](https://travis-ci.com/gelijergensen/PermutationImportance.svg?branch=master)](https://travis-ci.com/gelijergensen/PermutationImportance)
[![Documentation Status](https://readthedocs.org/projects/permutationimportance/badge/?version=latest)](https://permutationimportance.readthedocs.io/en/latest/?badge=latest)
![PermutationImportance Logo](https://github.com/gelijergensen/PermutationImportance/blob/master/docs/images/favicon.png)
Welcome to the PermutationImportance library!
PermutationImportance is a Python package for Python 2.7 and 3.6+ which provides
several methods for computing data-based predictor importance. The methods
implemented are model-agnostic and can be used for any machine learning model in
many stages of development. The complete documentation can be found at our
[Read The Docs](https://permutationimportance.readthedocs.io/en/latest/).
## Version History
- 1.2.1.8: Shuffled pandas dataframes now retain the proper row indexing
- 1.2.1.7: Fixed a bug where pandas dataframes were being unshuffled when
concatenated
- 1.2.1.5: Added documentation and examples and ensured compatibility with
Python 3.5+
- 1.2.1.4: Original scores are now also bootstrapped to match the other results
- 1.2.1.3: Corrected an issue with multithreading deadlock when returned scores
were too large
- 1.2.1.1: Provided object to assist in constructing scoring strategies
- Also added two new strategies with bootstrapping support
- 1.2.1.0: Metrics can now accept kwargs and support bootstrapping
- 1.2.0.0: Added support for Sequential Selection and completely revised backend
for proper abstraction and extension
- Return object now keeps track of `(context, result)` pairs
- `abstract_variable_importance` enables implementation of custom variable
importance methods
- Backend is now correctly multithreaded (when specified) and is
OS-independent
- 1.1.0.0: Revised return object of Permutation Importance to support easy
retrieval of Breiman- and Lakshmanan-style importances
- 1.0.0.0: Published with `pip` support!
%package help
Summary: Development documents and examples for PermutationImportance
Provides: python3-PermutationImportance-doc
%description help
# PermutationImportance
[![Build Status](https://travis-ci.com/gelijergensen/PermutationImportance.svg?branch=master)](https://travis-ci.com/gelijergensen/PermutationImportance)
[![Documentation Status](https://readthedocs.org/projects/permutationimportance/badge/?version=latest)](https://permutationimportance.readthedocs.io/en/latest/?badge=latest)
![PermutationImportance Logo](https://github.com/gelijergensen/PermutationImportance/blob/master/docs/images/favicon.png)
Welcome to the PermutationImportance library!
PermutationImportance is a Python package for Python 2.7 and 3.6+ which provides
several methods for computing data-based predictor importance. The methods
implemented are model-agnostic and can be used for any machine learning model in
many stages of development. The complete documentation can be found at our
[Read The Docs](https://permutationimportance.readthedocs.io/en/latest/).
## Version History
- 1.2.1.8: Shuffled pandas dataframes now retain the proper row indexing
- 1.2.1.7: Fixed a bug where pandas dataframes were being unshuffled when
concatenated
- 1.2.1.5: Added documentation and examples and ensured compatibility with
Python 3.5+
- 1.2.1.4: Original scores are now also bootstrapped to match the other results
- 1.2.1.3: Corrected an issue with multithreading deadlock when returned scores
were too large
- 1.2.1.1: Provided object to assist in constructing scoring strategies
- Also added two new strategies with bootstrapping support
- 1.2.1.0: Metrics can now accept kwargs and support bootstrapping
- 1.2.0.0: Added support for Sequential Selection and completely revised backend
for proper abstraction and extension
- Return object now keeps track of `(context, result)` pairs
- `abstract_variable_importance` enables implementation of custom variable
importance methods
- Backend is now correctly multithreaded (when specified) and is
OS-independent
- 1.1.0.0: Revised return object of Permutation Importance to support easy
retrieval of Breiman- and Lakshmanan-style importances
- 1.0.0.0: Published with `pip` support!
%prep
%autosetup -n PermutationImportance-1.2.1.8
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-PermutationImportance -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 1.2.1.8-1
- Package Spec generated