%global _empty_manifest_terminate_build 0
Name:		python-http-request-randomizer
Version:	1.3.2
Release:	1
Summary:	A package using public proxies to randomise http requests
License:	MIT
URL:		http://pgaref.com/blog/python-proxy
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/7b/84/ea11a2ccbe215ac200c0e6342245f2db0747ca963f38339219e6df46b546/http_request_randomizer-1.3.2.tar.gz
BuildArch:	noarch


%description
`Vietnamese version <README-vi.md>`__
A convenient way to implement HTTP requests is using Pythons’
**requests** library. One of requests’ most popular features is simple
proxying support. HTTP as a protocol has very well-defined semantics for
dealing with proxies, and this contributed to the widespread deployment
of HTTP proxies
Proxying is very useful when conducting intensive web crawling/scrapping
or when you just want to hide your identity (anonymization).
In this project I am using public proxies to randomise http requests
over a number of IP addresses and using a variety of known user agent
headers these requests look to have been produced by different
applications and operating systems.

%package -n python3-http-request-randomizer
Summary:	A package using public proxies to randomise http requests
Provides:	python-http-request-randomizer
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-http-request-randomizer
`Vietnamese version <README-vi.md>`__
A convenient way to implement HTTP requests is using Pythons’
**requests** library. One of requests’ most popular features is simple
proxying support. HTTP as a protocol has very well-defined semantics for
dealing with proxies, and this contributed to the widespread deployment
of HTTP proxies
Proxying is very useful when conducting intensive web crawling/scrapping
or when you just want to hide your identity (anonymization).
In this project I am using public proxies to randomise http requests
over a number of IP addresses and using a variety of known user agent
headers these requests look to have been produced by different
applications and operating systems.

%package help
Summary:	Development documents and examples for http-request-randomizer
Provides:	python3-http-request-randomizer-doc
%description help
`Vietnamese version <README-vi.md>`__
A convenient way to implement HTTP requests is using Pythons’
**requests** library. One of requests’ most popular features is simple
proxying support. HTTP as a protocol has very well-defined semantics for
dealing with proxies, and this contributed to the widespread deployment
of HTTP proxies
Proxying is very useful when conducting intensive web crawling/scrapping
or when you just want to hide your identity (anonymization).
In this project I am using public proxies to randomise http requests
over a number of IP addresses and using a variety of known user agent
headers these requests look to have been produced by different
applications and operating systems.

%prep
%autosetup -n http-request-randomizer-1.3.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-http-request-randomizer -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3.2-1
- Package Spec generated