%global _empty_manifest_terminate_build 0
Name: python-animals.py
Version: 1.0.0
Release: 1
Summary: please add a summary manually as the author left a blank one
License: MIT
URL: https://pypi.org/project/animals.py/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/43/ef/a1da56414b9557a6ad71c938aa6ccd8a2b928ef3f890cd4b78a8fb5b7647/animals.py-1.0.0.tar.gz
BuildArch: noarch
%description
# animals.py
A Python module to get random image/facts of different animals
# Getting started
**Installation**
```sh
pip install animals.py
```
**Example for usage**
```py
from animals import Animals
animal = Animals('cat')
print(animal.image()) # Prints the url for the image
```
# Thanks to
* [requests](https://github.com/psf/requests)
* [some-random-api](https://some-random-api.ml)
%package -n python3-animals.py
Summary: please add a summary manually as the author left a blank one
Provides: python-animals.py
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-animals.py
# animals.py
A Python module to get random image/facts of different animals
# Getting started
**Installation**
```sh
pip install animals.py
```
**Example for usage**
```py
from animals import Animals
animal = Animals('cat')
print(animal.image()) # Prints the url for the image
```
# Thanks to
* [requests](https://github.com/psf/requests)
* [some-random-api](https://some-random-api.ml)
%package help
Summary: Development documents and examples for animals.py
Provides: python3-animals.py-doc
%description help
# animals.py
A Python module to get random image/facts of different animals
# Getting started
**Installation**
```sh
pip install animals.py
```
**Example for usage**
```py
from animals import Animals
animal = Animals('cat')
print(animal.image()) # Prints the url for the image
```
# Thanks to
* [requests](https://github.com/psf/requests)
* [some-random-api](https://some-random-api.ml)
%prep
%autosetup -n animals.py-1.0.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-animals.py -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 1.0.0-1
- Package Spec generated