%global _empty_manifest_terminate_build 0
Name:		python-shakenfist
Version:	0.6.15
Release:	1
Summary:	Shaken Fist: an opinionated minimal cloud
License:	Apache2
URL:		https://madebymikal.com/shakenfist
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/c0/bf/ae4223ae5d3f5ac4d1f00e6b35d25accd5218c852475f01ab1f73b8593be/shakenfist-0.6.15.tar.gz
BuildArch:	noarch

Requires:	python3-Flask-JWT-Extended
Requires:	python3-Flask-RESTful
Requires:	python3-Flask
Requires:	python3-Jinja2
Requires:	python3-MarkupSafe
Requires:	python3-PyJWT
Requires:	python3-Werkzeug
Requires:	python3-aniso8601
Requires:	python3-bcrypt
Requires:	python3-clingwrap
Requires:	python3-distro
Requires:	python3-etcd3
Requires:	python3-etcd3gw
Requires:	python3-fixtures
Requires:	python3-flask-request-id-middleware
Requires:	python3-futurist
Requires:	python3-grpcio
Requires:	python3-gunicorn
Requires:	python3-importlib-metadata
Requires:	python3-itsdangerous
Requires:	python3-marshmallow
Requires:	python3-pip-api
Requires:	python3-prettytable
Requires:	python3-prometheus-client
Requires:	python3-protobuf
Requires:	python3-psutil
Requires:	python3-py-cpuinfo
Requires:	python3-pycdlib
Requires:	python3-pydantic
Requires:	python3-pylogrus
Requires:	python3-magic
Requires:	python3-setproctitle
Requires:	python3-setuptools
Requires:	python3-tenacity
Requires:	python3-tqdm
Requires:	python3-typing-extensions
Requires:	python3-wcwidth
Requires:	python3-webargs
Requires:	python3-importlib-metadata

%description
# Shaken Fist: Opinionated to the point of being impolite
![Python application](https://github.com/shakenfist/shakenfist/workflows/Python%20application/badge.svg)
<a href="https://pypi.org/project/shakenfist" target="_blank">
    <img src="https://img.shields.io/pypi/v/shakenfist?color=%2334D058&label=pypi%20package" alt="Package version">
</a>

**Documentation:** https://shakenfist.com/  
**Source Code:** https://github.com/shakenfist/shakenfist





%package -n python3-shakenfist
Summary:	Shaken Fist: an opinionated minimal cloud
Provides:	python-shakenfist
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-shakenfist
# Shaken Fist: Opinionated to the point of being impolite
![Python application](https://github.com/shakenfist/shakenfist/workflows/Python%20application/badge.svg)
<a href="https://pypi.org/project/shakenfist" target="_blank">
    <img src="https://img.shields.io/pypi/v/shakenfist?color=%2334D058&label=pypi%20package" alt="Package version">
</a>

**Documentation:** https://shakenfist.com/  
**Source Code:** https://github.com/shakenfist/shakenfist





%package help
Summary:	Development documents and examples for shakenfist
Provides:	python3-shakenfist-doc
%description help
# Shaken Fist: Opinionated to the point of being impolite
![Python application](https://github.com/shakenfist/shakenfist/workflows/Python%20application/badge.svg)
<a href="https://pypi.org/project/shakenfist" target="_blank">
    <img src="https://img.shields.io/pypi/v/shakenfist?color=%2334D058&label=pypi%20package" alt="Package version">
</a>

**Documentation:** https://shakenfist.com/  
**Source Code:** https://github.com/shakenfist/shakenfist





%prep
%autosetup -n shakenfist-0.6.15

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-shakenfist -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.6.15-1
- Package Spec generated