%global _empty_manifest_terminate_build 0
Name:		python-pytest-docstyle
Version:	2.0.1
Release:	1
Summary:	pytest plugin to run pydocstyle
License:	MIT
URL:		https://github.com/henry0312/pytest-docstyle
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/d9/92/a841948d831db8f51671dd121f7a835cc1d56dd517761995dc65a8a9745c/pytest-docstyle-2.0.1.tar.gz
BuildArch:	noarch


%description
# pytest-docstyle

[![PyPI version](https://badge.fury.io/py/pytest-docstyle.svg)](https://pypi.org/project/pytest-docstyle/)

[pytest](https://docs.pytest.org/en/latest/) plugin to run [pydocstyle](https://github.com/PyCQA/pydocstyle)

## Installation

```sh
pip install pytest-docstyle
```

## Usage

```sh
pytest --pydocstyle ...
```

For detail, please see `pytest -h` after installation.

## Configuration

The behavior can be configured in the same style of pydocstyle.  
(cf. [Configuration — pytest documentation](https://docs.pytest.org/en/latest/customize.html) and [Configuration Files — pydocstyle documentation](http://www.pydocstyle.org/en/latest/usage.html#configuration-files))

For example,

```
[pydocstyle]
convention = numpy
add-ignore = D400,D403

[tool:pytest]
addopts = --pydocstyle
```

## Licence

The MIT License  
Copyright (c) 2019 OMOTO Tsukasa

## Acknowledgments

- [abendebury/pytest-pep257](https://github.com/abendebury/pytest-pep257)

%package -n python3-pytest-docstyle
Summary:	pytest plugin to run pydocstyle
Provides:	python-pytest-docstyle
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pytest-docstyle
# pytest-docstyle

[![PyPI version](https://badge.fury.io/py/pytest-docstyle.svg)](https://pypi.org/project/pytest-docstyle/)

[pytest](https://docs.pytest.org/en/latest/) plugin to run [pydocstyle](https://github.com/PyCQA/pydocstyle)

## Installation

```sh
pip install pytest-docstyle
```

## Usage

```sh
pytest --pydocstyle ...
```

For detail, please see `pytest -h` after installation.

## Configuration

The behavior can be configured in the same style of pydocstyle.  
(cf. [Configuration — pytest documentation](https://docs.pytest.org/en/latest/customize.html) and [Configuration Files — pydocstyle documentation](http://www.pydocstyle.org/en/latest/usage.html#configuration-files))

For example,

```
[pydocstyle]
convention = numpy
add-ignore = D400,D403

[tool:pytest]
addopts = --pydocstyle
```

## Licence

The MIT License  
Copyright (c) 2019 OMOTO Tsukasa

## Acknowledgments

- [abendebury/pytest-pep257](https://github.com/abendebury/pytest-pep257)

%package help
Summary:	Development documents and examples for pytest-docstyle
Provides:	python3-pytest-docstyle-doc
%description help
# pytest-docstyle

[![PyPI version](https://badge.fury.io/py/pytest-docstyle.svg)](https://pypi.org/project/pytest-docstyle/)

[pytest](https://docs.pytest.org/en/latest/) plugin to run [pydocstyle](https://github.com/PyCQA/pydocstyle)

## Installation

```sh
pip install pytest-docstyle
```

## Usage

```sh
pytest --pydocstyle ...
```

For detail, please see `pytest -h` after installation.

## Configuration

The behavior can be configured in the same style of pydocstyle.  
(cf. [Configuration — pytest documentation](https://docs.pytest.org/en/latest/customize.html) and [Configuration Files — pydocstyle documentation](http://www.pydocstyle.org/en/latest/usage.html#configuration-files))

For example,

```
[pydocstyle]
convention = numpy
add-ignore = D400,D403

[tool:pytest]
addopts = --pydocstyle
```

## Licence

The MIT License  
Copyright (c) 2019 OMOTO Tsukasa

## Acknowledgments

- [abendebury/pytest-pep257](https://github.com/abendebury/pytest-pep257)

%prep
%autosetup -n pytest-docstyle-2.0.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pytest-docstyle -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 2.0.1-1
- Package Spec generated