%global _empty_manifest_terminate_build 0
Name:		python-PriceHero-mehtaarn000
Version:	0.5.9
Release:	1
Summary:	A python module that will allow users to get product prices information from a multitude of different websites.
License:	MIT License
URL:		https://github.com/mehtaarn000/PriceHero
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/c8/23/4ea16317bff18a326cf633b0b70fc44ec216f7740006836384ed48b695a7/PriceHero-mehtaarn000-0.5.9.tar.gz
BuildArch:	noarch


%description
# PriceHero
A python module that will allow users to get product prices information from a multitude of different websites. Perfect for building price trackers.

## Installation
`pip install PriceHero-mehtaarn000`

## Example
Import the module with:

`import PriceHero as ph`

Now, scrape a product off Acer with:

`travelpack = ph.acer("https://store.acer.com/en-us/porsche-design-acer-travelpack-rs-aak010")`

`print(travelpack)`, your output should be something like this:

`{'name': 'Porsche Design Acer Travelpack RS - AAK010', 'price': '$329.99', 'discountprice': None}`

## Supported Websites
Total of 28!
- Acer
- Adafruit
- Adidas
- Amazon
- Ann Taylor
- BestBuy
- Boohoo
- Chess.com Shop
- Dell
- Etsy
- Github Shop
- Gucci
- Joanns
- Journeys
- Jumia
- Konga
- Lids
- Louis Vuitton
- Michaels
- Minecraft Shop
- Newegg
- Overstock
- Pishop
- Tjmaxx
- Walgreens
- Walmart
- White House Black Market
- Xbox




%package -n python3-PriceHero-mehtaarn000
Summary:	A python module that will allow users to get product prices information from a multitude of different websites.
Provides:	python-PriceHero-mehtaarn000
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-PriceHero-mehtaarn000
# PriceHero
A python module that will allow users to get product prices information from a multitude of different websites. Perfect for building price trackers.

## Installation
`pip install PriceHero-mehtaarn000`

## Example
Import the module with:

`import PriceHero as ph`

Now, scrape a product off Acer with:

`travelpack = ph.acer("https://store.acer.com/en-us/porsche-design-acer-travelpack-rs-aak010")`

`print(travelpack)`, your output should be something like this:

`{'name': 'Porsche Design Acer Travelpack RS - AAK010', 'price': '$329.99', 'discountprice': None}`

## Supported Websites
Total of 28!
- Acer
- Adafruit
- Adidas
- Amazon
- Ann Taylor
- BestBuy
- Boohoo
- Chess.com Shop
- Dell
- Etsy
- Github Shop
- Gucci
- Joanns
- Journeys
- Jumia
- Konga
- Lids
- Louis Vuitton
- Michaels
- Minecraft Shop
- Newegg
- Overstock
- Pishop
- Tjmaxx
- Walgreens
- Walmart
- White House Black Market
- Xbox




%package help
Summary:	Development documents and examples for PriceHero-mehtaarn000
Provides:	python3-PriceHero-mehtaarn000-doc
%description help
# PriceHero
A python module that will allow users to get product prices information from a multitude of different websites. Perfect for building price trackers.

## Installation
`pip install PriceHero-mehtaarn000`

## Example
Import the module with:

`import PriceHero as ph`

Now, scrape a product off Acer with:

`travelpack = ph.acer("https://store.acer.com/en-us/porsche-design-acer-travelpack-rs-aak010")`

`print(travelpack)`, your output should be something like this:

`{'name': 'Porsche Design Acer Travelpack RS - AAK010', 'price': '$329.99', 'discountprice': None}`

## Supported Websites
Total of 28!
- Acer
- Adafruit
- Adidas
- Amazon
- Ann Taylor
- BestBuy
- Boohoo
- Chess.com Shop
- Dell
- Etsy
- Github Shop
- Gucci
- Joanns
- Journeys
- Jumia
- Konga
- Lids
- Louis Vuitton
- Michaels
- Minecraft Shop
- Newegg
- Overstock
- Pishop
- Tjmaxx
- Walgreens
- Walmart
- White House Black Market
- Xbox




%prep
%autosetup -n PriceHero-mehtaarn000-0.5.9

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-PriceHero-mehtaarn000 -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5.9-1
- Package Spec generated