%global _empty_manifest_terminate_build 0
Name: python-encryptedsocket
Version: 3.0.0
Release: 1
Summary: Secured yet simple socket server-client for interprocess communications with RSA and AES-256.
License: AGPL-3.0
URL: https://github.com/foxe6/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/63/4a/a4686459dbb581ca4807e9b6fd47e7a5ce21586842808a353b2b0146a193/encryptedsocket-3.0.0.tar.gz
BuildArch: noarch
Requires: python3-aescipher
Requires: python3-easyrsa
Requires: python3-omnitools
%description
# Encrypted Socket
[](https://pypi.org/project/encryptedsocket/)
[](https://pypi.org/project/encryptedsocket/)
[](https://pypi.org/project/encryptedsocket/)
[](https://saythanks.io/to/foxe6)
[](https://paypal.me/foxe6)
[](https://paypal.me/foxe6)
Secured yet simple socket server-client for interprocess communications with RSA and AES-256.
# Hierarchy
```
encryptedsocket
|---- SS()
| |---- start()
| '---- stop()
'---- SC()
|---- request()
'---- close()
```
# Example
## python
See `test`.
%package -n python3-encryptedsocket
Summary: Secured yet simple socket server-client for interprocess communications with RSA and AES-256.
Provides: python-encryptedsocket
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-encryptedsocket
# Encrypted Socket
[](https://pypi.org/project/encryptedsocket/)
[](https://pypi.org/project/encryptedsocket/)
[](https://pypi.org/project/encryptedsocket/)
[](https://saythanks.io/to/foxe6)
[](https://paypal.me/foxe6)
[](https://paypal.me/foxe6)
Secured yet simple socket server-client for interprocess communications with RSA and AES-256.
# Hierarchy
```
encryptedsocket
|---- SS()
| |---- start()
| '---- stop()
'---- SC()
|---- request()
'---- close()
```
# Example
## python
See `test`.
%package help
Summary: Development documents and examples for encryptedsocket
Provides: python3-encryptedsocket-doc
%description help
# Encrypted Socket
[](https://pypi.org/project/encryptedsocket/)
[](https://pypi.org/project/encryptedsocket/)
[](https://pypi.org/project/encryptedsocket/)
[](https://saythanks.io/to/foxe6)
[](https://paypal.me/foxe6)
[](https://paypal.me/foxe6)
Secured yet simple socket server-client for interprocess communications with RSA and AES-256.
# Hierarchy
```
encryptedsocket
|---- SS()
| |---- start()
| '---- stop()
'---- SC()
|---- request()
'---- close()
```
# Example
## python
See `test`.
%prep
%autosetup -n encryptedsocket-3.0.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-encryptedsocket -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 10 2023 Python_Bot - 3.0.0-1
- Package Spec generated