%global _empty_manifest_terminate_build 0
Name: python-aiogTTS
Version: 1.1.1
Release: 1
Summary: A Python library to interface with Google Translate text-to-speech API
License: MIT License
URL: https://github.com/Helow19274/aiogTTS
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/86/05/ecc208a30258eccf5d2d45df078130b375ca9838307c51a1748889c1b28b/aiogTTS-1.1.1.tar.gz
BuildArch: noarch
Requires: python3-aiohttp
Requires: python3-beautifulsoup4
Requires: python3-pytest-asyncio
%description
# aiogTTS [![PyPI version](https://img.shields.io/pypi/v/aiogTTS.svg)](https://pypi.org/project/aiogTTS/) [![Python versions](https://img.shields.io/pypi/pyversions/aiogTTS.svg)](https://pypi.org/project/aiogTTS/) [![Build Status](https://travis-ci.org/Helow19274/aiogTTS.svg?branch=master)](https://travis-ci.org/Helow19274/aiogTTS/)
**aiogTTS** (asynchronous Google Text-to-Speech), a Python library to interface with Google Translate's text-to-speech API.
Writes spoken mp3 data to a file or a file-like object (bytestring) for further audiomanipulation.
#### Original gTTS - (75% of this repo)
## Features
- Customizable speech-specific sentence tokenizer that allows for unlimited lengths of text to be read, all while keeping proper intonation, abbreviations, decimals and more;
- Customizable text pre-processors which can, for example, provide pronunciation corrections;
### Installation
```bash
$ pip install aiogTTS
```
### Quickstart
```python
import asyncio
from io import BytesIO
from aiogtts import aiogTTS
async def main():
aiogtts = aiogTTS()
io = BytesIO()
await aiogtts.save('Привет, мир!', 'audio.mp3', lang='ru')
await aiogtts.write_to_fp('Hallo!', io, slow=True, lang='de')
asyncio.get_event_loop().run_until_complete(main())
```
%package -n python3-aiogTTS
Summary: A Python library to interface with Google Translate text-to-speech API
Provides: python-aiogTTS
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-aiogTTS
# aiogTTS [![PyPI version](https://img.shields.io/pypi/v/aiogTTS.svg)](https://pypi.org/project/aiogTTS/) [![Python versions](https://img.shields.io/pypi/pyversions/aiogTTS.svg)](https://pypi.org/project/aiogTTS/) [![Build Status](https://travis-ci.org/Helow19274/aiogTTS.svg?branch=master)](https://travis-ci.org/Helow19274/aiogTTS/)
**aiogTTS** (asynchronous Google Text-to-Speech), a Python library to interface with Google Translate's text-to-speech API.
Writes spoken mp3 data to a file or a file-like object (bytestring) for further audiomanipulation.
#### Original gTTS - (75% of this repo)
## Features
- Customizable speech-specific sentence tokenizer that allows for unlimited lengths of text to be read, all while keeping proper intonation, abbreviations, decimals and more;
- Customizable text pre-processors which can, for example, provide pronunciation corrections;
### Installation
```bash
$ pip install aiogTTS
```
### Quickstart
```python
import asyncio
from io import BytesIO
from aiogtts import aiogTTS
async def main():
aiogtts = aiogTTS()
io = BytesIO()
await aiogtts.save('Привет, мир!', 'audio.mp3', lang='ru')
await aiogtts.write_to_fp('Hallo!', io, slow=True, lang='de')
asyncio.get_event_loop().run_until_complete(main())
```
%package help
Summary: Development documents and examples for aiogTTS
Provides: python3-aiogTTS-doc
%description help
# aiogTTS [![PyPI version](https://img.shields.io/pypi/v/aiogTTS.svg)](https://pypi.org/project/aiogTTS/) [![Python versions](https://img.shields.io/pypi/pyversions/aiogTTS.svg)](https://pypi.org/project/aiogTTS/) [![Build Status](https://travis-ci.org/Helow19274/aiogTTS.svg?branch=master)](https://travis-ci.org/Helow19274/aiogTTS/)
**aiogTTS** (asynchronous Google Text-to-Speech), a Python library to interface with Google Translate's text-to-speech API.
Writes spoken mp3 data to a file or a file-like object (bytestring) for further audiomanipulation.
#### Original gTTS - (75% of this repo)
## Features
- Customizable speech-specific sentence tokenizer that allows for unlimited lengths of text to be read, all while keeping proper intonation, abbreviations, decimals and more;
- Customizable text pre-processors which can, for example, provide pronunciation corrections;
### Installation
```bash
$ pip install aiogTTS
```
### Quickstart
```python
import asyncio
from io import BytesIO
from aiogtts import aiogTTS
async def main():
aiogtts = aiogTTS()
io = BytesIO()
await aiogtts.save('Привет, мир!', 'audio.mp3', lang='ru')
await aiogtts.write_to_fp('Hallo!', io, slow=True, lang='de')
asyncio.get_event_loop().run_until_complete(main())
```
%prep
%autosetup -n aiogTTS-1.1.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-aiogTTS -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 10 2023 Python_Bot - 1.1.1-1
- Package Spec generated