%global _empty_manifest_terminate_build 0
Name: python-fastapi-restful
Version: 0.4.3
Release: 1
Summary: Quicker FastApi developing tools
License: MIT
URL: https://fastapi-restful.netlify.app
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/16/fd/a30b8776eb48767b0bf97028f0d88aea01911ee24d131f2be34225bf082d/FastApi-RESTful-0.4.3.tar.gz
BuildArch: noarch
Requires: python3-dataclasses
Requires: python3-fastapi
Requires: python3-psutil
Requires: python3-pydantic
Requires: python3-sqlalchemy
%description
**Documentation**: https://fastapi-restful.netlify.app
**Source Code**: https://github.com/yuval9313/fastapi-restful
%package -n python3-fastapi-restful
Summary: Quicker FastApi developing tools
Provides: python-fastapi-restful
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-fastapi-restful
**Documentation**: https://fastapi-restful.netlify.app
**Source Code**: https://github.com/yuval9313/fastapi-restful
%package help
Summary: Development documents and examples for fastapi-restful
Provides: python3-fastapi-restful-doc
%description help
**Documentation**: https://fastapi-restful.netlify.app
**Source Code**: https://github.com/yuval9313/fastapi-restful
%prep
%autosetup -n fastapi-restful-0.4.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-fastapi-restful -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 10 2023 Python_Bot - 0.4.3-1
- Package Spec generated