%global _empty_manifest_terminate_build 0 Name: python-svix Version: 0.84.1 Release: 1 Summary: Svix License: MIT URL: https://www.svix.com Source0: https://mirrors.nju.edu.cn/pypi/web/packages/02/ee/e6ac634d3302d32078cc25eb853db4c4c4915f01b157653287258bc16134/svix-0.84.1.tar.gz BuildArch: noarch %description

Svix - Webhooks as a service

Website | Documentation | Community Slack

Python library for interacting with the Svix API and verifying webhook signatures ![GitHub tag](https://img.shields.io/github/tag/svix/svix-webhooks.svg) [![PyPI](https://img.shields.io/pypi/v/svix.svg)](https://pypi.python.org/pypi/svix/) [![Join our slack](https://img.shields.io/badge/Slack-join%20the%20community-blue?logo=slack&style=social)](https://www.svix.com/slack/) # Usage Documentation You can find general usage documentation at . For complete API documentation with code examples for each endpoint in all of our official client libraries head over to our API documentation site at . # Language Support
⚡️ Features ⚡️
Officially Supported
API Support
Signature Verification
Caveats None! 🚀
# Installation ```sh pip install Svix ``` ## Usage Please refer to [the documentation](https://docs.svix.com/) or [the API reference](https://api.svix.com/docs) for more usage instructions. ### Async ```python from svix.api import SvixAsync, ApplicationIn svix = SvixAsync("AUTH_TOKEN") app = await svix.application.create(ApplicationIn(name="Application name")) ``` ### Sync ```python from svix.api import Svix, ApplicationIn svix = Svix("AUTH_TOKEN") app = svix.application.create(ApplicationIn(name="Application name")) ``` # Development First checkout the [core README](../README.md#development) for details on how to generate our API bindings, then follow the steps below. ## Requirements - python 3 ## Installing dependencies ```sh python -m venv .venv pip install -r requirements.txt && pip install -r requirements-dev.txt ./scripts/generate_openapi.sh ``` ## Contributing Before opening a PR be sure to format your code! ```sh ./scripts/format.sh ``` ## Running Tests Simply run: ```sh pytest ``` %package -n python3-svix Summary: Svix Provides: python-svix BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-svix

Svix - Webhooks as a service

Website | Documentation | Community Slack

Python library for interacting with the Svix API and verifying webhook signatures ![GitHub tag](https://img.shields.io/github/tag/svix/svix-webhooks.svg) [![PyPI](https://img.shields.io/pypi/v/svix.svg)](https://pypi.python.org/pypi/svix/) [![Join our slack](https://img.shields.io/badge/Slack-join%20the%20community-blue?logo=slack&style=social)](https://www.svix.com/slack/) # Usage Documentation You can find general usage documentation at . For complete API documentation with code examples for each endpoint in all of our official client libraries head over to our API documentation site at . # Language Support
⚡️ Features ⚡️
Officially Supported
API Support
Signature Verification
Caveats None! 🚀
# Installation ```sh pip install Svix ``` ## Usage Please refer to [the documentation](https://docs.svix.com/) or [the API reference](https://api.svix.com/docs) for more usage instructions. ### Async ```python from svix.api import SvixAsync, ApplicationIn svix = SvixAsync("AUTH_TOKEN") app = await svix.application.create(ApplicationIn(name="Application name")) ``` ### Sync ```python from svix.api import Svix, ApplicationIn svix = Svix("AUTH_TOKEN") app = svix.application.create(ApplicationIn(name="Application name")) ``` # Development First checkout the [core README](../README.md#development) for details on how to generate our API bindings, then follow the steps below. ## Requirements - python 3 ## Installing dependencies ```sh python -m venv .venv pip install -r requirements.txt && pip install -r requirements-dev.txt ./scripts/generate_openapi.sh ``` ## Contributing Before opening a PR be sure to format your code! ```sh ./scripts/format.sh ``` ## Running Tests Simply run: ```sh pytest ``` %package help Summary: Development documents and examples for svix Provides: python3-svix-doc %description help

Svix - Webhooks as a service

Website | Documentation | Community Slack

Python library for interacting with the Svix API and verifying webhook signatures ![GitHub tag](https://img.shields.io/github/tag/svix/svix-webhooks.svg) [![PyPI](https://img.shields.io/pypi/v/svix.svg)](https://pypi.python.org/pypi/svix/) [![Join our slack](https://img.shields.io/badge/Slack-join%20the%20community-blue?logo=slack&style=social)](https://www.svix.com/slack/) # Usage Documentation You can find general usage documentation at . For complete API documentation with code examples for each endpoint in all of our official client libraries head over to our API documentation site at . # Language Support
⚡️ Features ⚡️
Officially Supported
API Support
Signature Verification
Caveats None! 🚀
# Installation ```sh pip install Svix ``` ## Usage Please refer to [the documentation](https://docs.svix.com/) or [the API reference](https://api.svix.com/docs) for more usage instructions. ### Async ```python from svix.api import SvixAsync, ApplicationIn svix = SvixAsync("AUTH_TOKEN") app = await svix.application.create(ApplicationIn(name="Application name")) ``` ### Sync ```python from svix.api import Svix, ApplicationIn svix = Svix("AUTH_TOKEN") app = svix.application.create(ApplicationIn(name="Application name")) ``` # Development First checkout the [core README](../README.md#development) for details on how to generate our API bindings, then follow the steps below. ## Requirements - python 3 ## Installing dependencies ```sh python -m venv .venv pip install -r requirements.txt && pip install -r requirements-dev.txt ./scripts/generate_openapi.sh ``` ## Contributing Before opening a PR be sure to format your code! ```sh ./scripts/format.sh ``` ## Running Tests Simply run: ```sh pytest ``` %prep %autosetup -n svix-0.84.1 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-svix -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Wed May 10 2023 Python_Bot - 0.84.1-1 - Package Spec generated