%global _empty_manifest_terminate_build 0
Name:		python-operator-manifest
Version:	2.0.1
Release:	1
Summary:	please add a summary manually as the author left a blank one
License:	BSD-3-Clause
URL:		https://github.com/containerbuildsystem/operator-manifest
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/74/8a/06d943b4eb2bf55c79692c7779dcdceec1fbcb7ce78011ff38c77a73187e/operator-manifest-2.0.1.tar.gz
BuildArch:	noarch


%description
A python library for processing operator manifests.

%package -n python3-operator-manifest
Summary:	please add a summary manually as the author left a blank one
Provides:	python-operator-manifest
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-operator-manifest
A python library for processing operator manifests.

%package help
Summary:	Development documents and examples for operator-manifest
Provides:	python3-operator-manifest-doc
%description help
A python library for processing operator manifests.

%prep
%autosetup -n operator-manifest-2.0.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-operator-manifest -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 2.0.1-1
- Package Spec generated