%global _empty_manifest_terminate_build 0
Name: python-glypy
Version: 1.0.8
Release: 1
Summary: A Glycoinformatics Toolkit
License: Apache Software License
URL: https://github.com/mobiusklein/glypy
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/96/44/c3146665f579c7cf33cd125dc2a8318c585ce1fd3bd3da060f7c1d26613b/glypy-1.0.8.tar.gz
Requires: python3-hjson
Requires: python3-six
Requires: python3-requests
Requires: python3-SPARQLWrapper
Requires: python3-matplotlib
Requires: python3-rdflib
Requires: python3-requests
Requires: python3-rdflib
Requires: python3-SPARQLWrapper
Requires: python3-matplotlib
%description
|https://img.shields.io/travis/mobiusklein/glypy.svg| |Documentation
Status|
Glycobiology is the study of the biological functions, properties, and
structures of carbohydrate biomolecules, also called *glycans*. These
large, tree-like molecules are complex, having a wide variety of
building blocks as well as modifications and substitutions on those
building blocks.
`glypy` is a Python library providing code for reading, writing, and
manipulating glycan structures, glycan compositions, monosaccharides, and
their substituents. It also includes interfaces to popular glycan structure
databases, `GlyTouCan `_ and `UnicarbKB `_
using `SPARQL` queries and an RDF-object mapper.
Example Use Cases
~~~~~~~~~~~~~~~~~
1. Traverse structures using either canonical or residue-level rule
ordering.
2. Operate on monosaccharide and substituents as nodes and bonds as
edges.
3. Add, remove, and modify these structures to alter glycan properties.
4. Identify substructures and motifs, classifying glycans.
5. Evaluate structural similarities with one of several ordering and
comparator methods.
6. Plot tree structures with MatPlotLib, rendering using a configurable
symbol nomenclature, such as SNFG, CFG, or IUPAC. Layout using vector
graphics for lossless scaling.
7. Calculate the mass of a native or derivatized glycan.
8. Generate glycosidic and cross ring cleavage fragments for a
collection of glycan structures for performing MS/MS database search.
9. Perform substructure similarity searches with exact ordering or
topological comparison and exact or fuzzy per-residue matching to
classify a structure as an N-linked glycan.
10. Annotate MS spectra with glycan structures, labeling which peaks
matched a database entry.
11. Download all N-Glycans from `GlyTouCan `__
12. Find all glycans in a list which contain a particular subtree, or
find common subtrees in a database of glycans, performing treelet
enrichment analysis.
13. Synthesize all possible glycans using a set of enzymes starting from
a set of seed structures.
Citing
~~~~~~
If you use `glypy` in a publication please cite:
Klein, J., & Zaia, J. (2019). glypy - An open source glycoinformatics library.
Journal of Proteome Research.
https://doi.org/10.1021/acs.jproteome.9b00367
%package -n python3-glypy
Summary: A Glycoinformatics Toolkit
Provides: python-glypy
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
BuildRequires: python3-cffi
BuildRequires: gcc
BuildRequires: gdb
%description -n python3-glypy
|https://img.shields.io/travis/mobiusklein/glypy.svg| |Documentation
Status|
Glycobiology is the study of the biological functions, properties, and
structures of carbohydrate biomolecules, also called *glycans*. These
large, tree-like molecules are complex, having a wide variety of
building blocks as well as modifications and substitutions on those
building blocks.
`glypy` is a Python library providing code for reading, writing, and
manipulating glycan structures, glycan compositions, monosaccharides, and
their substituents. It also includes interfaces to popular glycan structure
databases, `GlyTouCan `_ and `UnicarbKB `_
using `SPARQL` queries and an RDF-object mapper.
Example Use Cases
~~~~~~~~~~~~~~~~~
1. Traverse structures using either canonical or residue-level rule
ordering.
2. Operate on monosaccharide and substituents as nodes and bonds as
edges.
3. Add, remove, and modify these structures to alter glycan properties.
4. Identify substructures and motifs, classifying glycans.
5. Evaluate structural similarities with one of several ordering and
comparator methods.
6. Plot tree structures with MatPlotLib, rendering using a configurable
symbol nomenclature, such as SNFG, CFG, or IUPAC. Layout using vector
graphics for lossless scaling.
7. Calculate the mass of a native or derivatized glycan.
8. Generate glycosidic and cross ring cleavage fragments for a
collection of glycan structures for performing MS/MS database search.
9. Perform substructure similarity searches with exact ordering or
topological comparison and exact or fuzzy per-residue matching to
classify a structure as an N-linked glycan.
10. Annotate MS spectra with glycan structures, labeling which peaks
matched a database entry.
11. Download all N-Glycans from `GlyTouCan `__
12. Find all glycans in a list which contain a particular subtree, or
find common subtrees in a database of glycans, performing treelet
enrichment analysis.
13. Synthesize all possible glycans using a set of enzymes starting from
a set of seed structures.
Citing
~~~~~~
If you use `glypy` in a publication please cite:
Klein, J., & Zaia, J. (2019). glypy - An open source glycoinformatics library.
Journal of Proteome Research.
https://doi.org/10.1021/acs.jproteome.9b00367
%package help
Summary: Development documents and examples for glypy
Provides: python3-glypy-doc
%description help
|https://img.shields.io/travis/mobiusklein/glypy.svg| |Documentation
Status|
Glycobiology is the study of the biological functions, properties, and
structures of carbohydrate biomolecules, also called *glycans*. These
large, tree-like molecules are complex, having a wide variety of
building blocks as well as modifications and substitutions on those
building blocks.
`glypy` is a Python library providing code for reading, writing, and
manipulating glycan structures, glycan compositions, monosaccharides, and
their substituents. It also includes interfaces to popular glycan structure
databases, `GlyTouCan `_ and `UnicarbKB `_
using `SPARQL` queries and an RDF-object mapper.
Example Use Cases
~~~~~~~~~~~~~~~~~
1. Traverse structures using either canonical or residue-level rule
ordering.
2. Operate on monosaccharide and substituents as nodes and bonds as
edges.
3. Add, remove, and modify these structures to alter glycan properties.
4. Identify substructures and motifs, classifying glycans.
5. Evaluate structural similarities with one of several ordering and
comparator methods.
6. Plot tree structures with MatPlotLib, rendering using a configurable
symbol nomenclature, such as SNFG, CFG, or IUPAC. Layout using vector
graphics for lossless scaling.
7. Calculate the mass of a native or derivatized glycan.
8. Generate glycosidic and cross ring cleavage fragments for a
collection of glycan structures for performing MS/MS database search.
9. Perform substructure similarity searches with exact ordering or
topological comparison and exact or fuzzy per-residue matching to
classify a structure as an N-linked glycan.
10. Annotate MS spectra with glycan structures, labeling which peaks
matched a database entry.
11. Download all N-Glycans from `GlyTouCan `__
12. Find all glycans in a list which contain a particular subtree, or
find common subtrees in a database of glycans, performing treelet
enrichment analysis.
13. Synthesize all possible glycans using a set of enzymes starting from
a set of seed structures.
Citing
~~~~~~
If you use `glypy` in a publication please cite:
Klein, J., & Zaia, J. (2019). glypy - An open source glycoinformatics library.
Journal of Proteome Research.
https://doi.org/10.1021/acs.jproteome.9b00367
%prep
%autosetup -n glypy-1.0.8
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-glypy -f filelist.lst
%dir %{python3_sitearch}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 10 2023 Python_Bot - 1.0.8-1
- Package Spec generated