%global _empty_manifest_terminate_build 0
Name:		python-habanero
Version:	1.2.3
Release:	1
Summary:	Low Level Client for Crossref Search API
License:	MIT
URL:		https://github.com/sckott/habanero
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/0b/f7/e33b8c041445aecc4f4f3149df0fa42363ac695d9872fb48dbdd161a8ff1/habanero-1.2.3.tar.gz
BuildArch:	noarch

Requires:	python3-requests
Requires:	python3-tqdm
Requires:	python3-pytest
Requires:	python3-pytest

%description
|pypi| |docs| |ghactions| |coverage| |black|
This is a low level client for working with Crossref's search API. It's been named to be more generic, as other organizations are/will adopt Crossref's search API, making it possible to interact with all from one client.
`Crossref API docs <https://github.com/CrossRef/rest-api-doc>`__
Other Crossref API clients:
- Ruby: `serrano`, `<https://github.com/sckott/serrano>`__
Crossref's API issue tracker: https://gitlab.com/crossref/issues
`habanero` includes three modules you can import as needed (or
import all):
`Crossref` - Crossref search API. The `Crossref` module includes methods matching Crossref API routes, and a few convenience methods for getting DOI agency and random DOIs:
- `works` - `/works` route
- `members` - `/members` route
- `prefixes` - `/prefixes` route
- `funders` - `/funders` route
- `journals` - `/journals` route
- `types` - `/types` route
- `licenses` - `/licenses` route
- `registration_agency` - get DOI minting agency
- `random_dois` - get random set of DOIs
`counts` - citation counts. Includes the single `citation_count` method
`cn` - content negotiation. Includes the methods:
- `content_negotiation` - get citations in a variety of formats
- `csl_styles` - get CSL styles, used in `content_negotation` method
`WorksContainer` - A class for handling Crossref works. Pass output of works from methods on the `Crossref` class to more easily extract specific fields of works. 
Note about searching:
You are using the Crossref search API described at https://api.crossref.org/swagger-ui/index.html. When you search with query terms, on Crossref servers they are not searching full text, or even abstracts of articles, but only what is available in the data that is returned to you. That is, they search article titles, authors, etc. For some discussion on this, see https://gitlab.com/crossref/issues/-/issues/101

%package -n python3-habanero
Summary:	Low Level Client for Crossref Search API
Provides:	python-habanero
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-habanero
|pypi| |docs| |ghactions| |coverage| |black|
This is a low level client for working with Crossref's search API. It's been named to be more generic, as other organizations are/will adopt Crossref's search API, making it possible to interact with all from one client.
`Crossref API docs <https://github.com/CrossRef/rest-api-doc>`__
Other Crossref API clients:
- Ruby: `serrano`, `<https://github.com/sckott/serrano>`__
Crossref's API issue tracker: https://gitlab.com/crossref/issues
`habanero` includes three modules you can import as needed (or
import all):
`Crossref` - Crossref search API. The `Crossref` module includes methods matching Crossref API routes, and a few convenience methods for getting DOI agency and random DOIs:
- `works` - `/works` route
- `members` - `/members` route
- `prefixes` - `/prefixes` route
- `funders` - `/funders` route
- `journals` - `/journals` route
- `types` - `/types` route
- `licenses` - `/licenses` route
- `registration_agency` - get DOI minting agency
- `random_dois` - get random set of DOIs
`counts` - citation counts. Includes the single `citation_count` method
`cn` - content negotiation. Includes the methods:
- `content_negotiation` - get citations in a variety of formats
- `csl_styles` - get CSL styles, used in `content_negotation` method
`WorksContainer` - A class for handling Crossref works. Pass output of works from methods on the `Crossref` class to more easily extract specific fields of works. 
Note about searching:
You are using the Crossref search API described at https://api.crossref.org/swagger-ui/index.html. When you search with query terms, on Crossref servers they are not searching full text, or even abstracts of articles, but only what is available in the data that is returned to you. That is, they search article titles, authors, etc. For some discussion on this, see https://gitlab.com/crossref/issues/-/issues/101

%package help
Summary:	Development documents and examples for habanero
Provides:	python3-habanero-doc
%description help
|pypi| |docs| |ghactions| |coverage| |black|
This is a low level client for working with Crossref's search API. It's been named to be more generic, as other organizations are/will adopt Crossref's search API, making it possible to interact with all from one client.
`Crossref API docs <https://github.com/CrossRef/rest-api-doc>`__
Other Crossref API clients:
- Ruby: `serrano`, `<https://github.com/sckott/serrano>`__
Crossref's API issue tracker: https://gitlab.com/crossref/issues
`habanero` includes three modules you can import as needed (or
import all):
`Crossref` - Crossref search API. The `Crossref` module includes methods matching Crossref API routes, and a few convenience methods for getting DOI agency and random DOIs:
- `works` - `/works` route
- `members` - `/members` route
- `prefixes` - `/prefixes` route
- `funders` - `/funders` route
- `journals` - `/journals` route
- `types` - `/types` route
- `licenses` - `/licenses` route
- `registration_agency` - get DOI minting agency
- `random_dois` - get random set of DOIs
`counts` - citation counts. Includes the single `citation_count` method
`cn` - content negotiation. Includes the methods:
- `content_negotiation` - get citations in a variety of formats
- `csl_styles` - get CSL styles, used in `content_negotation` method
`WorksContainer` - A class for handling Crossref works. Pass output of works from methods on the `Crossref` class to more easily extract specific fields of works. 
Note about searching:
You are using the Crossref search API described at https://api.crossref.org/swagger-ui/index.html. When you search with query terms, on Crossref servers they are not searching full text, or even abstracts of articles, but only what is available in the data that is returned to you. That is, they search article titles, authors, etc. For some discussion on this, see https://gitlab.com/crossref/issues/-/issues/101

%prep
%autosetup -n habanero-1.2.3

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-habanero -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.3-1
- Package Spec generated