%global _empty_manifest_terminate_build 0
Name:		python-prefixcommons
Version:	0.1.12
Release:	1
Summary:	A python API for working with ID prefixes
License:	BSD License
URL:		https://github.com/prefixcommons/prefixcommons-py
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/7d/b5/c5b63a4bf5dedb36567181fdb98dbcc7aaa025faebabaaffa2f5eb4b8feb/prefixcommons-0.1.12.tar.gz
BuildArch:	noarch

Requires:	python3-requests
Requires:	python3-click
Requires:	python3-pytest-logging
Requires:	python3-PyYAML

%description
A python API for working with ID prefixes in the context of
`prefixcommons <http://prefixcommons.org>`__
Current functionality: Uses JSON-LD contexts to expand and contract
CURIEs to URIs
E.g. GO:0008150 <=> http://purl.obolibrary.org/obo/GO\_0008150

%package -n python3-prefixcommons
Summary:	A python API for working with ID prefixes
Provides:	python-prefixcommons
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-prefixcommons
A python API for working with ID prefixes in the context of
`prefixcommons <http://prefixcommons.org>`__
Current functionality: Uses JSON-LD contexts to expand and contract
CURIEs to URIs
E.g. GO:0008150 <=> http://purl.obolibrary.org/obo/GO\_0008150

%package help
Summary:	Development documents and examples for prefixcommons
Provides:	python3-prefixcommons-doc
%description help
A python API for working with ID prefixes in the context of
`prefixcommons <http://prefixcommons.org>`__
Current functionality: Uses JSON-LD contexts to expand and contract
CURIEs to URIs
E.g. GO:0008150 <=> http://purl.obolibrary.org/obo/GO\_0008150

%prep
%autosetup -n prefixcommons-0.1.12

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-prefixcommons -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.12-1
- Package Spec generated