%global _empty_manifest_terminate_build 0
Name:		python-teacup-visualization-back
Version:	1.0.0
Release:	1
Summary:	Teacup visualization back-end written in Python
License:	MIT License
URL:		https://github.com/HenryssonDaniel/teacup-visualization-web-back-python
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/f0/e2/bdcd3a18b1b422909a6967d8ab3512d21a1bccdbba77b968ad74e1f3d4bc/teacup-visualization-back-1.0.0.tar.gz
BuildArch:	noarch

Requires:	python3-flask
Requires:	python3-flask-cors
Requires:	python3-Flask-Session
Requires:	python3-itsdangerous
Requires:	python3-requests

%description
# [User Guide](https://henryssondaniel.github.io/teacup.github.io/)
**Te**sting Fr**a**mework for **C**omm**u**nication **P**rotocols and Web Services with visualization web back-end in Python

[![Build Status](https://travis-ci.com/HenryssonDaniel/teacup-visualization-web-back-python.svg?branch=master)](https://travis-ci.com/HenryssonDaniel/teacup-visualization-web-back-python)
[![Coverage](https://sonarcloud.io/api/project_badges/measure?project=HenryssonDaniel_teacup-visualization-web-back-python&metric=coverage)](https://sonarcloud.io/dashboard?id=HenryssonDaniel_teacup-visualization-web-back-python)
[![latest release](https://img.shields.io/badge/release%20notes-1.0.0-yellow.svg)](https://github.com/HenryssonDaniel/teacup-visualization-web-back-python/blob/master/CHANGES.rst)
[![PyPi](https://img.shields.io/pypi/v/teacup-visualization-back.svg)](https://pypi.org/project/teacup-visualization-back/)
## What ##
Visualization web back-end written in Python.
## Why ##
This project is needed so that the web front-end can interact with the server side and other Teacup projects.
## How ##
Follow the steps below:
1. pip install teacup-visualization-back
1. [The flask command](http://flask.pocoo.org/docs/1.0/tutorial/factory/#run-the-application)
1. [Configure](http://flask.pocoo.org/docs/1.0/tutorial/deploy/#configure-the-secret-key)
1. [Run the application](http://flask.pocoo.org/docs/1.0/tutorial/deploy/#run-with-a-production-server)

For developers:
1. [Run the application](http://flask.pocoo.org/docs/1.0/tutorial/factory/#run-the-application)



%package -n python3-teacup-visualization-back
Summary:	Teacup visualization back-end written in Python
Provides:	python-teacup-visualization-back
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-teacup-visualization-back
# [User Guide](https://henryssondaniel.github.io/teacup.github.io/)
**Te**sting Fr**a**mework for **C**omm**u**nication **P**rotocols and Web Services with visualization web back-end in Python

[![Build Status](https://travis-ci.com/HenryssonDaniel/teacup-visualization-web-back-python.svg?branch=master)](https://travis-ci.com/HenryssonDaniel/teacup-visualization-web-back-python)
[![Coverage](https://sonarcloud.io/api/project_badges/measure?project=HenryssonDaniel_teacup-visualization-web-back-python&metric=coverage)](https://sonarcloud.io/dashboard?id=HenryssonDaniel_teacup-visualization-web-back-python)
[![latest release](https://img.shields.io/badge/release%20notes-1.0.0-yellow.svg)](https://github.com/HenryssonDaniel/teacup-visualization-web-back-python/blob/master/CHANGES.rst)
[![PyPi](https://img.shields.io/pypi/v/teacup-visualization-back.svg)](https://pypi.org/project/teacup-visualization-back/)
## What ##
Visualization web back-end written in Python.
## Why ##
This project is needed so that the web front-end can interact with the server side and other Teacup projects.
## How ##
Follow the steps below:
1. pip install teacup-visualization-back
1. [The flask command](http://flask.pocoo.org/docs/1.0/tutorial/factory/#run-the-application)
1. [Configure](http://flask.pocoo.org/docs/1.0/tutorial/deploy/#configure-the-secret-key)
1. [Run the application](http://flask.pocoo.org/docs/1.0/tutorial/deploy/#run-with-a-production-server)

For developers:
1. [Run the application](http://flask.pocoo.org/docs/1.0/tutorial/factory/#run-the-application)



%package help
Summary:	Development documents and examples for teacup-visualization-back
Provides:	python3-teacup-visualization-back-doc
%description help
# [User Guide](https://henryssondaniel.github.io/teacup.github.io/)
**Te**sting Fr**a**mework for **C**omm**u**nication **P**rotocols and Web Services with visualization web back-end in Python

[![Build Status](https://travis-ci.com/HenryssonDaniel/teacup-visualization-web-back-python.svg?branch=master)](https://travis-ci.com/HenryssonDaniel/teacup-visualization-web-back-python)
[![Coverage](https://sonarcloud.io/api/project_badges/measure?project=HenryssonDaniel_teacup-visualization-web-back-python&metric=coverage)](https://sonarcloud.io/dashboard?id=HenryssonDaniel_teacup-visualization-web-back-python)
[![latest release](https://img.shields.io/badge/release%20notes-1.0.0-yellow.svg)](https://github.com/HenryssonDaniel/teacup-visualization-web-back-python/blob/master/CHANGES.rst)
[![PyPi](https://img.shields.io/pypi/v/teacup-visualization-back.svg)](https://pypi.org/project/teacup-visualization-back/)
## What ##
Visualization web back-end written in Python.
## Why ##
This project is needed so that the web front-end can interact with the server side and other Teacup projects.
## How ##
Follow the steps below:
1. pip install teacup-visualization-back
1. [The flask command](http://flask.pocoo.org/docs/1.0/tutorial/factory/#run-the-application)
1. [Configure](http://flask.pocoo.org/docs/1.0/tutorial/deploy/#configure-the-secret-key)
1. [Run the application](http://flask.pocoo.org/docs/1.0/tutorial/deploy/#run-with-a-production-server)

For developers:
1. [Run the application](http://flask.pocoo.org/docs/1.0/tutorial/factory/#run-the-application)



%prep
%autosetup -n teacup-visualization-back-1.0.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-teacup-visualization-back -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.0-1
- Package Spec generated