%global _empty_manifest_terminate_build 0
Name:		python-serialized-redis-interface
Version:	0.3.1
Release:	1
Summary:	Redis python interface that serializes all values using json, pickle, msgpack or a custom serializer.
License:	MIT
URL:		https://github.com/michael-mri/serialized-redis
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/03/91/e8433f5bda98e3a8c2c6829cb8c1e285d30ab8a1345189c85df600e7f708/serialized-redis-interface-0.3.1.tar.gz
BuildArch:	noarch

Requires:	python3-redis
Requires:	python3-msgpack

%description
Redis python interface that serializes all values using json, pickle, msgpack or a custom serializer.

%package -n python3-serialized-redis-interface
Summary:	Redis python interface that serializes all values using json, pickle, msgpack or a custom serializer.
Provides:	python-serialized-redis-interface
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-serialized-redis-interface
Redis python interface that serializes all values using json, pickle, msgpack or a custom serializer.

%package help
Summary:	Development documents and examples for serialized-redis-interface
Provides:	python3-serialized-redis-interface-doc
%description help
Redis python interface that serializes all values using json, pickle, msgpack or a custom serializer.

%prep
%autosetup -n serialized-redis-interface-0.3.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-serialized-redis-interface -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.1-1
- Package Spec generated