%global _empty_manifest_terminate_build 0
Name: python-termgraph
Version: 0.5.3
Release: 1
Summary: A command-line tool that draws basic graphs in the terminal.
License: MIT
URL: https://github.com/mkaz/termgraph
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/30/34/564eb11868f30102ddba7b41eff299abf2d6d25f4448765c730d65f328a1/termgraph-0.5.3.tar.gz
BuildArch: noarch
Requires: python3-colorama
%description
# Termgraph
A command-line tool that draws basic graphs in the terminal, written in Python.
Graph types supported:
- Bar Graphs
- Color charts
- Multi-variable
- Stacked charts
- Histograms
- Horizontal or Vertical
- Emoji!
### Examples
```
termgraph data/ex1.dat
# Reading data from data/ex1.dat
2007: ▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇ 183.32
2008: ▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇ 231.23
2009: ▇ 16.43
2010: ▇▇▇▇ 50.21
2011: ▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇ 508.97
2012: ▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇ 212.05
2014: ▏ 1.00
```
An example using emoji as custom tick:
```
termgraph data/ex1.dat --custom-tick "🏃" --width 20 --title "Running Data"
# Running Data
2007: 🏃🏃🏃🏃🏃🏃🏃 183.32
2008: 🏃🏃🏃🏃🏃🏃🏃🏃🏃 231.23
2009: 16.43
2010: 🏃 50.21
2011: 🏃🏃🏃🏃🏃🏃🏃🏃🏃🏃🏃🏃🏃🏃🏃🏃🏃🏃🏃🏃 508.97
2012: 🏃🏃🏃🏃🏃🏃🏃🏃 212.05
2014: 1.00
```
An example using stdin and emoji:
```
echo "Label,3,9,1" | termgraph --custom-tick "😀" --no-label
😀😀😀 3.00
😀😀😀😀😀😀😀😀😀 9.00
😀 1.00
```
Most results can be copied and pasted wherever you like, since they use standard block characters. However the color charts will not show, since they use terminal escape codes for color. A couple images to show color examples:
```
termgraph data/ex4.dat --color {blue,red}
```
```
termgraph data/ex7.dat --color {yellow,magenta} --stacked --title "Stacked Data"
```
Calendar Heatmap, expects first column to be date in yyyy-mm-dd
```
termgraph --calendar --start-dt 2017-07-01 data/cal.dat
```
### Install
Requires Python 3.7+, install from [PyPI project](https://pypi.org/project/termgraph/)
```
python3 -m pip install termgraph
```
Note: Be sure your PATH includes the pypi install directory, for me it is `~/.local/bin/`
### Usage
* Create data file with two columns either comma or space separated.
The first column is your labels, the second column is a numeric data
* termgraph [datafile]
* Help: termgraph -h
```
usage: termgraph.py [-h] [(optional arguments)] [filename]
draw basic graphs on terminal
positional arguments:
filename data file name (comma or space separated). Defaults to stdin.
optional arguments:
-h, --help show this help message and exit
--title TITLE Title of graph
--width WIDTH width of graph in characters default:50
--format FORMAT format specifier to use.
--suffix SUFFIX string to add as a suffix to all data points.
--no-labels Do not print the label column
--no-values Do not print the values at end
--space-between Print a new line after every field
--color [COLOR ...] Graph bar color( s )
--vertical Vertical graph
--stacked Stacked bar graph
--histogram Histogram
--bins BINS Bins of Histogram
--different-scale Categories have different scales.
--calendar Calendar Heatmap chart
--start-dt START_DT Start date for Calendar chart
--custom-tick CUSTOM_TICK
Custom tick mark, emoji approved
--delim DELIM Custom delimiter, default , or space
--verbose Verbose output, helpful for debugging
--label-before Display the values before the bars
--version Display version and exit
```
### Background
I wanted a quick way to visualize data stored in a simple text file. I initially created some scripts in R that generated graphs but this was a two step process of creating the graph and then opening the generated graph.
After seeing [command-line sparklines](https://github.com/holman/spark) I figured I could do the same thing using block characters for bar charts.
### Contribute
All contributions are welcome, for feature requests or bug reports, use [Github Issues](https://github.com/mkaz/termgraph/issues). Pull requests are welcome to help fix or add features.
**Code contributions**: This repository uses the [black code formatter](https://github.com/psf/black) to automatically format the code. A Github Action is setup to lint your code, to avoid failures it is recommended to [setup your editor to auto format on save](https://github.com/psf/black/blob/master/docs/editor_integration.md).
Thanks to all the [contributors](https://github.com/mkaz/termgraph/graphs/contributors)!
### License
MIT License, see [LICENSE.txt](LICENSE.txt)
%package -n python3-termgraph
Summary: A command-line tool that draws basic graphs in the terminal.
Provides: python-termgraph
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-termgraph
# Termgraph
A command-line tool that draws basic graphs in the terminal, written in Python.
Graph types supported:
- Bar Graphs
- Color charts
- Multi-variable
- Stacked charts
- Histograms
- Horizontal or Vertical
- Emoji!
### Examples
```
termgraph data/ex1.dat
# Reading data from data/ex1.dat
2007: ▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇ 183.32
2008: ▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇ 231.23
2009: ▇ 16.43
2010: ▇▇▇▇ 50.21
2011: ▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇ 508.97
2012: ▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇ 212.05
2014: ▏ 1.00
```
An example using emoji as custom tick:
```
termgraph data/ex1.dat --custom-tick "🏃" --width 20 --title "Running Data"
# Running Data
2007: 🏃🏃🏃🏃🏃🏃🏃 183.32
2008: 🏃🏃🏃🏃🏃🏃🏃🏃🏃 231.23
2009: 16.43
2010: 🏃 50.21
2011: 🏃🏃🏃🏃🏃🏃🏃🏃🏃🏃🏃🏃🏃🏃🏃🏃🏃🏃🏃🏃 508.97
2012: 🏃🏃🏃🏃🏃🏃🏃🏃 212.05
2014: 1.00
```
An example using stdin and emoji:
```
echo "Label,3,9,1" | termgraph --custom-tick "😀" --no-label
😀😀😀 3.00
😀😀😀😀😀😀😀😀😀 9.00
😀 1.00
```
Most results can be copied and pasted wherever you like, since they use standard block characters. However the color charts will not show, since they use terminal escape codes for color. A couple images to show color examples:
```
termgraph data/ex4.dat --color {blue,red}
```
```
termgraph data/ex7.dat --color {yellow,magenta} --stacked --title "Stacked Data"
```
Calendar Heatmap, expects first column to be date in yyyy-mm-dd
```
termgraph --calendar --start-dt 2017-07-01 data/cal.dat
```
### Install
Requires Python 3.7+, install from [PyPI project](https://pypi.org/project/termgraph/)
```
python3 -m pip install termgraph
```
Note: Be sure your PATH includes the pypi install directory, for me it is `~/.local/bin/`
### Usage
* Create data file with two columns either comma or space separated.
The first column is your labels, the second column is a numeric data
* termgraph [datafile]
* Help: termgraph -h
```
usage: termgraph.py [-h] [(optional arguments)] [filename]
draw basic graphs on terminal
positional arguments:
filename data file name (comma or space separated). Defaults to stdin.
optional arguments:
-h, --help show this help message and exit
--title TITLE Title of graph
--width WIDTH width of graph in characters default:50
--format FORMAT format specifier to use.
--suffix SUFFIX string to add as a suffix to all data points.
--no-labels Do not print the label column
--no-values Do not print the values at end
--space-between Print a new line after every field
--color [COLOR ...] Graph bar color( s )
--vertical Vertical graph
--stacked Stacked bar graph
--histogram Histogram
--bins BINS Bins of Histogram
--different-scale Categories have different scales.
--calendar Calendar Heatmap chart
--start-dt START_DT Start date for Calendar chart
--custom-tick CUSTOM_TICK
Custom tick mark, emoji approved
--delim DELIM Custom delimiter, default , or space
--verbose Verbose output, helpful for debugging
--label-before Display the values before the bars
--version Display version and exit
```
### Background
I wanted a quick way to visualize data stored in a simple text file. I initially created some scripts in R that generated graphs but this was a two step process of creating the graph and then opening the generated graph.
After seeing [command-line sparklines](https://github.com/holman/spark) I figured I could do the same thing using block characters for bar charts.
### Contribute
All contributions are welcome, for feature requests or bug reports, use [Github Issues](https://github.com/mkaz/termgraph/issues). Pull requests are welcome to help fix or add features.
**Code contributions**: This repository uses the [black code formatter](https://github.com/psf/black) to automatically format the code. A Github Action is setup to lint your code, to avoid failures it is recommended to [setup your editor to auto format on save](https://github.com/psf/black/blob/master/docs/editor_integration.md).
Thanks to all the [contributors](https://github.com/mkaz/termgraph/graphs/contributors)!
### License
MIT License, see [LICENSE.txt](LICENSE.txt)
%package help
Summary: Development documents and examples for termgraph
Provides: python3-termgraph-doc
%description help
# Termgraph
A command-line tool that draws basic graphs in the terminal, written in Python.
Graph types supported:
- Bar Graphs
- Color charts
- Multi-variable
- Stacked charts
- Histograms
- Horizontal or Vertical
- Emoji!
### Examples
```
termgraph data/ex1.dat
# Reading data from data/ex1.dat
2007: ▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇ 183.32
2008: ▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇ 231.23
2009: ▇ 16.43
2010: ▇▇▇▇ 50.21
2011: ▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇ 508.97
2012: ▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇ 212.05
2014: ▏ 1.00
```
An example using emoji as custom tick:
```
termgraph data/ex1.dat --custom-tick "🏃" --width 20 --title "Running Data"
# Running Data
2007: 🏃🏃🏃🏃🏃🏃🏃 183.32
2008: 🏃🏃🏃🏃🏃🏃🏃🏃🏃 231.23
2009: 16.43
2010: 🏃 50.21
2011: 🏃🏃🏃🏃🏃🏃🏃🏃🏃🏃🏃🏃🏃🏃🏃🏃🏃🏃🏃🏃 508.97
2012: 🏃🏃🏃🏃🏃🏃🏃🏃 212.05
2014: 1.00
```
An example using stdin and emoji:
```
echo "Label,3,9,1" | termgraph --custom-tick "😀" --no-label
😀😀😀 3.00
😀😀😀😀😀😀😀😀😀 9.00
😀 1.00
```
Most results can be copied and pasted wherever you like, since they use standard block characters. However the color charts will not show, since they use terminal escape codes for color. A couple images to show color examples:
```
termgraph data/ex4.dat --color {blue,red}
```
```
termgraph data/ex7.dat --color {yellow,magenta} --stacked --title "Stacked Data"
```
Calendar Heatmap, expects first column to be date in yyyy-mm-dd
```
termgraph --calendar --start-dt 2017-07-01 data/cal.dat
```
### Install
Requires Python 3.7+, install from [PyPI project](https://pypi.org/project/termgraph/)
```
python3 -m pip install termgraph
```
Note: Be sure your PATH includes the pypi install directory, for me it is `~/.local/bin/`
### Usage
* Create data file with two columns either comma or space separated.
The first column is your labels, the second column is a numeric data
* termgraph [datafile]
* Help: termgraph -h
```
usage: termgraph.py [-h] [(optional arguments)] [filename]
draw basic graphs on terminal
positional arguments:
filename data file name (comma or space separated). Defaults to stdin.
optional arguments:
-h, --help show this help message and exit
--title TITLE Title of graph
--width WIDTH width of graph in characters default:50
--format FORMAT format specifier to use.
--suffix SUFFIX string to add as a suffix to all data points.
--no-labels Do not print the label column
--no-values Do not print the values at end
--space-between Print a new line after every field
--color [COLOR ...] Graph bar color( s )
--vertical Vertical graph
--stacked Stacked bar graph
--histogram Histogram
--bins BINS Bins of Histogram
--different-scale Categories have different scales.
--calendar Calendar Heatmap chart
--start-dt START_DT Start date for Calendar chart
--custom-tick CUSTOM_TICK
Custom tick mark, emoji approved
--delim DELIM Custom delimiter, default , or space
--verbose Verbose output, helpful for debugging
--label-before Display the values before the bars
--version Display version and exit
```
### Background
I wanted a quick way to visualize data stored in a simple text file. I initially created some scripts in R that generated graphs but this was a two step process of creating the graph and then opening the generated graph.
After seeing [command-line sparklines](https://github.com/holman/spark) I figured I could do the same thing using block characters for bar charts.
### Contribute
All contributions are welcome, for feature requests or bug reports, use [Github Issues](https://github.com/mkaz/termgraph/issues). Pull requests are welcome to help fix or add features.
**Code contributions**: This repository uses the [black code formatter](https://github.com/psf/black) to automatically format the code. A Github Action is setup to lint your code, to avoid failures it is recommended to [setup your editor to auto format on save](https://github.com/psf/black/blob/master/docs/editor_integration.md).
Thanks to all the [contributors](https://github.com/mkaz/termgraph/graphs/contributors)!
### License
MIT License, see [LICENSE.txt](LICENSE.txt)
%prep
%autosetup -n termgraph-0.5.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-termgraph -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 10 2023 Python_Bot - 0.5.3-1
- Package Spec generated