%global _empty_manifest_terminate_build 0
Name: python-AnkiIn
Version: 0.1.7
Release: 1
Summary: Import markdown to Anki
License: MIT License
URL: https://github.com/clouder0/AnkiIn
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/7e/da/b7dfef2ea7ef449b321d176615d08e1e671783c7865aec1539a63c7d8d80/AnkiIn-0.1.7.tar.gz
BuildArch: noarch
Requires: python3-genanki
Requires: python3-markdown2
Requires: python3-requests
Requires: python3-aiohttp
Requires: python3-toml
%description
To use this lib, you are not required to sacrifice your note readability for compatibility with Anki.
Here is a quick example:
```markdown
This is a question.
This is an answer.
Single line question.
Multiple line answer.
The first line of this block is recognized as the question.
Multiple line question is
possible somehow.
too hacky maybe.
markdown rendering is supported.
- use a list!
- or something like that.
Clozes are **easy** to **create** too.
```
## Installation
You can install by pip:
```bash
pip install AnkiIn
```
### install Anki Connect
To use the lib, you need to install [AnkiConnect](https://github.com/FooSoft/anki-connect) extension.
Code:`2055492159`
For detailed installation guide, please visit the [anki-connect repo](https://github.com/FooSoft/anki-connect).
## Usage
You can review [AnkiLink](https://github.com/Clouder0/AnkiLink) to understand how this works.
Also, [AnkiIn Wiki](https://github.com/Clouder0/AnkiIn/wiki) is under construction.
For more syntax examples, see [tests](https://github.com/Clouder0/AnkiIn/tree/main/tests).
## Applications
I'd like to list some applications using AnkiIn here.
If you want to add yours, please create an issue/pull request.
- [AnkiLink](https://github.com/Clouder0/AnkiLink)
## Credit
- [anki](https://github.com/ankitects/anki)
- [anki-connect](https://github.com/FooSoft/anki-connect)
- [genanki](https://github.com/kerrickstaley/genanki)
- [markdown2](https://github.com/trentm/python-markdown2)
## License
The source code is licensed under MIT.
License is available [here](https://github.com/Clouder0/AnkiIn/blob/main/LICENSE).
[contributors-shield]: https://img.shields.io/github/contributors/Clouder0/AnkiIn.svg
[contributors-url]: https://github.com/Clouder0/AnkiIn/graphs/contributors
[forks-shield]: https://img.shields.io/github/forks/Clouder0/AnkiIn.svg
[forks-url]: https://github.com/Clouder0/AnkiIn/network/members
[stars-shield]: https://img.shields.io/github/stars/Clouder0/AnkiIn.svg
[stars-url]: https://github.com/Clouder0/AnkiIn/stargazers
[issues-shield]: https://img.shields.io/github/issues/Clouder0/AnkiIn.svg
[issues-url]: https://github.com/Clouder0/AnkiIn/issues
[license-shield]: https://img.shields.io/github/license/Clouder0/AnkiIn.svg
[license-url]: https://github.com/Clouder0/AnkiIn/blob/main/LICENSE
[release-shield]: https://img.shields.io/github/release/Clouder0/AnkiIn.svg
[release-url]: https://github.com/Clouder0/AnkiIn/releases
[codefactor-shield]: https://www.codefactor.io/repository/github/clouder0/AnkiIn/badge/main
[codefactor-url]: https://www.codefactor.io/repository/github/clouder0/AnkiIn/overview/main
%package -n python3-AnkiIn
Summary: Import markdown to Anki
Provides: python-AnkiIn
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-AnkiIn
To use this lib, you are not required to sacrifice your note readability for compatibility with Anki.
Here is a quick example:
```markdown
This is a question.
This is an answer.
Single line question.
Multiple line answer.
The first line of this block is recognized as the question.
Multiple line question is
possible somehow.
too hacky maybe.
markdown rendering is supported.
- use a list!
- or something like that.
Clozes are **easy** to **create** too.
```
## Installation
You can install by pip:
```bash
pip install AnkiIn
```
### install Anki Connect
To use the lib, you need to install [AnkiConnect](https://github.com/FooSoft/anki-connect) extension.
Code:`2055492159`
For detailed installation guide, please visit the [anki-connect repo](https://github.com/FooSoft/anki-connect).
## Usage
You can review [AnkiLink](https://github.com/Clouder0/AnkiLink) to understand how this works.
Also, [AnkiIn Wiki](https://github.com/Clouder0/AnkiIn/wiki) is under construction.
For more syntax examples, see [tests](https://github.com/Clouder0/AnkiIn/tree/main/tests).
## Applications
I'd like to list some applications using AnkiIn here.
If you want to add yours, please create an issue/pull request.
- [AnkiLink](https://github.com/Clouder0/AnkiLink)
## Credit
- [anki](https://github.com/ankitects/anki)
- [anki-connect](https://github.com/FooSoft/anki-connect)
- [genanki](https://github.com/kerrickstaley/genanki)
- [markdown2](https://github.com/trentm/python-markdown2)
## License
The source code is licensed under MIT.
License is available [here](https://github.com/Clouder0/AnkiIn/blob/main/LICENSE).
[contributors-shield]: https://img.shields.io/github/contributors/Clouder0/AnkiIn.svg
[contributors-url]: https://github.com/Clouder0/AnkiIn/graphs/contributors
[forks-shield]: https://img.shields.io/github/forks/Clouder0/AnkiIn.svg
[forks-url]: https://github.com/Clouder0/AnkiIn/network/members
[stars-shield]: https://img.shields.io/github/stars/Clouder0/AnkiIn.svg
[stars-url]: https://github.com/Clouder0/AnkiIn/stargazers
[issues-shield]: https://img.shields.io/github/issues/Clouder0/AnkiIn.svg
[issues-url]: https://github.com/Clouder0/AnkiIn/issues
[license-shield]: https://img.shields.io/github/license/Clouder0/AnkiIn.svg
[license-url]: https://github.com/Clouder0/AnkiIn/blob/main/LICENSE
[release-shield]: https://img.shields.io/github/release/Clouder0/AnkiIn.svg
[release-url]: https://github.com/Clouder0/AnkiIn/releases
[codefactor-shield]: https://www.codefactor.io/repository/github/clouder0/AnkiIn/badge/main
[codefactor-url]: https://www.codefactor.io/repository/github/clouder0/AnkiIn/overview/main
%package help
Summary: Development documents and examples for AnkiIn
Provides: python3-AnkiIn-doc
%description help
To use this lib, you are not required to sacrifice your note readability for compatibility with Anki.
Here is a quick example:
```markdown
This is a question.
This is an answer.
Single line question.
Multiple line answer.
The first line of this block is recognized as the question.
Multiple line question is
possible somehow.
too hacky maybe.
markdown rendering is supported.
- use a list!
- or something like that.
Clozes are **easy** to **create** too.
```
## Installation
You can install by pip:
```bash
pip install AnkiIn
```
### install Anki Connect
To use the lib, you need to install [AnkiConnect](https://github.com/FooSoft/anki-connect) extension.
Code:`2055492159`
For detailed installation guide, please visit the [anki-connect repo](https://github.com/FooSoft/anki-connect).
## Usage
You can review [AnkiLink](https://github.com/Clouder0/AnkiLink) to understand how this works.
Also, [AnkiIn Wiki](https://github.com/Clouder0/AnkiIn/wiki) is under construction.
For more syntax examples, see [tests](https://github.com/Clouder0/AnkiIn/tree/main/tests).
## Applications
I'd like to list some applications using AnkiIn here.
If you want to add yours, please create an issue/pull request.
- [AnkiLink](https://github.com/Clouder0/AnkiLink)
## Credit
- [anki](https://github.com/ankitects/anki)
- [anki-connect](https://github.com/FooSoft/anki-connect)
- [genanki](https://github.com/kerrickstaley/genanki)
- [markdown2](https://github.com/trentm/python-markdown2)
## License
The source code is licensed under MIT.
License is available [here](https://github.com/Clouder0/AnkiIn/blob/main/LICENSE).
[contributors-shield]: https://img.shields.io/github/contributors/Clouder0/AnkiIn.svg
[contributors-url]: https://github.com/Clouder0/AnkiIn/graphs/contributors
[forks-shield]: https://img.shields.io/github/forks/Clouder0/AnkiIn.svg
[forks-url]: https://github.com/Clouder0/AnkiIn/network/members
[stars-shield]: https://img.shields.io/github/stars/Clouder0/AnkiIn.svg
[stars-url]: https://github.com/Clouder0/AnkiIn/stargazers
[issues-shield]: https://img.shields.io/github/issues/Clouder0/AnkiIn.svg
[issues-url]: https://github.com/Clouder0/AnkiIn/issues
[license-shield]: https://img.shields.io/github/license/Clouder0/AnkiIn.svg
[license-url]: https://github.com/Clouder0/AnkiIn/blob/main/LICENSE
[release-shield]: https://img.shields.io/github/release/Clouder0/AnkiIn.svg
[release-url]: https://github.com/Clouder0/AnkiIn/releases
[codefactor-shield]: https://www.codefactor.io/repository/github/clouder0/AnkiIn/badge/main
[codefactor-url]: https://www.codefactor.io/repository/github/clouder0/AnkiIn/overview/main
%prep
%autosetup -n AnkiIn-0.1.7
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-AnkiIn -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon May 15 2023 Python_Bot - 0.1.7-1
- Package Spec generated