%global _empty_manifest_terminate_build 0
Name: python-binance.py
Version: 1.9.0
Release: 1
Summary: A python3 binance API wrapper powered by modern technologies such as asyncio
License: MIT License
URL: https://git.io/binance.py
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/29/43/1303a389b78466fcedf915fe05e2d12082dd8115e7a7857325ebc97d0078/binance.py-1.9.0.tar.gz
BuildArch: noarch
Requires: python3-aiohttp
%description
🦾 A python3 binance API wrapper powered by asyncio and python Decimals.
## Get binance.py
To install the library, you can just run the following command:
```console
# Linux/macOS
python3 -m pip install -U binance.py
# Windows
py -3 -m pip install -U binance.py
```
Alternatively you can build the package and install it manually:
```
python setup.py sdist bdist_wheel
python -m pip install dist/binance.py-X.X.X-py3-none-any.whl
```
## Why binance.py?
The binance api is complex to grasp and using a wrapper saves time but also ensures that the right practices are adopted. Binance.py offers a modern and asynchronous solution.
## Features
- Covers general endpoints (test connectivity and get exchange informations)
- Covers market data endpoints
- Covers Account endpoints (create and manage orders)
- Covers user data stream (receive real time user updates)
- Covers web socket streams (receive real time market updates)
- Async support
- Completely free and without limitations
## What it does not
- Binance.py does not cover the withdraw API
- Binance.py does not cover the margin trading API
> If you need these features, don't open an issue to ask me to implement them
## Get started
- [Generate an API Key](https://www.binance.com/en/support/articles/360002502072) and assign relevant permissions.
- import binance, create a client and send your first test order:
```python
import binance
client = binance.Client(API_KEY, API_SECRET)
await client.load()
order = await client.create_order(
"ETHPAX", binance.Side.BUY.value, binance.OrderType.MARKET.value, quantity="1", test=True,
)
print(order)
await client.close()
```
- Check some [examples](https://github.com/Th0rgal/binance.py/tree/master/examples)
## License
[![FOSSA Status](https://app.fossa.com/api/projects/git%2Bgithub.com%2FTh0rgal%2Fbinance.py.svg?type=large)](https://app.fossa.com/projects/git%2Bgithub.com%2FTh0rgal%2Fbinance.py?ref=badge_large)
## Donate
- ETH (ENS): ``thomas.ethers.xyz``
- ETH (legacy address): ``0x54c5a92c57A07f33500Ec9977797219D70D506C9``
- BTC: ``bc1qm9g2k3fznl2a9vghnpnwem87p03txl4y5lahyu``
## Powered by binance.py
### [martin binance](https://github.com/DogsTailFarmer/martin-binance)
Free trading system for Binance SPOT market. Adaptive customizable reverse grid strategy based on martingale.
%package -n python3-binance.py
Summary: A python3 binance API wrapper powered by modern technologies such as asyncio
Provides: python-binance.py
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-binance.py
🦾 A python3 binance API wrapper powered by asyncio and python Decimals.
## Get binance.py
To install the library, you can just run the following command:
```console
# Linux/macOS
python3 -m pip install -U binance.py
# Windows
py -3 -m pip install -U binance.py
```
Alternatively you can build the package and install it manually:
```
python setup.py sdist bdist_wheel
python -m pip install dist/binance.py-X.X.X-py3-none-any.whl
```
## Why binance.py?
The binance api is complex to grasp and using a wrapper saves time but also ensures that the right practices are adopted. Binance.py offers a modern and asynchronous solution.
## Features
- Covers general endpoints (test connectivity and get exchange informations)
- Covers market data endpoints
- Covers Account endpoints (create and manage orders)
- Covers user data stream (receive real time user updates)
- Covers web socket streams (receive real time market updates)
- Async support
- Completely free and without limitations
## What it does not
- Binance.py does not cover the withdraw API
- Binance.py does not cover the margin trading API
> If you need these features, don't open an issue to ask me to implement them
## Get started
- [Generate an API Key](https://www.binance.com/en/support/articles/360002502072) and assign relevant permissions.
- import binance, create a client and send your first test order:
```python
import binance
client = binance.Client(API_KEY, API_SECRET)
await client.load()
order = await client.create_order(
"ETHPAX", binance.Side.BUY.value, binance.OrderType.MARKET.value, quantity="1", test=True,
)
print(order)
await client.close()
```
- Check some [examples](https://github.com/Th0rgal/binance.py/tree/master/examples)
## License
[![FOSSA Status](https://app.fossa.com/api/projects/git%2Bgithub.com%2FTh0rgal%2Fbinance.py.svg?type=large)](https://app.fossa.com/projects/git%2Bgithub.com%2FTh0rgal%2Fbinance.py?ref=badge_large)
## Donate
- ETH (ENS): ``thomas.ethers.xyz``
- ETH (legacy address): ``0x54c5a92c57A07f33500Ec9977797219D70D506C9``
- BTC: ``bc1qm9g2k3fznl2a9vghnpnwem87p03txl4y5lahyu``
## Powered by binance.py
### [martin binance](https://github.com/DogsTailFarmer/martin-binance)
Free trading system for Binance SPOT market. Adaptive customizable reverse grid strategy based on martingale.
%package help
Summary: Development documents and examples for binance.py
Provides: python3-binance.py-doc
%description help
🦾 A python3 binance API wrapper powered by asyncio and python Decimals.
## Get binance.py
To install the library, you can just run the following command:
```console
# Linux/macOS
python3 -m pip install -U binance.py
# Windows
py -3 -m pip install -U binance.py
```
Alternatively you can build the package and install it manually:
```
python setup.py sdist bdist_wheel
python -m pip install dist/binance.py-X.X.X-py3-none-any.whl
```
## Why binance.py?
The binance api is complex to grasp and using a wrapper saves time but also ensures that the right practices are adopted. Binance.py offers a modern and asynchronous solution.
## Features
- Covers general endpoints (test connectivity and get exchange informations)
- Covers market data endpoints
- Covers Account endpoints (create and manage orders)
- Covers user data stream (receive real time user updates)
- Covers web socket streams (receive real time market updates)
- Async support
- Completely free and without limitations
## What it does not
- Binance.py does not cover the withdraw API
- Binance.py does not cover the margin trading API
> If you need these features, don't open an issue to ask me to implement them
## Get started
- [Generate an API Key](https://www.binance.com/en/support/articles/360002502072) and assign relevant permissions.
- import binance, create a client and send your first test order:
```python
import binance
client = binance.Client(API_KEY, API_SECRET)
await client.load()
order = await client.create_order(
"ETHPAX", binance.Side.BUY.value, binance.OrderType.MARKET.value, quantity="1", test=True,
)
print(order)
await client.close()
```
- Check some [examples](https://github.com/Th0rgal/binance.py/tree/master/examples)
## License
[![FOSSA Status](https://app.fossa.com/api/projects/git%2Bgithub.com%2FTh0rgal%2Fbinance.py.svg?type=large)](https://app.fossa.com/projects/git%2Bgithub.com%2FTh0rgal%2Fbinance.py?ref=badge_large)
## Donate
- ETH (ENS): ``thomas.ethers.xyz``
- ETH (legacy address): ``0x54c5a92c57A07f33500Ec9977797219D70D506C9``
- BTC: ``bc1qm9g2k3fznl2a9vghnpnwem87p03txl4y5lahyu``
## Powered by binance.py
### [martin binance](https://github.com/DogsTailFarmer/martin-binance)
Free trading system for Binance SPOT market. Adaptive customizable reverse grid strategy based on martingale.
%prep
%autosetup -n binance.py-1.9.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-binance.py -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon May 15 2023 Python_Bot - 1.9.0-1
- Package Spec generated