%global _empty_manifest_terminate_build 0
Name:		python-factful.py
Version:	0.0.7
Release:	1
Summary:	A Package which can give you Random Facts in an easy way!
License:	MIT
URL:		https://pypi.org/project/factful.py/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/19/3d/ca4156bc24a5b85c774c89a8e5b618493e04ad6073911fc975b75d576139/factful.py-0.0.7.tar.gz
BuildArch:	noarch


%description
# Factful.py

A Package which can give you Random Facts in an easy way!

# Links
- [Discord Support Server](https://discord.com/invite/FrduEZd)
- [GitHub Profile](https://github.com/Scientific-Guy)
- [Factful.js NPM](https://www.npmjs.com/package/factful.py.js)

# Quick Example

#### 1. Getting Random Facts

```py
# Import factful.py Module
import factful

# Define facts function
facts = factful.facts()

# Getting random fact from random cateogary
print(facts["all"])

# Getting random facts from a paticular cateogary!
# All Cateogaries: "computer", "food", "emoji", "space"
print(facts["computer"])
print(facts["food"])
print(facts["emoji"])
print(facts["space"])
```

> We also have this module as **Javascript NPM Package**! [https://www.npmjs.com/package/factful.js](https://www.npmjs.com/package/factful.js). You can join our Discord Server for support!

### © Science Spot | Decimal Development - 2020

%package -n python3-factful.py
Summary:	A Package which can give you Random Facts in an easy way!
Provides:	python-factful.py
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-factful.py
# Factful.py

A Package which can give you Random Facts in an easy way!

# Links
- [Discord Support Server](https://discord.com/invite/FrduEZd)
- [GitHub Profile](https://github.com/Scientific-Guy)
- [Factful.js NPM](https://www.npmjs.com/package/factful.py.js)

# Quick Example

#### 1. Getting Random Facts

```py
# Import factful.py Module
import factful

# Define facts function
facts = factful.facts()

# Getting random fact from random cateogary
print(facts["all"])

# Getting random facts from a paticular cateogary!
# All Cateogaries: "computer", "food", "emoji", "space"
print(facts["computer"])
print(facts["food"])
print(facts["emoji"])
print(facts["space"])
```

> We also have this module as **Javascript NPM Package**! [https://www.npmjs.com/package/factful.js](https://www.npmjs.com/package/factful.js). You can join our Discord Server for support!

### © Science Spot | Decimal Development - 2020

%package help
Summary:	Development documents and examples for factful.py
Provides:	python3-factful.py-doc
%description help
# Factful.py

A Package which can give you Random Facts in an easy way!

# Links
- [Discord Support Server](https://discord.com/invite/FrduEZd)
- [GitHub Profile](https://github.com/Scientific-Guy)
- [Factful.js NPM](https://www.npmjs.com/package/factful.py.js)

# Quick Example

#### 1. Getting Random Facts

```py
# Import factful.py Module
import factful

# Define facts function
facts = factful.facts()

# Getting random fact from random cateogary
print(facts["all"])

# Getting random facts from a paticular cateogary!
# All Cateogaries: "computer", "food", "emoji", "space"
print(facts["computer"])
print(facts["food"])
print(facts["emoji"])
print(facts["space"])
```

> We also have this module as **Javascript NPM Package**! [https://www.npmjs.com/package/factful.js](https://www.npmjs.com/package/factful.js). You can join our Discord Server for support!

### © Science Spot | Decimal Development - 2020

%prep
%autosetup -n factful.py-0.0.7

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-factful.py -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.7-1
- Package Spec generated