%global _empty_manifest_terminate_build 0
Name: python-hydra-genetics
Version: 1.3.0
Release: 1
Summary: Helper tools for use with hydra-genetics pipelines.
License: GPL-3
URL: https://github.com/hydra-genetics/tools
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/5e/04/3a92d9df734fc75a2ea670f9d74a2dcf45948657db2449871cac096ce3c9/hydra-genetics-1.3.0.tar.gz
BuildArch: noarch
%description
# Hydra-genetics
Command line interface to create new modules/pipelines or adding a new rule to an existing project. Provides libraries used to make it easier for people not used to pandas to extract information from samples and units dataframes. These dataframes are generated from [units.tsv](https://github.com/hydra-genetics/tools/blob/develop/hydra_genetics/pipeline-template/workflow/schemas/units.schema.yaml) and [samples.tsv](https://github.com/hydra-genetics/prealignment/blob/develop/workflow/schemas/samples.schema.yaml) files which are used as input.
[![Lint and Test](https://github.com/hydra-genetics/tools/actions/workflows/main.yaml/badge.svg?branch=develop)](https://github.com/hydra-genetics/tools/actions/workflows/main.yaml)
![python](https://img.shields.io/badge/python-3.8-blue)
## Functions
* create
* reference
Example of how to generate a new project
```
virtualenv -p python3.9 venv
source venv/bin/activate
pip install hydra-genetics
hydra-genetics create-module -n snv -d "Collection of callers" -a "Patrik S" -e "p.s@mail.se" -g patrik -o snv
# Create new smk file named "samtools.smk" with rule "samtools_rule2"
hydra-genetics create-rule -c rule2 -t samtools -m snv -a test2 -e "test@test"
# Add command to "samtools smk" file, rule name will be "samtools_rule3"
hydra-genetics create-rule -c rule3 -t samtools -m snv -a test2 -e "test@test"
# -t/--tool can be skipped for a single command tool, ex a script
# this will create a smk file named "super_script.smk" with a rule "super_script"
hydra-genetics create-rule -c rule3 -t samtools -m snv -a test2 -e "test@test"
# Create input files
hydra-genetics create-input-files -d path/dir1 -d path/dir2
# Create singularity cache
# all container specified in config.yaml will be fetched
hydra-genetics singularity create-singularity-files -o singularity_cache -c config.yaml
```
%package -n python3-hydra-genetics
Summary: Helper tools for use with hydra-genetics pipelines.
Provides: python-hydra-genetics
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-hydra-genetics
# Hydra-genetics
Command line interface to create new modules/pipelines or adding a new rule to an existing project. Provides libraries used to make it easier for people not used to pandas to extract information from samples and units dataframes. These dataframes are generated from [units.tsv](https://github.com/hydra-genetics/tools/blob/develop/hydra_genetics/pipeline-template/workflow/schemas/units.schema.yaml) and [samples.tsv](https://github.com/hydra-genetics/prealignment/blob/develop/workflow/schemas/samples.schema.yaml) files which are used as input.
[![Lint and Test](https://github.com/hydra-genetics/tools/actions/workflows/main.yaml/badge.svg?branch=develop)](https://github.com/hydra-genetics/tools/actions/workflows/main.yaml)
![python](https://img.shields.io/badge/python-3.8-blue)
## Functions
* create
* reference
Example of how to generate a new project
```
virtualenv -p python3.9 venv
source venv/bin/activate
pip install hydra-genetics
hydra-genetics create-module -n snv -d "Collection of callers" -a "Patrik S" -e "p.s@mail.se" -g patrik -o snv
# Create new smk file named "samtools.smk" with rule "samtools_rule2"
hydra-genetics create-rule -c rule2 -t samtools -m snv -a test2 -e "test@test"
# Add command to "samtools smk" file, rule name will be "samtools_rule3"
hydra-genetics create-rule -c rule3 -t samtools -m snv -a test2 -e "test@test"
# -t/--tool can be skipped for a single command tool, ex a script
# this will create a smk file named "super_script.smk" with a rule "super_script"
hydra-genetics create-rule -c rule3 -t samtools -m snv -a test2 -e "test@test"
# Create input files
hydra-genetics create-input-files -d path/dir1 -d path/dir2
# Create singularity cache
# all container specified in config.yaml will be fetched
hydra-genetics singularity create-singularity-files -o singularity_cache -c config.yaml
```
%package help
Summary: Development documents and examples for hydra-genetics
Provides: python3-hydra-genetics-doc
%description help
# Hydra-genetics
Command line interface to create new modules/pipelines or adding a new rule to an existing project. Provides libraries used to make it easier for people not used to pandas to extract information from samples and units dataframes. These dataframes are generated from [units.tsv](https://github.com/hydra-genetics/tools/blob/develop/hydra_genetics/pipeline-template/workflow/schemas/units.schema.yaml) and [samples.tsv](https://github.com/hydra-genetics/prealignment/blob/develop/workflow/schemas/samples.schema.yaml) files which are used as input.
[![Lint and Test](https://github.com/hydra-genetics/tools/actions/workflows/main.yaml/badge.svg?branch=develop)](https://github.com/hydra-genetics/tools/actions/workflows/main.yaml)
![python](https://img.shields.io/badge/python-3.8-blue)
## Functions
* create
* reference
Example of how to generate a new project
```
virtualenv -p python3.9 venv
source venv/bin/activate
pip install hydra-genetics
hydra-genetics create-module -n snv -d "Collection of callers" -a "Patrik S" -e "p.s@mail.se" -g patrik -o snv
# Create new smk file named "samtools.smk" with rule "samtools_rule2"
hydra-genetics create-rule -c rule2 -t samtools -m snv -a test2 -e "test@test"
# Add command to "samtools smk" file, rule name will be "samtools_rule3"
hydra-genetics create-rule -c rule3 -t samtools -m snv -a test2 -e "test@test"
# -t/--tool can be skipped for a single command tool, ex a script
# this will create a smk file named "super_script.smk" with a rule "super_script"
hydra-genetics create-rule -c rule3 -t samtools -m snv -a test2 -e "test@test"
# Create input files
hydra-genetics create-input-files -d path/dir1 -d path/dir2
# Create singularity cache
# all container specified in config.yaml will be fetched
hydra-genetics singularity create-singularity-files -o singularity_cache -c config.yaml
```
%prep
%autosetup -n hydra-genetics-1.3.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-hydra-genetics -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon May 15 2023 Python_Bot - 1.3.0-1
- Package Spec generated