%global _empty_manifest_terminate_build 0
Name:		python-acceptable
Version:	0.39
Release:	1
Summary:	API metadata and schema tool for generating tests and documentation
License:	LGPLv3
URL:		https://github.com/canonical/acceptable
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/61/75/17c8d5c9f9b5a64743624ce75afb228b3d295cfd1985717dc7fbcdc609b4/acceptable-0.39.tar.gz
BuildArch:	noarch

Requires:	python3-jsonschema
Requires:	python3-pyyaml
Requires:	python3-Jinja2
Requires:	python3-django
Requires:	python3-Flask

%description
- Tightly couple code, metadata, and documentation to reduce drift and increase DRY.
- Validation of JSON input and output
- Provide tools for developers to make safe changes to APIs
- Make it easy to generate API documentation.
- Tools for generating testing doubles from the API metadata.

%package -n python3-acceptable
Summary:	API metadata and schema tool for generating tests and documentation
Provides:	python-acceptable
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-acceptable
- Tightly couple code, metadata, and documentation to reduce drift and increase DRY.
- Validation of JSON input and output
- Provide tools for developers to make safe changes to APIs
- Make it easy to generate API documentation.
- Tools for generating testing doubles from the API metadata.

%package help
Summary:	Development documents and examples for acceptable
Provides:	python3-acceptable-doc
%description help
- Tightly couple code, metadata, and documentation to reduce drift and increase DRY.
- Validation of JSON input and output
- Provide tools for developers to make safe changes to APIs
- Make it easy to generate API documentation.
- Tools for generating testing doubles from the API metadata.

%prep
%autosetup -n acceptable-0.39

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-acceptable -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.39-1
- Package Spec generated