%global _empty_manifest_terminate_build 0
Name: python-aiomailru
Version: 0.1.1.post1
Release: 1
Summary: Python Mail.Ru API wrapper
License: BSD
URL: https://github.com/KonstantinTogoi/aiomailru
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/88/df/bd696a1427bed80f4f747404bf2b8cbc0f3245f48cd30146575614b85709/aiomailru-0.1.1.post1.tar.gz
BuildArch: noarch
Requires: python3-aiohttp
Requires: python3-yarl
Requires: python3-pyppeteer
%description
aiomailru is a python `Mail.Ru API `_ wrapper.
The main features are:
* authorization (`Authorization Code `_, `Implicit Flow `_, `Password Grant `_, `Refresh Token `_)
* `REST API `_ methods
* web scrapers
%package -n python3-aiomailru
Summary: Python Mail.Ru API wrapper
Provides: python-aiomailru
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-aiomailru
aiomailru is a python `Mail.Ru API `_ wrapper.
The main features are:
* authorization (`Authorization Code `_, `Implicit Flow `_, `Password Grant `_, `Refresh Token `_)
* `REST API `_ methods
* web scrapers
%package help
Summary: Development documents and examples for aiomailru
Provides: python3-aiomailru-doc
%description help
aiomailru is a python `Mail.Ru API `_ wrapper.
The main features are:
* authorization (`Authorization Code `_, `Implicit Flow `_, `Password Grant `_, `Refresh Token `_)
* `REST API `_ methods
* web scrapers
%prep
%autosetup -n aiomailru-0.1.1.post1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-aiomailru -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon May 15 2023 Python_Bot - 0.1.1.post1-1
- Package Spec generated