%global _empty_manifest_terminate_build 0
Name:		python-openerz-api
Version:	0.2.0
Release:	1
Summary:	A Python wrapper around the OpenERZ API.
License:	MIT License
URL:		https://github.com/misialq/openerz-api
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/8f/05/7ef84d00be5e8c950eed8fa9d9a5338c38c9afd14feded5ddf459640d8a6/openerz-api-0.2.0.tar.gz
BuildArch:	noarch

Requires:	python3-requests

%description
### OpenERZ Python API

This wrapper allows you to interact with the OpenERZ API using Python code.

For more information about the API itself see: [http://openerz.metaodi.ch/documentation](http://openerz.metaodi.ch/documentation) and [https://github.com/metaodi/openerz](https://github.com/metaodi/openerz)

#### Usage example

A ready-to-run example can also be found in the `examples` directory.

```
from openerz_api.main import OpenERZConnector

ZIP = 8001
WASTE = "paper"

# initialize the connector given zip code and waste type
connector = OpenERZConnector(zip_code=ZIP, waste_type=WASTE)

# retrieve the next pick-up date within a period of choice
next_pickup = connector.find_next_pickup(day_offset=15)
```


%package -n python3-openerz-api
Summary:	A Python wrapper around the OpenERZ API.
Provides:	python-openerz-api
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-openerz-api
### OpenERZ Python API

This wrapper allows you to interact with the OpenERZ API using Python code.

For more information about the API itself see: [http://openerz.metaodi.ch/documentation](http://openerz.metaodi.ch/documentation) and [https://github.com/metaodi/openerz](https://github.com/metaodi/openerz)

#### Usage example

A ready-to-run example can also be found in the `examples` directory.

```
from openerz_api.main import OpenERZConnector

ZIP = 8001
WASTE = "paper"

# initialize the connector given zip code and waste type
connector = OpenERZConnector(zip_code=ZIP, waste_type=WASTE)

# retrieve the next pick-up date within a period of choice
next_pickup = connector.find_next_pickup(day_offset=15)
```


%package help
Summary:	Development documents and examples for openerz-api
Provides:	python3-openerz-api-doc
%description help
### OpenERZ Python API

This wrapper allows you to interact with the OpenERZ API using Python code.

For more information about the API itself see: [http://openerz.metaodi.ch/documentation](http://openerz.metaodi.ch/documentation) and [https://github.com/metaodi/openerz](https://github.com/metaodi/openerz)

#### Usage example

A ready-to-run example can also be found in the `examples` directory.

```
from openerz_api.main import OpenERZConnector

ZIP = 8001
WASTE = "paper"

# initialize the connector given zip code and waste type
connector = OpenERZConnector(zip_code=ZIP, waste_type=WASTE)

# retrieve the next pick-up date within a period of choice
next_pickup = connector.find_next_pickup(day_offset=15)
```


%prep
%autosetup -n openerz-api-0.2.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-openerz-api -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.0-1
- Package Spec generated