%global _empty_manifest_terminate_build 0
Name:		python-pyhelios
Version:	2.2.4
Release:	1
Summary:	The Helios' toolbox
License:	MIT
URL:		https://pypi.org/project/pyhelios
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/9d/a8/0786fa2d3cb724b78de0b50ef692ebc5af032b4f6a3fa5f2af49fff8729d/pyhelios-2.2.4.tar.gz
BuildArch:	noarch

Requires:	python3-rich
Requires:	python3-typer
Requires:	python3-numpy
Requires:	python3-jinja2
Requires:	python3-loguru
Requires:	python3-ipython
Requires:	python3-flatdict
Requires:	python3-pytomlpp
Requires:	python3-pygments
Requires:	python3-traitlets
Requires:	python3-xmltodict
Requires:	python3-cmake-format

%description
# pyhelios: the Helios' toolbox

## Installation

```sh
pip install pyhelios
```

## Contributing

The pyhelios Python package is managed by awesome tools: [poetry](https://python-poetry.org/) and [tox](https://tox.wiki/en/latest/index.html).

1. Create a virtual environment using poetry.

```sh
poetry env use `which python`
```

2. Build the pyhelios Python package (sdist and wheel).

```sh
poetry build
```

2. Install in the previously created virtual environment.

```sh
poetry install
```

3. Run the tests.

```sh
poetry run python -m tox
```

4. Publish to the [Python Package Index](https://pypi.org/)

```sh
poetry publish
```

If necessary, [poetry](https://python-poetry.org/) can bump the version for you.
The new version should be a valid [semver](https://semver.org/) string or a valid bump rule: patch, minor, major, prepatch, preminor, premajor, prerelease.

```sh
poetry version patch[minor, major, prepatch, preminor, premajor, prerelease]
```

%package -n python3-pyhelios
Summary:	The Helios' toolbox
Provides:	python-pyhelios
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pyhelios
# pyhelios: the Helios' toolbox

## Installation

```sh
pip install pyhelios
```

## Contributing

The pyhelios Python package is managed by awesome tools: [poetry](https://python-poetry.org/) and [tox](https://tox.wiki/en/latest/index.html).

1. Create a virtual environment using poetry.

```sh
poetry env use `which python`
```

2. Build the pyhelios Python package (sdist and wheel).

```sh
poetry build
```

2. Install in the previously created virtual environment.

```sh
poetry install
```

3. Run the tests.

```sh
poetry run python -m tox
```

4. Publish to the [Python Package Index](https://pypi.org/)

```sh
poetry publish
```

If necessary, [poetry](https://python-poetry.org/) can bump the version for you.
The new version should be a valid [semver](https://semver.org/) string or a valid bump rule: patch, minor, major, prepatch, preminor, premajor, prerelease.

```sh
poetry version patch[minor, major, prepatch, preminor, premajor, prerelease]
```

%package help
Summary:	Development documents and examples for pyhelios
Provides:	python3-pyhelios-doc
%description help
# pyhelios: the Helios' toolbox

## Installation

```sh
pip install pyhelios
```

## Contributing

The pyhelios Python package is managed by awesome tools: [poetry](https://python-poetry.org/) and [tox](https://tox.wiki/en/latest/index.html).

1. Create a virtual environment using poetry.

```sh
poetry env use `which python`
```

2. Build the pyhelios Python package (sdist and wheel).

```sh
poetry build
```

2. Install in the previously created virtual environment.

```sh
poetry install
```

3. Run the tests.

```sh
poetry run python -m tox
```

4. Publish to the [Python Package Index](https://pypi.org/)

```sh
poetry publish
```

If necessary, [poetry](https://python-poetry.org/) can bump the version for you.
The new version should be a valid [semver](https://semver.org/) string or a valid bump rule: patch, minor, major, prepatch, preminor, premajor, prerelease.

```sh
poetry version patch[minor, major, prepatch, preminor, premajor, prerelease]
```

%prep
%autosetup -n pyhelios-2.2.4

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pyhelios -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 2.2.4-1
- Package Spec generated