%global _empty_manifest_terminate_build 0
Name:		python-deepwalk
Version:	1.0.3
Release:	1
Summary:	DeepWalk online learning of social representations.
License:	GPLv3
URL:		https://github.com/phanein/deepwalk
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/aa/30/bbbf62ca65e9c427b91eb685e3ce37490324969f8a4141971f5a12a3e2bf/deepwalk-1.0.3.tar.gz
BuildArch:	noarch

Requires:	python3-wheel
Requires:	python3-Cython
Requires:	python3-argparse
Requires:	python3-futures
Requires:	python3-six
Requires:	python3-gensim
Requires:	python3-scipy
Requires:	python3-psutil

%description


%package -n python3-deepwalk
Summary:	DeepWalk online learning of social representations.
Provides:	python-deepwalk
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-deepwalk


%package help
Summary:	Development documents and examples for deepwalk
Provides:	python3-deepwalk-doc
%description help


%prep
%autosetup -n deepwalk-1.0.3

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-deepwalk -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.3-1
- Package Spec generated