%global _empty_manifest_terminate_build 0
Name:		python-cel-python
Version:	0.1.5
Release:	1
Summary:	Pure Python CEL Implementation
License:	Apache-2.0
URL:		https://github.com/cloud-custodian/cel-python
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/b3/9e/c3af4a83cbe8108cff92b0588b7ac53efc41fcaf1ffd09d07dc68c9b5d27/cel-python-0.1.5.tar.gz
BuildArch:	noarch

Requires:	python3-jmespath
Requires:	python3-lark-parser
Requires:	python3-dateutil
Requires:	python3-pyyaml
Requires:	python3-requests
Requires:	python3-urllib3
Requires:	python3-babel

%description
    pip install cel-python
You now have the CEL run-time available to Python-based applications.

%package -n python3-cel-python
Summary:	Pure Python CEL Implementation
Provides:	python-cel-python
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-cel-python
    pip install cel-python
You now have the CEL run-time available to Python-based applications.

%package help
Summary:	Development documents and examples for cel-python
Provides:	python3-cel-python-doc
%description help
    pip install cel-python
You now have the CEL run-time available to Python-based applications.

%prep
%autosetup -n cel-python-0.1.5

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-cel-python -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.5-1
- Package Spec generated