%global _empty_manifest_terminate_build 0
Name: python-glue-jupyter
Version: 0.16.3
Release: 1
Summary: Jupyter notebook/lab viewers for glue
License: BSD License
URL: https://glueviz.org
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f2/fe/747256ad0555e8cde44dd065184d27fdb25437f0d46cc599d66f9b45afbf/glue-jupyter-0.16.3.tar.gz
BuildArch: noarch
Requires: python3-glue-core
Requires: python3-glue-vispy-viewers
Requires: python3-notebook
Requires: python3-ipympl
Requires: python3-ipyvolume
Requires: python3-ipywidgets
Requires: python3-ipyvue
Requires: python3-ipyvuetify
Requires: python3-bqplot-image-gl
Requires: python3-bqplot
Requires: python3-scikit-image
Requires: python3-ipyvolume
Requires: python3-sphinx
Requires: python3-sphinx-automodapi
Requires: python3-numpydoc
Requires: python3-nbconvert
Requires: python3-nbsphinx
Requires: python3-sphinx-rtd-theme
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-runipy
Requires: python3-nbconvert
Requires: python3-glue-core
%description
Sometimes known as “Glupyter”
|Build Status| |Coverage Status| |Documentation Status|
About
~~~~~
`Glue `__ is a Python library to explore
relationships within and among datasets. The main interface until now
has been based on `Qt `__, but the **glue-jupyter**
package aims to provide a way to use Glue in Jupyter notebooks and
Jupyter lab instead. This is currently a work in progress and highly
experimental.
For some notebooks with examples of usage of glue-jupyter, see the
``notebooks`` directory.
You can try out glue-jupyter online at mybinder:
|Binder|
Notebooks with real data:
- `Investigating star formation in the W5
region `__
(example with linking a table and an image)
- `Exploring the L1448 data in
3D `__
(example of 3D volume rendering)
- `Visualizing flight paths in the Boston
area `__
(example with a single tabular dataset)
- `Distance to the Pleiades with GAIA
data `__
Installing
~~~~~~~~~~
For now, installing should be done using pip::
pip install git+https://github.com/glue-viz/glue-jupyter.git
Or from source::
git clone https://github.com/glue-viz/glue-jupyter.git
cd glue-jupyter
pip install -e .
Testing
~~~~~~~
The test suite can be run using::
pytest glue_jupyter
%package -n python3-glue-jupyter
Summary: Jupyter notebook/lab viewers for glue
Provides: python-glue-jupyter
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-glue-jupyter
Sometimes known as “Glupyter”
|Build Status| |Coverage Status| |Documentation Status|
About
~~~~~
`Glue `__ is a Python library to explore
relationships within and among datasets. The main interface until now
has been based on `Qt `__, but the **glue-jupyter**
package aims to provide a way to use Glue in Jupyter notebooks and
Jupyter lab instead. This is currently a work in progress and highly
experimental.
For some notebooks with examples of usage of glue-jupyter, see the
``notebooks`` directory.
You can try out glue-jupyter online at mybinder:
|Binder|
Notebooks with real data:
- `Investigating star formation in the W5
region `__
(example with linking a table and an image)
- `Exploring the L1448 data in
3D `__
(example of 3D volume rendering)
- `Visualizing flight paths in the Boston
area `__
(example with a single tabular dataset)
- `Distance to the Pleiades with GAIA
data `__
Installing
~~~~~~~~~~
For now, installing should be done using pip::
pip install git+https://github.com/glue-viz/glue-jupyter.git
Or from source::
git clone https://github.com/glue-viz/glue-jupyter.git
cd glue-jupyter
pip install -e .
Testing
~~~~~~~
The test suite can be run using::
pytest glue_jupyter
%package help
Summary: Development documents and examples for glue-jupyter
Provides: python3-glue-jupyter-doc
%description help
Sometimes known as “Glupyter”
|Build Status| |Coverage Status| |Documentation Status|
About
~~~~~
`Glue `__ is a Python library to explore
relationships within and among datasets. The main interface until now
has been based on `Qt `__, but the **glue-jupyter**
package aims to provide a way to use Glue in Jupyter notebooks and
Jupyter lab instead. This is currently a work in progress and highly
experimental.
For some notebooks with examples of usage of glue-jupyter, see the
``notebooks`` directory.
You can try out glue-jupyter online at mybinder:
|Binder|
Notebooks with real data:
- `Investigating star formation in the W5
region `__
(example with linking a table and an image)
- `Exploring the L1448 data in
3D `__
(example of 3D volume rendering)
- `Visualizing flight paths in the Boston
area `__
(example with a single tabular dataset)
- `Distance to the Pleiades with GAIA
data `__
Installing
~~~~~~~~~~
For now, installing should be done using pip::
pip install git+https://github.com/glue-viz/glue-jupyter.git
Or from source::
git clone https://github.com/glue-viz/glue-jupyter.git
cd glue-jupyter
pip install -e .
Testing
~~~~~~~
The test suite can be run using::
pytest glue_jupyter
%prep
%autosetup -n glue-jupyter-0.16.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-glue-jupyter -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon May 15 2023 Python_Bot - 0.16.3-1
- Package Spec generated