%global _empty_manifest_terminate_build 0
Name: python-vwsfriend
Version: 0.23.10
Release: 1
Summary: please add a summary manually as the author left a blank one
License: MIT
URL: https://github.com/tillsteinbach/VWsFriend
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d1/fb/ccf05f9ec028677062d4233b85dccfe6ffe627bc1e65a57dc5d709e2e3df/vwsfriend-0.23.10.tar.gz
BuildArch: noarch
Requires: python3-weconnect[images]
Requires: python3-HAP-python[qrcode]
Requires: python3-pypng
Requires: python3-sqlalchemy
Requires: python3-psycopg2-binary
Requires: python3-requests
Requires: python3-Werkzeug
Requires: python3-Flask
Requires: python3-flask-login
Requires: python3-flask-caching
Requires: python3-WTForms
Requires: python3-flask-wtf
Requires: python3-flask-sqlalchemy
Requires: python3-alembic
Requires: python3-haversine
Requires: python3-weconnect-mqtt
%description
# VWsFriend
Volkswagen WeConnect© API visualization and control (HomeKit) inspired by TeslaMate https://docs.teslamate.org/
## What it looks like
## Requirements
You need to install python 3 on your system: [How to install python](https://realpython.com/installing-python/). Minimum python version required is 3.8
To make use of all features you have to install and configure several depending projects (grafana, postgresql, ...) most users use the preconfigured docker images at: https://github.com/tillsteinbach/VWsFriend/
If you still want to setup everything on your own, please continue reading.
### Login & Consent
VWsFriend is based on the new WeConnect ID API that was introduced with the new series of ID cars. If you use another car or hybrid you probably need to agree to the terms and conditions of the WeConnect ID interface. Easiest to do so is by installing the WeConnect ID app on your smartphone and login there. If necessary you will be asked to agree to the terms and conditions.
## How to install
If you want to use VWsFriend, the easiest way is to obtain it from [PyPI](https://pypi.org/project/vwsfriend/). Just install using:
```bash
pip3 install vwsfriend
```
### Updates
If you want to update VWsFriend, the easiest way is:
```bash
pip3 install vwsfriend --upgrade
```
## Privacy
Depending on the data provided by your car usage profiles of the cars users can be made (including the locations of trips, refueling and charging). If you need to protect the privacy of the cars users please add ` --privacy no-locations` to the start parameters
## More information
More information can be found in the Wiki: https://github.com/tillsteinbach/VWsFriend/wiki
## ABPR (A better Route Planner) support
VWsFriend supports sending its data to ABPR out of the box. You just have to generate a user-token in ABRP and configure it for your car in the UI.
Connecting VWsFriend to ABRP enables you to use the current SoC, position, parking and charging state (feature availability depends on your car!) when planning routes in ABRP
If you only want to use the ABPR feature you can try:
```bash
vwsfriend -u user -p password --with-abrp
```
After vwsfriend is started open a browser at http://IP-ADDRESS:4000 and add your user-token in the settings of your car.
## VWsFriend with Apple Homekit support
![](https://raw.githubusercontent.com/tillsteinbach/VWsFriend/main/screenshots/homekit.jpg)
![](https://raw.githubusercontent.com/tillsteinbach/VWsFriend/main/screenshots/homekit2.jpg)
![](https://raw.githubusercontent.com/tillsteinbach/VWsFriend/main/screenshots/homekit3.jpg)
```bash
vwsfriend --with-homekit
```
## VWsFriend with MQTT support (Experimental)
VWsFriend now includes [WeConnect-MQTT](https://github.com/tillsteinbach/WeConnect-mqtt). This enables to use the data from the servers at the same time inside VWsFriend and with MQTT and thus saves additional requests and load on the server.
If you want to know how to configure MQTT, see here: [WeConnect-MQTT Readme](https://github.com/tillsteinbach/WeConnect-mqtt/blob/main/README.md)
VWsFriend is using the same options as WeConnect-MQTT. Just select the options as described in WeConnect-MQTT and add those to VWsFriend when starting.
## Related projects
- [WeConnect-cli](https://github.com/tillsteinbach/WeConnect-cli): A commandline interface to interact with WeConnect
- [WeConnect-MQTT](https://github.com/tillsteinbach/WeConnect-mqtt): A MQTT Client that provides WeConnect data to the MQTT Broker of your choice (e.g. your home automation solution such as [ioBroker](https://www.iobroker.net), [FHEM](https://fhem.de) or [Home Assistant](https://www.home-assistant.io))
## Other
We Connect© Volkswagen AG
%package -n python3-vwsfriend
Summary: please add a summary manually as the author left a blank one
Provides: python-vwsfriend
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-vwsfriend
# VWsFriend
Volkswagen WeConnect© API visualization and control (HomeKit) inspired by TeslaMate https://docs.teslamate.org/
## What it looks like
## Requirements
You need to install python 3 on your system: [How to install python](https://realpython.com/installing-python/). Minimum python version required is 3.8
To make use of all features you have to install and configure several depending projects (grafana, postgresql, ...) most users use the preconfigured docker images at: https://github.com/tillsteinbach/VWsFriend/
If you still want to setup everything on your own, please continue reading.
### Login & Consent
VWsFriend is based on the new WeConnect ID API that was introduced with the new series of ID cars. If you use another car or hybrid you probably need to agree to the terms and conditions of the WeConnect ID interface. Easiest to do so is by installing the WeConnect ID app on your smartphone and login there. If necessary you will be asked to agree to the terms and conditions.
## How to install
If you want to use VWsFriend, the easiest way is to obtain it from [PyPI](https://pypi.org/project/vwsfriend/). Just install using:
```bash
pip3 install vwsfriend
```
### Updates
If you want to update VWsFriend, the easiest way is:
```bash
pip3 install vwsfriend --upgrade
```
## Privacy
Depending on the data provided by your car usage profiles of the cars users can be made (including the locations of trips, refueling and charging). If you need to protect the privacy of the cars users please add ` --privacy no-locations` to the start parameters
## More information
More information can be found in the Wiki: https://github.com/tillsteinbach/VWsFriend/wiki
## ABPR (A better Route Planner) support
VWsFriend supports sending its data to ABPR out of the box. You just have to generate a user-token in ABRP and configure it for your car in the UI.
Connecting VWsFriend to ABRP enables you to use the current SoC, position, parking and charging state (feature availability depends on your car!) when planning routes in ABRP
If you only want to use the ABPR feature you can try:
```bash
vwsfriend -u user -p password --with-abrp
```
After vwsfriend is started open a browser at http://IP-ADDRESS:4000 and add your user-token in the settings of your car.
## VWsFriend with Apple Homekit support
![](https://raw.githubusercontent.com/tillsteinbach/VWsFriend/main/screenshots/homekit.jpg)
![](https://raw.githubusercontent.com/tillsteinbach/VWsFriend/main/screenshots/homekit2.jpg)
![](https://raw.githubusercontent.com/tillsteinbach/VWsFriend/main/screenshots/homekit3.jpg)
```bash
vwsfriend --with-homekit
```
## VWsFriend with MQTT support (Experimental)
VWsFriend now includes [WeConnect-MQTT](https://github.com/tillsteinbach/WeConnect-mqtt). This enables to use the data from the servers at the same time inside VWsFriend and with MQTT and thus saves additional requests and load on the server.
If you want to know how to configure MQTT, see here: [WeConnect-MQTT Readme](https://github.com/tillsteinbach/WeConnect-mqtt/blob/main/README.md)
VWsFriend is using the same options as WeConnect-MQTT. Just select the options as described in WeConnect-MQTT and add those to VWsFriend when starting.
## Related projects
- [WeConnect-cli](https://github.com/tillsteinbach/WeConnect-cli): A commandline interface to interact with WeConnect
- [WeConnect-MQTT](https://github.com/tillsteinbach/WeConnect-mqtt): A MQTT Client that provides WeConnect data to the MQTT Broker of your choice (e.g. your home automation solution such as [ioBroker](https://www.iobroker.net), [FHEM](https://fhem.de) or [Home Assistant](https://www.home-assistant.io))
## Other
We Connect© Volkswagen AG
%package help
Summary: Development documents and examples for vwsfriend
Provides: python3-vwsfriend-doc
%description help
# VWsFriend
Volkswagen WeConnect© API visualization and control (HomeKit) inspired by TeslaMate https://docs.teslamate.org/
## What it looks like
## Requirements
You need to install python 3 on your system: [How to install python](https://realpython.com/installing-python/). Minimum python version required is 3.8
To make use of all features you have to install and configure several depending projects (grafana, postgresql, ...) most users use the preconfigured docker images at: https://github.com/tillsteinbach/VWsFriend/
If you still want to setup everything on your own, please continue reading.
### Login & Consent
VWsFriend is based on the new WeConnect ID API that was introduced with the new series of ID cars. If you use another car or hybrid you probably need to agree to the terms and conditions of the WeConnect ID interface. Easiest to do so is by installing the WeConnect ID app on your smartphone and login there. If necessary you will be asked to agree to the terms and conditions.
## How to install
If you want to use VWsFriend, the easiest way is to obtain it from [PyPI](https://pypi.org/project/vwsfriend/). Just install using:
```bash
pip3 install vwsfriend
```
### Updates
If you want to update VWsFriend, the easiest way is:
```bash
pip3 install vwsfriend --upgrade
```
## Privacy
Depending on the data provided by your car usage profiles of the cars users can be made (including the locations of trips, refueling and charging). If you need to protect the privacy of the cars users please add ` --privacy no-locations` to the start parameters
## More information
More information can be found in the Wiki: https://github.com/tillsteinbach/VWsFriend/wiki
## ABPR (A better Route Planner) support
VWsFriend supports sending its data to ABPR out of the box. You just have to generate a user-token in ABRP and configure it for your car in the UI.
Connecting VWsFriend to ABRP enables you to use the current SoC, position, parking and charging state (feature availability depends on your car!) when planning routes in ABRP
If you only want to use the ABPR feature you can try:
```bash
vwsfriend -u user -p password --with-abrp
```
After vwsfriend is started open a browser at http://IP-ADDRESS:4000 and add your user-token in the settings of your car.
## VWsFriend with Apple Homekit support
![](https://raw.githubusercontent.com/tillsteinbach/VWsFriend/main/screenshots/homekit.jpg)
![](https://raw.githubusercontent.com/tillsteinbach/VWsFriend/main/screenshots/homekit2.jpg)
![](https://raw.githubusercontent.com/tillsteinbach/VWsFriend/main/screenshots/homekit3.jpg)
```bash
vwsfriend --with-homekit
```
## VWsFriend with MQTT support (Experimental)
VWsFriend now includes [WeConnect-MQTT](https://github.com/tillsteinbach/WeConnect-mqtt). This enables to use the data from the servers at the same time inside VWsFriend and with MQTT and thus saves additional requests and load on the server.
If you want to know how to configure MQTT, see here: [WeConnect-MQTT Readme](https://github.com/tillsteinbach/WeConnect-mqtt/blob/main/README.md)
VWsFriend is using the same options as WeConnect-MQTT. Just select the options as described in WeConnect-MQTT and add those to VWsFriend when starting.
## Related projects
- [WeConnect-cli](https://github.com/tillsteinbach/WeConnect-cli): A commandline interface to interact with WeConnect
- [WeConnect-MQTT](https://github.com/tillsteinbach/WeConnect-mqtt): A MQTT Client that provides WeConnect data to the MQTT Broker of your choice (e.g. your home automation solution such as [ioBroker](https://www.iobroker.net), [FHEM](https://fhem.de) or [Home Assistant](https://www.home-assistant.io))
## Other
We Connect© Volkswagen AG
%prep
%autosetup -n vwsfriend-0.23.10
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-vwsfriend -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon May 15 2023 Python_Bot - 0.23.10-1
- Package Spec generated