%global _empty_manifest_terminate_build 0
Name:		python-ricxappframe
Version:	3.2.1
Release:	1
Summary:	Xapp and RMR framework for Python
License:	Apache 2.0
URL:		https://gerrit.o-ran-sc.org/r/admin/repos/ric-plt/xapp-frame-py
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/99/7d/ef6b34acf4590e1061be15b93dbedbf4e52ab99f9988db7dd2c7c5785d18/ricxappframe-3.2.1.tar.gz
BuildArch:	noarch

Requires:	python3-msgpack
Requires:	python3-inotify-simple
Requires:	python3-mdclogpy
Requires:	python3-ricsdl
Requires:	python3-requests
Requires:	python3-protobuf
Requires:	python3-inotify

%description
This package is a framework for writing RAN Intelligent Controller
(RIC) Xapps in python. The framework reduces the amount of code
required in an Xapp by providing common features needed by all
Python-based Xapps including communication with the RIC message router
(RMR) and the Shared Data Layer (SDL).
The framework was designed to suport many types of Xapps, including
applications that are purely reactive to RMR messages, and general
applications that initiate actions according to other criteria.
For complete documentation see the ReadTheDocs site for
`xapp-frame-py <https://docs.o-ran-sc.org/projects/o-ran-sc-ric-plt-xapp-frame-py>`_.

%package -n python3-ricxappframe
Summary:	Xapp and RMR framework for Python
Provides:	python-ricxappframe
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-ricxappframe
This package is a framework for writing RAN Intelligent Controller
(RIC) Xapps in python. The framework reduces the amount of code
required in an Xapp by providing common features needed by all
Python-based Xapps including communication with the RIC message router
(RMR) and the Shared Data Layer (SDL).
The framework was designed to suport many types of Xapps, including
applications that are purely reactive to RMR messages, and general
applications that initiate actions according to other criteria.
For complete documentation see the ReadTheDocs site for
`xapp-frame-py <https://docs.o-ran-sc.org/projects/o-ran-sc-ric-plt-xapp-frame-py>`_.

%package help
Summary:	Development documents and examples for ricxappframe
Provides:	python3-ricxappframe-doc
%description help
This package is a framework for writing RAN Intelligent Controller
(RIC) Xapps in python. The framework reduces the amount of code
required in an Xapp by providing common features needed by all
Python-based Xapps including communication with the RIC message router
(RMR) and the Shared Data Layer (SDL).
The framework was designed to suport many types of Xapps, including
applications that are purely reactive to RMR messages, and general
applications that initiate actions according to other criteria.
For complete documentation see the ReadTheDocs site for
`xapp-frame-py <https://docs.o-ran-sc.org/projects/o-ran-sc-ric-plt-xapp-frame-py>`_.

%prep
%autosetup -n ricxappframe-3.2.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-ricxappframe -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 3.2.1-1
- Package Spec generated