%global _empty_manifest_terminate_build 0
Name:		python-rticonnextdds-connector
Version:	1.2.2
Release:	1
Summary:	RTI Connector for Python
License:	RTI
URL:		https://github.com/rticommunity/rticonnextdds-connector-py
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/a5/82/c99708e29673e9ced0b61848b0be133a479dc8688e6987306b254d44af9d/rticonnextdds_connector-1.2.2.tar.gz
BuildArch:	noarch


%description
RTI® Connext® DDS is a connectivity software framework for integrating
data sources of all types. At its core is the world's leading ultra-high
performance, distributed networking databus.
*RTI Connector* provides a quick and easy way to write applications that
publish and subscribe to the *RTI Connext DDS databus* in Python and
other languages.
   With the introduction of the RTI Connext Python API in *RTI Connext* 
   7.0.0, *Connector for Python* is deprecated and will be removed in a 
   future release, once the Connext Python API is fully supported. You are 
   encouraged to try the 
   `Connext Python API <https://community.rti.com/static/documentation/connext-dds/7.0.0/doc/api/connext_dds/api_python/index.html>`__ (experimental in 7.0.0).

%package -n python3-rticonnextdds-connector
Summary:	RTI Connector for Python
Provides:	python-rticonnextdds-connector
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-rticonnextdds-connector
RTI® Connext® DDS is a connectivity software framework for integrating
data sources of all types. At its core is the world's leading ultra-high
performance, distributed networking databus.
*RTI Connector* provides a quick and easy way to write applications that
publish and subscribe to the *RTI Connext DDS databus* in Python and
other languages.
   With the introduction of the RTI Connext Python API in *RTI Connext* 
   7.0.0, *Connector for Python* is deprecated and will be removed in a 
   future release, once the Connext Python API is fully supported. You are 
   encouraged to try the 
   `Connext Python API <https://community.rti.com/static/documentation/connext-dds/7.0.0/doc/api/connext_dds/api_python/index.html>`__ (experimental in 7.0.0).

%package help
Summary:	Development documents and examples for rticonnextdds-connector
Provides:	python3-rticonnextdds-connector-doc
%description help
RTI® Connext® DDS is a connectivity software framework for integrating
data sources of all types. At its core is the world's leading ultra-high
performance, distributed networking databus.
*RTI Connector* provides a quick and easy way to write applications that
publish and subscribe to the *RTI Connext DDS databus* in Python and
other languages.
   With the introduction of the RTI Connext Python API in *RTI Connext* 
   7.0.0, *Connector for Python* is deprecated and will be removed in a 
   future release, once the Connext Python API is fully supported. You are 
   encouraged to try the 
   `Connext Python API <https://community.rti.com/static/documentation/connext-dds/7.0.0/doc/api/connext_dds/api_python/index.html>`__ (experimental in 7.0.0).

%prep
%autosetup -n rticonnextdds-connector-1.2.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-rticonnextdds-connector -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.2-1
- Package Spec generated