%global _empty_manifest_terminate_build 0
Name: python-pyopencl-extension
Version: 0.2.5
Release: 1
Summary: This package extends PyOpenCl by providing an object-oriented kernel programming framework and debugging capabilities.
License: MIT
URL: https://github.com/philipp-mohr/pyopencl-extension
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/7c/1b/1689558de36a15489dc24eb0ac4fa69089dd35f42605e78f08203d5b29a8/pyopencl-extension-0.2.5.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-pyopencl
Requires: python3-mako
Requires: python3-pycparser
Requires: python3-pycparserext
Requires: python3-pyastyle
Requires: python3-pytest
Requires: python3-check-manifest
Requires: python3-twine
Requires: python3-reikna
Requires: python3-wheel
%description
This package extends PyOpenCl by providing an object-oriented kernel programming framework and debugging capabilities.
What makes pyopencl-extension special?
* Build on top of `PyOpenCl `_ which can increase performance significantly.
* Usage of this framework forces consistent code when programming for GPU.
* Allows debugging of OpenCl-Programs through kernel emulation in Python using a visual debugger (tested with Pycharm).
* OpenCl emulation allows to find out-of-bounds array indexing more easily.
* Integrated profiling features give quick overview over performance bottlenecks.
The project is in an early development stage and actively maintained.
For any feature requests/feedback/etc. you can get in touch via
`Github `_ or by E-Mail (philipp.mohr@tuhh.de).
%package -n python3-pyopencl-extension
Summary: This package extends PyOpenCl by providing an object-oriented kernel programming framework and debugging capabilities.
Provides: python-pyopencl-extension
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pyopencl-extension
This package extends PyOpenCl by providing an object-oriented kernel programming framework and debugging capabilities.
What makes pyopencl-extension special?
* Build on top of `PyOpenCl `_ which can increase performance significantly.
* Usage of this framework forces consistent code when programming for GPU.
* Allows debugging of OpenCl-Programs through kernel emulation in Python using a visual debugger (tested with Pycharm).
* OpenCl emulation allows to find out-of-bounds array indexing more easily.
* Integrated profiling features give quick overview over performance bottlenecks.
The project is in an early development stage and actively maintained.
For any feature requests/feedback/etc. you can get in touch via
`Github `_ or by E-Mail (philipp.mohr@tuhh.de).
%package help
Summary: Development documents and examples for pyopencl-extension
Provides: python3-pyopencl-extension-doc
%description help
This package extends PyOpenCl by providing an object-oriented kernel programming framework and debugging capabilities.
What makes pyopencl-extension special?
* Build on top of `PyOpenCl `_ which can increase performance significantly.
* Usage of this framework forces consistent code when programming for GPU.
* Allows debugging of OpenCl-Programs through kernel emulation in Python using a visual debugger (tested with Pycharm).
* OpenCl emulation allows to find out-of-bounds array indexing more easily.
* Integrated profiling features give quick overview over performance bottlenecks.
The project is in an early development stage and actively maintained.
For any feature requests/feedback/etc. you can get in touch via
`Github `_ or by E-Mail (philipp.mohr@tuhh.de).
%prep
%autosetup -n pyopencl-extension-0.2.5
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pyopencl-extension -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon May 15 2023 Python_Bot - 0.2.5-1
- Package Spec generated