%global _empty_manifest_terminate_build 0
Name:		python-click-loglevel
Version:	0.4.0.post1
Release:	1
Summary:	Log level parameter type for Click
License:	MIT
URL:		https://github.com/jwodder/click-loglevel
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/14/3d/07807b439cf75f326f15fa72bdfc4dafeb8f2d44595ce8f95d669aff2310/click-loglevel-0.4.0.post1.tar.gz
BuildArch:	noarch

Requires:	python3-click

%description
``click-loglevel`` requires Python 3.6 or higher.  Just use `pip
<https://pip.pypa.io>`_ for Python 3 (You have pip, right?) to install
``click-loglevel`` and its dependencies::
    python3 -m pip install click-loglevel

%package -n python3-click-loglevel
Summary:	Log level parameter type for Click
Provides:	python-click-loglevel
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-click-loglevel
``click-loglevel`` requires Python 3.6 or higher.  Just use `pip
<https://pip.pypa.io>`_ for Python 3 (You have pip, right?) to install
``click-loglevel`` and its dependencies::
    python3 -m pip install click-loglevel

%package help
Summary:	Development documents and examples for click-loglevel
Provides:	python3-click-loglevel-doc
%description help
``click-loglevel`` requires Python 3.6 or higher.  Just use `pip
<https://pip.pypa.io>`_ for Python 3 (You have pip, right?) to install
``click-loglevel`` and its dependencies::
    python3 -m pip install click-loglevel

%prep
%autosetup -n click-loglevel-0.4.0.post1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-click-loglevel -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 17 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4.0.post1-1
- Package Spec generated