%global _empty_manifest_terminate_build 0
Name: python-dbdaora
Version: 0.27.0
Release: 1
Summary: Communicates with databases using repository pattern and service patterns
License: MIT License
URL: https://github.com/dutradda/dbdaora
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/8e/8c/ec68f09b6436b77df3f3ff1a60d7cfbecb9930f43041a155cfcb0cc2b50e/dbdaora-0.27.0.tar.gz
BuildArch: noarch
Requires: python3-circuitbreaker
Requires: python3-cachetools
Requires: python3-jsondaora
Requires: python3-aioredis
Requires: python3-google-cloud-datastore
Requires: python3-mkdocs
Requires: python3-mkdocs-material
Requires: python3-markdown-include
Requires: python3-motor
Requires: python3-newrelic
Requires: python3-black
Requires: python3-isort
Requires: python3-ipython
Requires: python3-mypy
Requires: python3-pytest-asyncio
Requires: python3-pytest-cov
Requires: python3-pytest-mock
Requires: python3-pytest
%description
**Documentation**: https://dutradda.github.io/dbdaora/
%package -n python3-dbdaora
Summary: Communicates with databases using repository pattern and service patterns
Provides: python-dbdaora
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-dbdaora
**Documentation**: https://dutradda.github.io/dbdaora/
%package help
Summary: Development documents and examples for dbdaora
Provides: python3-dbdaora-doc
%description help
**Documentation**: https://dutradda.github.io/dbdaora/
%prep
%autosetup -n dbdaora-0.27.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-dbdaora -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 17 2023 Python_Bot - 0.27.0-1
- Package Spec generated