%global _empty_manifest_terminate_build 0
Name:		python-django-geonode-client
Version:	1.0.9
Release:	1
Summary:	Use GeoNode client in your django projects
License:	LGPL, see LICENSE file.
URL:		https://github.com/GeoNode/geonode-client
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/15/bd/2296876811013f7b21c80b5c5151f38b2701083dea086120d77b6712475f/django-geonode-client-1.0.9.tar.gz
BuildArch:	noarch


%description
# geonode-client [![Build Status](https://travis-ci.org/GeoNode/geonode-client.svg?branch=master)](https://travis-ci.org/GeoNode/geonode-client) [![Code Climate](https://codeclimate.com/github/GeoNode/geonode-viewer/badges/gpa.svg)](https://codeclimate.com/github/GeoNode/geonode-viewer) [![Test Coverage](https://codeclimate.com/github/GeoNode/geonode-viewer/badges/coverage.svg)](https://codeclimate.com/github/GeoNode/geonode-viewer/coverage)

OL3 - React map viewer for GeoNode

## Installation

Install `node` and `npm`. We would encourage you to use [nvm](https://github.com/creationix/nvm) a version manager for node.

You need `node > 5`

Run `npm install` to install all dependencies.

## Development Server

Run `npm start` to start the development server. Visit your browser at `http://localhost:8080` to see the result.

## Testing

During development run `npm run test:watch` to run tests on every file change.  

Run `npm test` to run the full test suite with code coverage report.  

## Building

Building is done via webpack and the command is `npm build`  
The dist folder is where the minified versions of these files are stored.  

## Deployment to GH-pages

Automated deployment via travis is enabled for the master branch. 

If you want to deploy manually to gh-pages use `npm run deploy`

### Important
The deplyoment uses the `index-gh.html` please keep this file in sync with `index.html` and change the path once the repo changes it's name. The `.travis.yml` needs to be changed as well.

## Integrating into GeoNode/Django

Add `django-geonode-client` to your requirements.txt
Add `geonode-client` to your `INSTALLED_APPS`

### For GeoNode
Change the `LAYER_PREVIEW_LIBRARY` to `react`

### For Django
We added templatetags you can use in your templates

Add `{% client_viewer_js %}` to include the viewer javasricpt
Add `{% client_composer_js %}` to include the composer javasricpt

The following templates are available:
`client_map_view_html` for the full map view
`client_map_detail_view_html` for a smaller map view (as in the map preview)
`client_map_new_html` create a new map with composer
`client_layer_map_html` smaller map view for the layer preview

%package -n python3-django-geonode-client
Summary:	Use GeoNode client in your django projects
Provides:	python-django-geonode-client
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-django-geonode-client
# geonode-client [![Build Status](https://travis-ci.org/GeoNode/geonode-client.svg?branch=master)](https://travis-ci.org/GeoNode/geonode-client) [![Code Climate](https://codeclimate.com/github/GeoNode/geonode-viewer/badges/gpa.svg)](https://codeclimate.com/github/GeoNode/geonode-viewer) [![Test Coverage](https://codeclimate.com/github/GeoNode/geonode-viewer/badges/coverage.svg)](https://codeclimate.com/github/GeoNode/geonode-viewer/coverage)

OL3 - React map viewer for GeoNode

## Installation

Install `node` and `npm`. We would encourage you to use [nvm](https://github.com/creationix/nvm) a version manager for node.

You need `node > 5`

Run `npm install` to install all dependencies.

## Development Server

Run `npm start` to start the development server. Visit your browser at `http://localhost:8080` to see the result.

## Testing

During development run `npm run test:watch` to run tests on every file change.  

Run `npm test` to run the full test suite with code coverage report.  

## Building

Building is done via webpack and the command is `npm build`  
The dist folder is where the minified versions of these files are stored.  

## Deployment to GH-pages

Automated deployment via travis is enabled for the master branch. 

If you want to deploy manually to gh-pages use `npm run deploy`

### Important
The deplyoment uses the `index-gh.html` please keep this file in sync with `index.html` and change the path once the repo changes it's name. The `.travis.yml` needs to be changed as well.

## Integrating into GeoNode/Django

Add `django-geonode-client` to your requirements.txt
Add `geonode-client` to your `INSTALLED_APPS`

### For GeoNode
Change the `LAYER_PREVIEW_LIBRARY` to `react`

### For Django
We added templatetags you can use in your templates

Add `{% client_viewer_js %}` to include the viewer javasricpt
Add `{% client_composer_js %}` to include the composer javasricpt

The following templates are available:
`client_map_view_html` for the full map view
`client_map_detail_view_html` for a smaller map view (as in the map preview)
`client_map_new_html` create a new map with composer
`client_layer_map_html` smaller map view for the layer preview

%package help
Summary:	Development documents and examples for django-geonode-client
Provides:	python3-django-geonode-client-doc
%description help
# geonode-client [![Build Status](https://travis-ci.org/GeoNode/geonode-client.svg?branch=master)](https://travis-ci.org/GeoNode/geonode-client) [![Code Climate](https://codeclimate.com/github/GeoNode/geonode-viewer/badges/gpa.svg)](https://codeclimate.com/github/GeoNode/geonode-viewer) [![Test Coverage](https://codeclimate.com/github/GeoNode/geonode-viewer/badges/coverage.svg)](https://codeclimate.com/github/GeoNode/geonode-viewer/coverage)

OL3 - React map viewer for GeoNode

## Installation

Install `node` and `npm`. We would encourage you to use [nvm](https://github.com/creationix/nvm) a version manager for node.

You need `node > 5`

Run `npm install` to install all dependencies.

## Development Server

Run `npm start` to start the development server. Visit your browser at `http://localhost:8080` to see the result.

## Testing

During development run `npm run test:watch` to run tests on every file change.  

Run `npm test` to run the full test suite with code coverage report.  

## Building

Building is done via webpack and the command is `npm build`  
The dist folder is where the minified versions of these files are stored.  

## Deployment to GH-pages

Automated deployment via travis is enabled for the master branch. 

If you want to deploy manually to gh-pages use `npm run deploy`

### Important
The deplyoment uses the `index-gh.html` please keep this file in sync with `index.html` and change the path once the repo changes it's name. The `.travis.yml` needs to be changed as well.

## Integrating into GeoNode/Django

Add `django-geonode-client` to your requirements.txt
Add `geonode-client` to your `INSTALLED_APPS`

### For GeoNode
Change the `LAYER_PREVIEW_LIBRARY` to `react`

### For Django
We added templatetags you can use in your templates

Add `{% client_viewer_js %}` to include the viewer javasricpt
Add `{% client_composer_js %}` to include the composer javasricpt

The following templates are available:
`client_map_view_html` for the full map view
`client_map_detail_view_html` for a smaller map view (as in the map preview)
`client_map_new_html` create a new map with composer
`client_layer_map_html` smaller map view for the layer preview

%prep
%autosetup -n django-geonode-client-1.0.9

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-django-geonode-client -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.9-1
- Package Spec generated