%global _empty_manifest_terminate_build 0
Name: python-sretools
Version: 0.1.137
Release: 1
Summary: SRE console/terminal toolbox
License: MIT
URL: https://github.com/laowangv5/sretools
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/de/49/74f212730376f9f49b0d648871c31cf83d3c5f454b0051093a37c35bad37/sretools-0.1.137.tar.gz
BuildArch: noarch
%description
# sretools
A collection of SRE command line tools
## SSH tool
sretools-ssh ssh command tool with expect integration. run remote command, ship and run package on remote server, etc.
## expect
sretools-expect command line expect tool. help SRE to "expect' interactive applications in a very easy way.
## structure data
[sretools-dsq](/examples/sretools-dsq.md) jq/jello like query tools with interactive mode. \
sretools-json2html format JSON from file or pipe to HTML tables. \
sretools-json2yaml format JSON from file or pipe \
sretools-yaml2json format YAML from file or pipe \
sretools-yaml2html format YAML from file or pipe
## concole
[sretools-table-format](/examples/sretools-table-format.md) console table formatting tool. pipe, CSV, etc. support UNICODE.
## database client
[sretools-dbx](/examples/sretools-dbx.md) generic JDBC calls. dump query in good table format. open JDBC access to bash level.
## misc
- sretools-nonascii scan FS, files for non-ascii characters. will help resovle issues caused by "invisiable" characters.
## Classes
- LE expect class for develp sretools-ltexpect alike tools.
- SimpleTable console formatting table supporting wide chacaters.
- JsonConverter convert JSON str or dict/list object to HTML or YAML.
%package -n python3-sretools
Summary: SRE console/terminal toolbox
Provides: python-sretools
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-sretools
# sretools
A collection of SRE command line tools
## SSH tool
sretools-ssh ssh command tool with expect integration. run remote command, ship and run package on remote server, etc.
## expect
sretools-expect command line expect tool. help SRE to "expect' interactive applications in a very easy way.
## structure data
[sretools-dsq](/examples/sretools-dsq.md) jq/jello like query tools with interactive mode. \
sretools-json2html format JSON from file or pipe to HTML tables. \
sretools-json2yaml format JSON from file or pipe \
sretools-yaml2json format YAML from file or pipe \
sretools-yaml2html format YAML from file or pipe
## concole
[sretools-table-format](/examples/sretools-table-format.md) console table formatting tool. pipe, CSV, etc. support UNICODE.
## database client
[sretools-dbx](/examples/sretools-dbx.md) generic JDBC calls. dump query in good table format. open JDBC access to bash level.
## misc
- sretools-nonascii scan FS, files for non-ascii characters. will help resovle issues caused by "invisiable" characters.
## Classes
- LE expect class for develp sretools-ltexpect alike tools.
- SimpleTable console formatting table supporting wide chacaters.
- JsonConverter convert JSON str or dict/list object to HTML or YAML.
%package help
Summary: Development documents and examples for sretools
Provides: python3-sretools-doc
%description help
# sretools
A collection of SRE command line tools
## SSH tool
sretools-ssh ssh command tool with expect integration. run remote command, ship and run package on remote server, etc.
## expect
sretools-expect command line expect tool. help SRE to "expect' interactive applications in a very easy way.
## structure data
[sretools-dsq](/examples/sretools-dsq.md) jq/jello like query tools with interactive mode. \
sretools-json2html format JSON from file or pipe to HTML tables. \
sretools-json2yaml format JSON from file or pipe \
sretools-yaml2json format YAML from file or pipe \
sretools-yaml2html format YAML from file or pipe
## concole
[sretools-table-format](/examples/sretools-table-format.md) console table formatting tool. pipe, CSV, etc. support UNICODE.
## database client
[sretools-dbx](/examples/sretools-dbx.md) generic JDBC calls. dump query in good table format. open JDBC access to bash level.
## misc
- sretools-nonascii scan FS, files for non-ascii characters. will help resovle issues caused by "invisiable" characters.
## Classes
- LE expect class for develp sretools-ltexpect alike tools.
- SimpleTable console formatting table supporting wide chacaters.
- JsonConverter convert JSON str or dict/list object to HTML or YAML.
%prep
%autosetup -n sretools-0.1.137
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-sretools -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu May 18 2023 Python_Bot - 0.1.137-1
- Package Spec generated