%global _empty_manifest_terminate_build 0
Name:		python-AnimatedGraphs
Version:	1.0
Release:	1
Summary:	Build and awesome animated graph easily
License:	MIT
URL:		https://github.com/lgbaeza/animatedgraph-pkg
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/2c/b1/43e5f9cdda35cc925c03feda16ad70d68a47cf82def5f2de2cebc5f1343f/AnimatedGraphs-1.0.tar.gz
BuildArch:	noarch

Requires:	python3-imageio
Requires:	python3-pandas
Requires:	python3-IPython
Requires:	python3-numpy
Requires:	python3-requests
Requires:	python3-matplotlib

%description
# AnimatedGraphs

Build and awesome animated graph easily
![](https://github.com/lgbaeza/py-animated-graph/raw/master/news_sample.gif)

## Installation

Use the package manager [pip](https://pip.pypa.io/en/stable/) to install AnimatedGraphs.

```bash
pip install AnimatedGraphs
```

## Usage

```python
import AnimatedGraphs as ag
from AnimatedGraphs import AnimatedBar as agBar

GRAPH_FILENAME = agBar.CreateGraphBar(
    dataset,
    args**
)
if (GRAPH_FILENAME != ""):
    print("Succeed. Animated grahBar available at {}" + GRAPH_FILENAME)
else:
    print("something went wrong")
```

You can find a notebook with sample usage here ![](https://github.com/lgbaeza/py-animated-graph)

## Args** details

| Argument                      | Required?     | Possible Values        | Default value / action |
| -------------                 | ------------- | --------------         | -------------          |
| DS                            |  Yes          |  numpy arr             |                        |
| AGGREGATION_TYPE              |  Yes          |  "COUNT", "SUM"        |                        |
| AGGREGATION_ATTRIBUTE_NAME    |  when AGG=SUM |  String                |                        |
| BAR_ATTRIBUTE_NAME            |  Yes          |  String                |                        |
| LOOP_ATTRIBUTE_NAME           |  Yes          |  String                |                        |
| SERIES_ATTRIBUTE_NAME         |  Yes          |  String                |                        |
| SERIES_ATTRIBUTE_NAME         |  Yes          |  String                |                        |
| GRAPH_XLABEL                  |  Opcional     |  String                | Empty                  |
| GRAPH_XLABEL                  |  Opcional     |  String                | Empty                  |
| IMAGE_SET_URL                 |  Opcional     |  String: URL to Zip    | <No image>             |
| IMAGE_SET_EXT                 |  Opcional     |  String                | <No image>             |
| SORT_BARS_LIST                |  Opcional     |  Array of String       | <No sorting>           |
| GRAPH_STEPS                   |  Opcional     |  Integer               | 10                     |
| GRAPH_FRAME_DURATION          |  Opcional     |  Float (0-3]           | 1.0                    |
| GRAPH_FILENAME                |  Opcional     |  String                | "animated-graph.gif"   |

## Contributing
Pull requests are welcome. For major changes, please open an issue first to discuss what you would like to change.

Please make sure to update tests as appropriate.

## License
[MIT](https://choosealicense.com/licenses/mit/)



%package -n python3-AnimatedGraphs
Summary:	Build and awesome animated graph easily
Provides:	python-AnimatedGraphs
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-AnimatedGraphs
# AnimatedGraphs

Build and awesome animated graph easily
![](https://github.com/lgbaeza/py-animated-graph/raw/master/news_sample.gif)

## Installation

Use the package manager [pip](https://pip.pypa.io/en/stable/) to install AnimatedGraphs.

```bash
pip install AnimatedGraphs
```

## Usage

```python
import AnimatedGraphs as ag
from AnimatedGraphs import AnimatedBar as agBar

GRAPH_FILENAME = agBar.CreateGraphBar(
    dataset,
    args**
)
if (GRAPH_FILENAME != ""):
    print("Succeed. Animated grahBar available at {}" + GRAPH_FILENAME)
else:
    print("something went wrong")
```

You can find a notebook with sample usage here ![](https://github.com/lgbaeza/py-animated-graph)

## Args** details

| Argument                      | Required?     | Possible Values        | Default value / action |
| -------------                 | ------------- | --------------         | -------------          |
| DS                            |  Yes          |  numpy arr             |                        |
| AGGREGATION_TYPE              |  Yes          |  "COUNT", "SUM"        |                        |
| AGGREGATION_ATTRIBUTE_NAME    |  when AGG=SUM |  String                |                        |
| BAR_ATTRIBUTE_NAME            |  Yes          |  String                |                        |
| LOOP_ATTRIBUTE_NAME           |  Yes          |  String                |                        |
| SERIES_ATTRIBUTE_NAME         |  Yes          |  String                |                        |
| SERIES_ATTRIBUTE_NAME         |  Yes          |  String                |                        |
| GRAPH_XLABEL                  |  Opcional     |  String                | Empty                  |
| GRAPH_XLABEL                  |  Opcional     |  String                | Empty                  |
| IMAGE_SET_URL                 |  Opcional     |  String: URL to Zip    | <No image>             |
| IMAGE_SET_EXT                 |  Opcional     |  String                | <No image>             |
| SORT_BARS_LIST                |  Opcional     |  Array of String       | <No sorting>           |
| GRAPH_STEPS                   |  Opcional     |  Integer               | 10                     |
| GRAPH_FRAME_DURATION          |  Opcional     |  Float (0-3]           | 1.0                    |
| GRAPH_FILENAME                |  Opcional     |  String                | "animated-graph.gif"   |

## Contributing
Pull requests are welcome. For major changes, please open an issue first to discuss what you would like to change.

Please make sure to update tests as appropriate.

## License
[MIT](https://choosealicense.com/licenses/mit/)



%package help
Summary:	Development documents and examples for AnimatedGraphs
Provides:	python3-AnimatedGraphs-doc
%description help
# AnimatedGraphs

Build and awesome animated graph easily
![](https://github.com/lgbaeza/py-animated-graph/raw/master/news_sample.gif)

## Installation

Use the package manager [pip](https://pip.pypa.io/en/stable/) to install AnimatedGraphs.

```bash
pip install AnimatedGraphs
```

## Usage

```python
import AnimatedGraphs as ag
from AnimatedGraphs import AnimatedBar as agBar

GRAPH_FILENAME = agBar.CreateGraphBar(
    dataset,
    args**
)
if (GRAPH_FILENAME != ""):
    print("Succeed. Animated grahBar available at {}" + GRAPH_FILENAME)
else:
    print("something went wrong")
```

You can find a notebook with sample usage here ![](https://github.com/lgbaeza/py-animated-graph)

## Args** details

| Argument                      | Required?     | Possible Values        | Default value / action |
| -------------                 | ------------- | --------------         | -------------          |
| DS                            |  Yes          |  numpy arr             |                        |
| AGGREGATION_TYPE              |  Yes          |  "COUNT", "SUM"        |                        |
| AGGREGATION_ATTRIBUTE_NAME    |  when AGG=SUM |  String                |                        |
| BAR_ATTRIBUTE_NAME            |  Yes          |  String                |                        |
| LOOP_ATTRIBUTE_NAME           |  Yes          |  String                |                        |
| SERIES_ATTRIBUTE_NAME         |  Yes          |  String                |                        |
| SERIES_ATTRIBUTE_NAME         |  Yes          |  String                |                        |
| GRAPH_XLABEL                  |  Opcional     |  String                | Empty                  |
| GRAPH_XLABEL                  |  Opcional     |  String                | Empty                  |
| IMAGE_SET_URL                 |  Opcional     |  String: URL to Zip    | <No image>             |
| IMAGE_SET_EXT                 |  Opcional     |  String                | <No image>             |
| SORT_BARS_LIST                |  Opcional     |  Array of String       | <No sorting>           |
| GRAPH_STEPS                   |  Opcional     |  Integer               | 10                     |
| GRAPH_FRAME_DURATION          |  Opcional     |  Float (0-3]           | 1.0                    |
| GRAPH_FILENAME                |  Opcional     |  String                | "animated-graph.gif"   |

## Contributing
Pull requests are welcome. For major changes, please open an issue first to discuss what you would like to change.

Please make sure to update tests as appropriate.

## License
[MIT](https://choosealicense.com/licenses/mit/)



%prep
%autosetup -n AnimatedGraphs-1.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-AnimatedGraphs -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0-1
- Package Spec generated