%global _empty_manifest_terminate_build 0
Name: python-SlaterPythonGames
Version: 1.7
Release: 1
Summary: An updated version of rygames, a collection of games written in Python
License: MIT License
URL: https://github.com/rjslater2000/SlaterPythonGames
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/50/a5/ad6fcbe38e23b08788fdb78beeb6b3db3b20d2d8839774923738e803932a/SlaterPythonGames-1.7.tar.gz
BuildArch: noarch
Requires: python3-pygame
Requires: python3-numpy
Requires: python3-matplotlib
Requires: python3-names
Requires: python3-requests
%description
# SlaterPythonGames
[![Downloads](http://pepy.tech/badge/SlaterPythonGames)](http://pepy.tech/project/SlaterPythonGames) ![PyPi](https://badge.fury.io/py/SlaterPythonGames.png)
Python games by Ryan J. Slater [GitHub](https://github.com/rjslater2000/SlaterPythonGames)
[PyPi](https://pypi.org/project/SlaterPythonGames/)
This is an updated replacement for [rygames](https://pypi.org/project/RyGames/) [![Downloads](http://pepy.tech/badge/rygames)](http://pepy.tech/project/rygames)
## Installation
To install: `pip install SlaterPythonGames`
## Games
Make sure to `import SlaterPythonGames as s`
Here are the games currently included in this module:
- 2048
- Coin Game
- Country Guessing Game
- Tic-Tac-Toe
- Warships
- Warships2
### 2048
This is a clone of the popular mobile game under the same name. This will run with a Graphical User Interface, and with a scalable window size. You can find the original version [here](https://gabrielecirulli.github.io/2048/).
Run with `s.TwentyFortyEight()`
### Coin Game
This is just a quick little game some new programmers write within their first year. Two players take turns flipping a coin, choosing from a penny, nickel, dime, or quarter. The players flip their coin, and if it lands on heads, the player gains the amount the coin is worth. If the coin lands on tails, they lose that amount. Players race to reach $1.00 first.
Run with `s.CoinGame()`
### Country Guessing Game
Name as many countries as you can!
NOTE: This game was written on July 28th, 2017. The world has changed since then, so some of these countries may not exist any more and there may be new ones. I kinda don't feel like updating this though, since only my brother is crazy enough to play it seriously.
Run with `s.CountryGuessingGame()``
### Tic-Tac-Toe
If you don't know how to play this game, I'm wondering what you're doing here. Enter the number corresponding to the space you want to mark.
To play single-player: `s.TicTacToe1Player()`
To play two-player: `s.TicTacToe2Player()`
### Warships
This is the game that won the high school competition at the [Shawnee State](http://www.shawnee.edu/gaming/) [17.0 Art & Gaming Conference](https://vrcfa.com/events/shawnee-17-0/) in 2017.
It's a text-based clone of the Battleship board game, with one or two player options. If you play the two-player version, you'll have access to some slightly different options.
Instructions are included in the game.
NOTE: Due to the use of colored text, this will not run on Windows 7.
Run with `s.Warships()`
### Warships2
This is the successor to Warships. Updates include a GUI, account system, and an AI that learns your personal play style and adapts to play against you!
Run with `s.Warships2()`
%package -n python3-SlaterPythonGames
Summary: An updated version of rygames, a collection of games written in Python
Provides: python-SlaterPythonGames
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-SlaterPythonGames
# SlaterPythonGames
[![Downloads](http://pepy.tech/badge/SlaterPythonGames)](http://pepy.tech/project/SlaterPythonGames) ![PyPi](https://badge.fury.io/py/SlaterPythonGames.png)
Python games by Ryan J. Slater [GitHub](https://github.com/rjslater2000/SlaterPythonGames)
[PyPi](https://pypi.org/project/SlaterPythonGames/)
This is an updated replacement for [rygames](https://pypi.org/project/RyGames/) [![Downloads](http://pepy.tech/badge/rygames)](http://pepy.tech/project/rygames)
## Installation
To install: `pip install SlaterPythonGames`
## Games
Make sure to `import SlaterPythonGames as s`
Here are the games currently included in this module:
- 2048
- Coin Game
- Country Guessing Game
- Tic-Tac-Toe
- Warships
- Warships2
### 2048
This is a clone of the popular mobile game under the same name. This will run with a Graphical User Interface, and with a scalable window size. You can find the original version [here](https://gabrielecirulli.github.io/2048/).
Run with `s.TwentyFortyEight()`
### Coin Game
This is just a quick little game some new programmers write within their first year. Two players take turns flipping a coin, choosing from a penny, nickel, dime, or quarter. The players flip their coin, and if it lands on heads, the player gains the amount the coin is worth. If the coin lands on tails, they lose that amount. Players race to reach $1.00 first.
Run with `s.CoinGame()`
### Country Guessing Game
Name as many countries as you can!
NOTE: This game was written on July 28th, 2017. The world has changed since then, so some of these countries may not exist any more and there may be new ones. I kinda don't feel like updating this though, since only my brother is crazy enough to play it seriously.
Run with `s.CountryGuessingGame()``
### Tic-Tac-Toe
If you don't know how to play this game, I'm wondering what you're doing here. Enter the number corresponding to the space you want to mark.
To play single-player: `s.TicTacToe1Player()`
To play two-player: `s.TicTacToe2Player()`
### Warships
This is the game that won the high school competition at the [Shawnee State](http://www.shawnee.edu/gaming/) [17.0 Art & Gaming Conference](https://vrcfa.com/events/shawnee-17-0/) in 2017.
It's a text-based clone of the Battleship board game, with one or two player options. If you play the two-player version, you'll have access to some slightly different options.
Instructions are included in the game.
NOTE: Due to the use of colored text, this will not run on Windows 7.
Run with `s.Warships()`
### Warships2
This is the successor to Warships. Updates include a GUI, account system, and an AI that learns your personal play style and adapts to play against you!
Run with `s.Warships2()`
%package help
Summary: Development documents and examples for SlaterPythonGames
Provides: python3-SlaterPythonGames-doc
%description help
# SlaterPythonGames
[![Downloads](http://pepy.tech/badge/SlaterPythonGames)](http://pepy.tech/project/SlaterPythonGames) ![PyPi](https://badge.fury.io/py/SlaterPythonGames.png)
Python games by Ryan J. Slater [GitHub](https://github.com/rjslater2000/SlaterPythonGames)
[PyPi](https://pypi.org/project/SlaterPythonGames/)
This is an updated replacement for [rygames](https://pypi.org/project/RyGames/) [![Downloads](http://pepy.tech/badge/rygames)](http://pepy.tech/project/rygames)
## Installation
To install: `pip install SlaterPythonGames`
## Games
Make sure to `import SlaterPythonGames as s`
Here are the games currently included in this module:
- 2048
- Coin Game
- Country Guessing Game
- Tic-Tac-Toe
- Warships
- Warships2
### 2048
This is a clone of the popular mobile game under the same name. This will run with a Graphical User Interface, and with a scalable window size. You can find the original version [here](https://gabrielecirulli.github.io/2048/).
Run with `s.TwentyFortyEight()`
### Coin Game
This is just a quick little game some new programmers write within their first year. Two players take turns flipping a coin, choosing from a penny, nickel, dime, or quarter. The players flip their coin, and if it lands on heads, the player gains the amount the coin is worth. If the coin lands on tails, they lose that amount. Players race to reach $1.00 first.
Run with `s.CoinGame()`
### Country Guessing Game
Name as many countries as you can!
NOTE: This game was written on July 28th, 2017. The world has changed since then, so some of these countries may not exist any more and there may be new ones. I kinda don't feel like updating this though, since only my brother is crazy enough to play it seriously.
Run with `s.CountryGuessingGame()``
### Tic-Tac-Toe
If you don't know how to play this game, I'm wondering what you're doing here. Enter the number corresponding to the space you want to mark.
To play single-player: `s.TicTacToe1Player()`
To play two-player: `s.TicTacToe2Player()`
### Warships
This is the game that won the high school competition at the [Shawnee State](http://www.shawnee.edu/gaming/) [17.0 Art & Gaming Conference](https://vrcfa.com/events/shawnee-17-0/) in 2017.
It's a text-based clone of the Battleship board game, with one or two player options. If you play the two-player version, you'll have access to some slightly different options.
Instructions are included in the game.
NOTE: Due to the use of colored text, this will not run on Windows 7.
Run with `s.Warships()`
### Warships2
This is the successor to Warships. Updates include a GUI, account system, and an AI that learns your personal play style and adapts to play against you!
Run with `s.Warships2()`
%prep
%autosetup -n SlaterPythonGames-1.7
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-SlaterPythonGames -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu May 18 2023 Python_Bot - 1.7-1
- Package Spec generated