%global _empty_manifest_terminate_build 0
Name: python-signalr-client-threads
Version: 0.0.12
Release: 1
Summary: Fork of SignalR client for Python based on threads instead of gevent
License: Apache
URL: https://github.com/PawelTroka/signalr-client-threads
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/02/c4/d5ef8c9b2f2131e926f1f6ea2bb9fc5833a48d7dbd3a655a11954e8c068e/signalr-client-threads-0.0.12.tar.gz
BuildArch: noarch
Requires: python3-websocket-client
Requires: python3-sseclient
Requires: python3-requests
%description
Python client proxy for `SignalR `_.
*Note: This is currently not compatible with ASP.NET Core SignalR (.NET Core 2.1), due to some changes in SignalR protocol there.*
%package -n python3-signalr-client-threads
Summary: Fork of SignalR client for Python based on threads instead of gevent
Provides: python-signalr-client-threads
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-signalr-client-threads
Python client proxy for `SignalR `_.
*Note: This is currently not compatible with ASP.NET Core SignalR (.NET Core 2.1), due to some changes in SignalR protocol there.*
%package help
Summary: Development documents and examples for signalr-client-threads
Provides: python3-signalr-client-threads-doc
%description help
Python client proxy for `SignalR `_.
*Note: This is currently not compatible with ASP.NET Core SignalR (.NET Core 2.1), due to some changes in SignalR protocol there.*
%prep
%autosetup -n signalr-client-threads-0.0.12
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-signalr-client-threads -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu May 18 2023 Python_Bot - 0.0.12-1
- Package Spec generated