%global _empty_manifest_terminate_build 0
Name: python-alacrity
Version: 1.4.1
Release: 1
Summary: Quickstart your Python development with CLI package templating
License: MIT License
URL: https://pypi.org/project/alacrity/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/00/b1/e7a8d9af922ad9ede4d5274e4480bdbed443af7bea524e6a8ea24e8dcac8/alacrity-1.4.1.tar.gz
BuildArch: noarch
Requires: python3-clint
%description
#
Alacrity
[![Release](https://img.shields.io/github/v/release/vishnuvardhan-kumar/alacrity.svg)](https://img.shields.io/github/v/release/vishnuvardhan-kumar/alacrity.svg)
[![Build Status](https://travis-ci.org/vishnuvardhan-kumar/alacrity.svg?branch=master)](https://travis-ci.org/vishnuvardhan-kumar/alacrity)
[![Issues](https://img.shields.io/github/issues/vishnuvardhan-kumar/alacrity.svg)](https://img.shields.io/github/issues/vishnuvardhan-kumar/alacrity.svg)
[![PRs Welcome](https://img.shields.io/badge/PRs-welcome-brightgreen.svg?style=flat-square)](http://makeapullrequest.com)
[![Stars](https://img.shields.io/github/stars/vishnuvardhan-kumar/alacrity.svg?style=social&label=Star)](https://img.shields.io/github/stars/vishnuvardhan-kumar/alacrity?style=social&label=Star)
Quickstart your Python project with a single handy command.
![Screenshot](https://raw.githubusercontent.com/vishnuvardhan-kumar/alacrity/master/alacrity/tests/scr.png)
## Installation
`pip install alacrity`
## Running Alacrity
To run alacrity, use:
`alacrity `
To display all the options, use:
`alacrity -h`
Answer some questions interactively, and poof, your package structure is ready.
Based on the [sample Python package](https://github.com/kennethreitz/samplemod) structure by Kenneth Reitz.
## Features
- Customized setup.py file
- Automatic git repository initialization
- Automatic virtual environment setup
- Automatic Sphinx docs initialization
- Easily extensible workflow for custom install steps
## Platforms
- Windows (and Cygwin)
- Linux
- Android (Termux)
## Testing
- To run the built-in tests, run `tox` in the project root
- To add custom testing, edit `tox.ini`
%package -n python3-alacrity
Summary: Quickstart your Python development with CLI package templating
Provides: python-alacrity
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-alacrity
# Alacrity
[![Release](https://img.shields.io/github/v/release/vishnuvardhan-kumar/alacrity.svg)](https://img.shields.io/github/v/release/vishnuvardhan-kumar/alacrity.svg)
[![Build Status](https://travis-ci.org/vishnuvardhan-kumar/alacrity.svg?branch=master)](https://travis-ci.org/vishnuvardhan-kumar/alacrity)
[![Issues](https://img.shields.io/github/issues/vishnuvardhan-kumar/alacrity.svg)](https://img.shields.io/github/issues/vishnuvardhan-kumar/alacrity.svg)
[![PRs Welcome](https://img.shields.io/badge/PRs-welcome-brightgreen.svg?style=flat-square)](http://makeapullrequest.com)
[![Stars](https://img.shields.io/github/stars/vishnuvardhan-kumar/alacrity.svg?style=social&label=Star)](https://img.shields.io/github/stars/vishnuvardhan-kumar/alacrity?style=social&label=Star)
Quickstart your Python project with a single handy command.
![Screenshot](https://raw.githubusercontent.com/vishnuvardhan-kumar/alacrity/master/alacrity/tests/scr.png)
## Installation
`pip install alacrity`
## Running Alacrity
To run alacrity, use:
`alacrity `
To display all the options, use:
`alacrity -h`
Answer some questions interactively, and poof, your package structure is ready.
Based on the [sample Python package](https://github.com/kennethreitz/samplemod) structure by Kenneth Reitz.
## Features
- Customized setup.py file
- Automatic git repository initialization
- Automatic virtual environment setup
- Automatic Sphinx docs initialization
- Easily extensible workflow for custom install steps
## Platforms
- Windows (and Cygwin)
- Linux
- Android (Termux)
## Testing
- To run the built-in tests, run `tox` in the project root
- To add custom testing, edit `tox.ini`
%package help
Summary: Development documents and examples for alacrity
Provides: python3-alacrity-doc
%description help
# Alacrity
[![Release](https://img.shields.io/github/v/release/vishnuvardhan-kumar/alacrity.svg)](https://img.shields.io/github/v/release/vishnuvardhan-kumar/alacrity.svg)
[![Build Status](https://travis-ci.org/vishnuvardhan-kumar/alacrity.svg?branch=master)](https://travis-ci.org/vishnuvardhan-kumar/alacrity)
[![Issues](https://img.shields.io/github/issues/vishnuvardhan-kumar/alacrity.svg)](https://img.shields.io/github/issues/vishnuvardhan-kumar/alacrity.svg)
[![PRs Welcome](https://img.shields.io/badge/PRs-welcome-brightgreen.svg?style=flat-square)](http://makeapullrequest.com)
[![Stars](https://img.shields.io/github/stars/vishnuvardhan-kumar/alacrity.svg?style=social&label=Star)](https://img.shields.io/github/stars/vishnuvardhan-kumar/alacrity?style=social&label=Star)
Quickstart your Python project with a single handy command.
![Screenshot](https://raw.githubusercontent.com/vishnuvardhan-kumar/alacrity/master/alacrity/tests/scr.png)
## Installation
`pip install alacrity`
## Running Alacrity
To run alacrity, use:
`alacrity `
To display all the options, use:
`alacrity -h`
Answer some questions interactively, and poof, your package structure is ready.
Based on the [sample Python package](https://github.com/kennethreitz/samplemod) structure by Kenneth Reitz.
## Features
- Customized setup.py file
- Automatic git repository initialization
- Automatic virtual environment setup
- Automatic Sphinx docs initialization
- Easily extensible workflow for custom install steps
## Platforms
- Windows (and Cygwin)
- Linux
- Android (Termux)
## Testing
- To run the built-in tests, run `tox` in the project root
- To add custom testing, edit `tox.ini`
%prep
%autosetup -n alacrity-1.4.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-alacrity -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon May 29 2023 Python_Bot - 1.4.1-1
- Package Spec generated