%global _empty_manifest_terminate_build 0
Name:		python-django-rest-framework-docs
Version:	0.1.7
Release:	1
Summary:	An inventory tool for Django Rest Framework v2 API
License:	FreeBSD License
URL:		http://github.com/marcgibbons
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/d6/f2/ed989c4c236be7aa28510d7d6c28efda770f15659a39725d9dcf9166cbe6/django-rest-framework-docs-0.1.7.tar.gz
BuildArch:	noarch


%description
Django REST Framework Docs

Rest Framework Docs is an application built to produce an inventory and documentation for your Django Rest Framework v2 endpoints.

Installation
From pip:

pip install django-rest-framework-docs

Docs & details @
https://github.com/marcgibbons/django-rest-framework-docs

%package -n python3-django-rest-framework-docs
Summary:	An inventory tool for Django Rest Framework v2 API
Provides:	python-django-rest-framework-docs
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-django-rest-framework-docs
Django REST Framework Docs

Rest Framework Docs is an application built to produce an inventory and documentation for your Django Rest Framework v2 endpoints.

Installation
From pip:

pip install django-rest-framework-docs

Docs & details @
https://github.com/marcgibbons/django-rest-framework-docs

%package help
Summary:	Development documents and examples for django-rest-framework-docs
Provides:	python3-django-rest-framework-docs-doc
%description help
Django REST Framework Docs

Rest Framework Docs is an application built to produce an inventory and documentation for your Django Rest Framework v2 endpoints.

Installation
From pip:

pip install django-rest-framework-docs

Docs & details @
https://github.com/marcgibbons/django-rest-framework-docs

%prep
%autosetup -n django-rest-framework-docs-0.1.7

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-django-rest-framework-docs -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.7-1
- Package Spec generated