%global _empty_manifest_terminate_build 0
Name:		python-ahapi
Version:	0.1.18
Release:	1
Summary:	Asynchronous HTTP API Server
License:	Apache
URL:		https://github.com/Humbedooh/ahapi
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/79/cd/d0374075510451ef1762f9eb5aad3a4279b21837202b334a2cdaf4f2e43c/ahapi-0.1.18.tar.gz
BuildArch:	noarch

Requires:	python3-aiohttp
Requires:	python3-multipart

%description
This is a simple, asynchronous HTTP API server for serving dynamic content




%package -n python3-ahapi
Summary:	Asynchronous HTTP API Server
Provides:	python-ahapi
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-ahapi
This is a simple, asynchronous HTTP API server for serving dynamic content




%package help
Summary:	Development documents and examples for ahapi
Provides:	python3-ahapi-doc
%description help
This is a simple, asynchronous HTTP API server for serving dynamic content




%prep
%autosetup -n ahapi-0.1.18

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-ahapi -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.18-1
- Package Spec generated